diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:56:48 -0500 |
commit | f9410c080415bce2d6b4ecd7e32655f18650f895 (patch) | |
tree | d8623377aca0370e914120175f3c3c20725b6617 /recipes-bsp/cppi-lld/cppi-lld_git.bb | |
parent | 2801ef9ce5fc3846e61c99e16b39f553e65c632d (diff) | |
download | meta-ti-f9410c080415bce2d6b4ecd7e32655f18650f895.tar.gz |
cppi-lld: Only build binaries relevent to the machine
* Due to this change, the init script is no longer needed
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld/cppi-lld_git.bb')
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld_git.bb | 22 |
1 files changed, 9 insertions, 13 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb index 169e0fcb..edbc35dd 100644 --- a/recipes-bsp/cppi-lld/cppi-lld_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -1,18 +1,10 @@ | |||
1 | DESCRIPTION = "TI CPPI Module low level driver" | 1 | DESCRIPTION = "TI CPPI Module low level driver" |
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | 2 | ||
4 | DEPENDS = "common-csl-ip rm-lld qmss-lld" | 3 | DEPENDS = "common-csl-ip rm-lld qmss-lld" |
5 | 4 | ||
6 | include cppi-lld.inc | 5 | include cppi-lld.inc |
7 | 6 | ||
8 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
9 | |||
10 | SRC_URI += "file://init_cppi.sh" | ||
11 | |||
12 | inherit update-rc.d | ||
13 | |||
14 | INITSCRIPT_NAME = "init_cppi.sh" | ||
15 | INITSCRIPT_PARAMS = "defaults 10" | ||
16 | 8 | ||
17 | do_compile () { | 9 | do_compile () { |
18 | # Now build the lld in the updated directory | 10 | # Now build the lld in the updated directory |
@@ -25,11 +17,15 @@ do_compile () { | |||
25 | 17 | ||
26 | do_install () { | 18 | do_install () { |
27 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
20 | |||
28 | # Set the generic device library symbolic link to default k2h | 21 | # Set the generic device library symbolic link to default k2h |
29 | cd ${D}${libdir} | 22 | cd ${D}${libdir} |
30 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | 23 | |
24 | # Link only the first device in the list | ||
25 | for device in ${DEVICELIST} | ||
26 | do | ||
27 | ln -sf libcppi_${device}.so.1.0.0 libcppi_device.so.1 | ||
28 | break | ||
29 | done | ||
31 | ln -sf libcppi_device.so.1 libcppi_device.so | 30 | ln -sf libcppi_device.so.1 libcppi_device.so |
32 | # Copy init scripts | ||
33 | install -d ${D}${sysconfdir}/init.d/ | ||
34 | install -c -m 755 ${WORKDIR}/init_cppi.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
35 | } | 31 | } |