summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/common-csl-ip
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-11-04 01:47:08 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-04 09:56:35 -0500
commit6042df4426cd1aebe3462f34ed82185983ed0449 (patch)
tree2f64a50b2521743a728148313670d85171d33476 /recipes-bsp/common-csl-ip
parent51cf2fad408c71f78b17441266ccc3b0f24cadf9 (diff)
downloadmeta-ti-6042df4426cd1aebe3462f34ed82185983ed0449.tar.gz
common-csl-ip: Clean up recipes
* Use INC_PR to track recipe revisions * Define variables for GIT SRC_URI parameters Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/common-csl-ip')
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb6
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip.inc19
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip_git.bb4
3 files changed, 18 insertions, 11 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
index c1fb5665..f8dc1baa 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
+++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
@@ -1,13 +1,13 @@
1require common-csl-ip.inc 1require common-csl-ip.inc
2 2
3PR = "${INC_PR}.0"
4
3require recipes-ti/includes/ti-paths.inc 5require recipes-ti/includes/ti-paths.inc
4require recipes-ti/includes/ti-staging.inc 6require recipes-ti/includes/ti-staging.inc
5 7
6PR = "r1"
7
8DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios" 8DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios"
9 9
10S = "${WORKDIR}/ti/csl" 10CSL_GIT_DESTSUFFIX = "git/ti/csl"
11 11
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr" 12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr"
13export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" 13export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip.inc b/recipes-bsp/common-csl-ip/common-csl-ip.inc
index 63551658..74abab0c 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip.inc
+++ b/recipes-bsp/common-csl-ip/common-csl-ip.inc
@@ -5,13 +5,22 @@ LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5857833e20836213677fac33f9aded21"
5COMPATIBLE_MACHINE = "keystone|dra7xx" 5COMPATIBLE_MACHINE = "keystone|dra7xx"
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
8BRANCH="master" 8INC_PR = "r4"
9BRANCH_dra7xx = "releases/PROCESSOR-SDK.01.00.00"
10 9
11SRC_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git;protocol=git;branch=${BRANCH};destsuffix=${S}" 10CSL_GIT_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git"
11CSL_GIT_PROTOCOL ="git"
12CSL_GIT_BRANCH = "master"
13CSL_GIT_BRANCH_dra7xx = "releases/PROCESSOR-SDK.01.00.00"
14CSL_GIT_DESTSUFFIX = "git"
12 15
13# commit ID corresponds to DEV.CSL_KEYSTONE2.02.01.01.00A 16# commit ID corresponds to DEV.CSL_KEYSTONE2.02.01.01.00A
14SRCREV = "17bb083f0d5ed4ad6f38c991210a6a8e9aaf9c56" 17CSL_SRCREV = "17bb083f0d5ed4ad6f38c991210a6a8e9aaf9c56"
15 18
16# commit ID corresponds to PROCESSOR-SDK-ALPHA-1 19# commit ID corresponds to PROCESSOR-SDK-ALPHA-1
17SRCREV_dra7xx = "37c5311ddf289f83b1432a9422816722d264bf55" 20CSL_SRCREV_dra7xx = "37c5311ddf289f83b1432a9422816722d264bf55"
21
22BRANCH="${CSL_GIT_BRANCH}"
23SRC_URI = "${CSL_GIT_URI};protocol=${CSL_GIT_PROTOCOL};branch=${BRANCH};destsuffix=${CSL_GIT_DESTSUFFIX}"
24SRCREV = "${CSL_SRCREV}"
25
26S = "${WORKDIR}/${CSL_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
index 8f622a5e..77f78589 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
+++ b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
@@ -1,11 +1,9 @@
1require common-csl-ip.inc 1require common-csl-ip.inc
2 2
3PR = "r3" 3PR = "${INC_PR}.0"
4 4
5ALLOW_EMPTY_${PN} = "1" 5ALLOW_EMPTY_${PN} = "1"
6 6
7S = "${WORKDIR}/git"
8
9do_install () { 7do_install () {
10 install -d ${D}${includedir}/ti/csl 8 install -d ${D}${includedir}/ti/csl
11 find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl 9 find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl