summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/common-csl-ip
diff options
context:
space:
mode:
authorStephen Molfetta <sjmolfetta@ti.com>2018-01-30 01:06:37 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-01-29 19:03:08 -0500
commit7577f46fda5c036fd029335ba50975442645fe15 (patch)
tree116653a507556474558a28d9edb17bb98598d9d3 /recipes-bsp/common-csl-ip
parent07c78b49f8c33cd38026b87bf7254dd1429f1776 (diff)
downloadmeta-ti-7577f46fda5c036fd029335ba50975442645fe15.tar.gz
dra7xx-evm.conf: removing am57xx SOCS from PDK
opencl-monitor does not distinguish between dra7xx and am57xx devices, treating both as the same and attempting to build for am57xx regardless. However, this is dependent on common-csl-ip-rtos, a component of PDK, which in general does handle these devices differently. The definition of am57xx SOCs in the PDK list from omap-15.conf gets inherited by dra7xx-evm.conf, thereby creating a rule that all dra7xx PDK recipes must build am57xx libraries. This results in a dra7xx image which is much larger than necessary, and more severely, creates an artifical dependency link between these two devices and introduces build failures for various PDK recipes. Instead, we now override the PDK SOC definition in dra7xx-evm.conf, and only in the CSL RTOS recipe do we append the am57xx SOCS for dra7xx-evm machine build. This allows for opencl-monitor to build successfully for dra7xx while preventing any other PDK recipes from attempting to build libraries for am57xx devices. This is a workaround that must stay in place until opencl build can properly comprehend am57xx and dra7xx independently, and/or omap-a15 is not implied to be synonymous with am57xx in various recipes. Signed-off-by: Stephen Molfetta <sjmolfetta@ti.com> Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/common-csl-ip')
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
index f4496b96..100d2f4d 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
+++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
@@ -1,5 +1,5 @@
1require common-csl-ip.inc 1require common-csl-ip.inc
2PR = "${INC_PR}.5" 2PR = "${INC_PR}.6"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5COMPATIBLE_MACHINE_append = "|c66x" 5COMPATIBLE_MACHINE_append = "|c66x"
@@ -16,3 +16,6 @@ export DEST_ROOT="${S}"
16 16
17# HTML doc link params 17# HTML doc link params
18PDK_COMP_LINK_TEXT = "CSL-Chip Support Library" 18PDK_COMP_LINK_TEXT = "CSL-Chip Support Library"
19
20# Workaround: dra7xx build requires am57xx CSL libraries for opencl-monitor
21TI_PDK_LIMIT_SOCS_append_dra7xx = " am571x am572x"