summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/common-csl-ip
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-01-27 03:16:42 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-01-27 15:53:53 -0500
commite887c3f2a6166adaf420eb2c5789e468de2633da (patch)
treeba50b230a6c625c39721a1d7859eb2214dae6163 /recipes-bsp/common-csl-ip
parenta83eb9039edea25386d320e7a1403d732930c2fa (diff)
downloadmeta-ti-e887c3f2a6166adaf420eb2c5789e468de2633da.tar.gz
common-csl-ip: Upgrade to version 3.3.0.1B
* Re-implement common-csl-ip-rtos using the ti-pdk class Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/common-csl-ip')
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb43
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip.inc11
-rw-r--r--recipes-bsp/common-csl-ip/common-csl-ip_git.bb6
3 files changed, 25 insertions, 35 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
index f8dc1baa..6f7d3ccc 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
+++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb
@@ -1,36 +1,23 @@
1require common-csl-ip.inc 1require common-csl-ip.inc
2
3PR = "${INC_PR}.0" 2PR = "${INC_PR}.0"
4 3
5require recipes-ti/includes/ti-paths.inc 4inherit ti-pdk
6require recipes-ti/includes/ti-staging.inc
7
8DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios"
9
10CSL_GIT_DESTSUFFIX = "git/ti/csl"
11 5
12export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr" 6DEPENDS_remove = "${PN}"
13export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
14export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages"
15 7
16do_configure() { 8XDCARGS_ti33x = "am335x"
17 sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs 9XDCARGS_ti43x = "am437x"
18 find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \; 10XDCARGS_omap-a15 = "am571x am572x"
19 find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \; 11XDCARGS_k2hk-evm = "k2h k2k"
20 find -name "*.xs" -exec sed -i "/\.chm/d" {} \; 12XDCARGS_k2l-evm = "k2l"
21 find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \; 13XDCARGS_k2e-evm = "k2e"
22}
23 14
24do_compile() { 15do_configure_append() {
25 ${XDC_INSTALL_DIR}/xdc .make 16 # Create empty makefile
26 ${XDC_INSTALL_DIR}/xdc clean 17 # If libraries are supported for this device, then this will be overwritten
27 ${XDC_INSTALL_DIR}/xdc release 18 cat > ${BUILD_DIR}/makefile << __EOF__
28} 19# Nothing to do
20all:
29 21
30do_install () { 22__EOF__
31 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages
32 find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
33} 23}
34
35ALLOW_EMPTY_${PN} = "1"
36FILES_${PN}-dev += "${PDK_INSTALL_DIR_RECIPE}/packages"
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip.inc b/recipes-bsp/common-csl-ip/common-csl-ip.inc
index 74abab0c..c81b0f13 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip.inc
+++ b/recipes-bsp/common-csl-ip/common-csl-ip.inc
@@ -5,19 +5,16 @@ LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5857833e20836213677fac33f9aded21"
5COMPATIBLE_MACHINE = "keystone|dra7xx" 5COMPATIBLE_MACHINE = "keystone|dra7xx"
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
8INC_PR = "r4" 8PV = "3.3.0.1B"
9INC_PR = "r0"
9 10
10CSL_GIT_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git" 11CSL_GIT_URI = "git://git.ti.com/keystone-rtos/common-csl-ip.git"
11CSL_GIT_PROTOCOL ="git" 12CSL_GIT_PROTOCOL ="git"
12CSL_GIT_BRANCH = "master" 13CSL_GIT_BRANCH = "master"
13CSL_GIT_BRANCH_dra7xx = "releases/PROCESSOR-SDK.01.00.00"
14CSL_GIT_DESTSUFFIX = "git" 14CSL_GIT_DESTSUFFIX = "git"
15 15
16# commit ID corresponds to DEV.CSL_KEYSTONE2.02.01.01.00A 16# commit ID corresponds to DEV.CSL_PROCESSOR-SDK.03.03.00.01B
17CSL_SRCREV = "17bb083f0d5ed4ad6f38c991210a6a8e9aaf9c56" 17CSL_SRCREV = "48bb80a8d5919e17528a21be5d3ea6437dfc0425"
18
19# commit ID corresponds to PROCESSOR-SDK-ALPHA-1
20CSL_SRCREV_dra7xx = "37c5311ddf289f83b1432a9422816722d264bf55"
21 18
22BRANCH="${CSL_GIT_BRANCH}" 19BRANCH="${CSL_GIT_BRANCH}"
23SRC_URI = "${CSL_GIT_URI};protocol=${CSL_GIT_PROTOCOL};branch=${BRANCH};destsuffix=${CSL_GIT_DESTSUFFIX}" 20SRC_URI = "${CSL_GIT_URI};protocol=${CSL_GIT_PROTOCOL};branch=${BRANCH};destsuffix=${CSL_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
index 77f78589..9ea87d36 100644
--- a/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
+++ b/recipes-bsp/common-csl-ip/common-csl-ip_git.bb
@@ -4,6 +4,12 @@ PR = "${INC_PR}.0"
4 4
5ALLOW_EMPTY_${PN} = "1" 5ALLOW_EMPTY_${PN} = "1"
6 6
7CLEANBROKEN = "1"
8
9do_compile() {
10 :
11}
12
7do_install () { 13do_install () {
8 install -d ${D}${includedir}/ti/csl 14 install -d ${D}${includedir}/ti/csl
9 find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl 15 find . -name "*.h" -type f | xargs -I {} cp --parents {} ${D}${includedir}/ti/csl