diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-01-27 03:16:42 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-01-27 15:53:53 -0500 |
commit | e887c3f2a6166adaf420eb2c5789e468de2633da (patch) | |
tree | ba50b230a6c625c39721a1d7859eb2214dae6163 /recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | |
parent | a83eb9039edea25386d320e7a1403d732930c2fa (diff) | |
download | meta-ti-e887c3f2a6166adaf420eb2c5789e468de2633da.tar.gz |
common-csl-ip: Upgrade to version 3.3.0.1B
* Re-implement common-csl-ip-rtos using the ti-pdk class
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb')
-rw-r--r-- | recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | 43 |
1 files changed, 15 insertions, 28 deletions
diff --git a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb index f8dc1baa..6f7d3ccc 100644 --- a/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb +++ b/recipes-bsp/common-csl-ip/common-csl-ip-rtos_git.bb | |||
@@ -1,36 +1,23 @@ | |||
1 | require common-csl-ip.inc | 1 | require common-csl-ip.inc |
2 | |||
3 | PR = "${INC_PR}.0" | 2 | PR = "${INC_PR}.0" |
4 | 3 | ||
5 | require recipes-ti/includes/ti-paths.inc | 4 | inherit ti-pdk |
6 | require recipes-ti/includes/ti-staging.inc | ||
7 | |||
8 | DEPENDS = "ti-xdctools ti-cgt6x-native ti-sysbios" | ||
9 | |||
10 | CSL_GIT_DESTSUFFIX = "git/ti/csl" | ||
11 | 5 | ||
12 | export C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr" | 6 | DEPENDS_remove = "${PN}" |
13 | export XDCCGROOT="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
14 | export XDCPATH="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages" | ||
15 | 7 | ||
16 | do_configure() { | 8 | XDCARGS_ti33x = "am335x" |
17 | sed -i "s/\ \"\.\\\\\\\\\"\ +//" src/Module.xs | 9 | XDCARGS_ti43x = "am437x" |
18 | find -name "*.xs" -exec sed -i "s/ofd6x\.exe/ofd6x/" {} \; | 10 | XDCARGS_omap-a15 = "am571x am572x" |
19 | find -name "*.xs" -exec sed -i "s/sectti\.exe/sectti/" {} \; | 11 | XDCARGS_k2hk-evm = "k2h k2k" |
20 | find -name "*.xs" -exec sed -i "/\.chm/d" {} \; | 12 | XDCARGS_k2l-evm = "k2l" |
21 | find -name "*.xs" -exec sed -i "s/pasm\_dos/pasm\_linux/" {} \; | 13 | XDCARGS_k2e-evm = "k2e" |
22 | } | ||
23 | 14 | ||
24 | do_compile() { | 15 | do_configure_append() { |
25 | ${XDC_INSTALL_DIR}/xdc .make | 16 | # Create empty makefile |
26 | ${XDC_INSTALL_DIR}/xdc clean | 17 | # If libraries are supported for this device, then this will be overwritten |
27 | ${XDC_INSTALL_DIR}/xdc release | 18 | cat > ${BUILD_DIR}/makefile << __EOF__ |
28 | } | 19 | # Nothing to do |
20 | all: | ||
29 | 21 | ||
30 | do_install () { | 22 | __EOF__ |
31 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages | ||
32 | find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; | ||
33 | } | 23 | } |
34 | |||
35 | ALLOW_EMPTY_${PN} = "1" | ||
36 | FILES_${PN}-dev += "${PDK_INSTALL_DIR_RECIPE}/packages" | ||