summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cmem
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2013-12-18 18:54:39 -0500
committerDenys Dmytriyenko <denys@ti.com>2014-01-27 16:21:20 -0500
commitb17cf2d6f1d9107eff707b1f88a8f7bc1a5d2aab (patch)
tree5b1e5ad58e707c8e596f3ca5c1e85ba31d25de2c /recipes-bsp/cmem
parent02410a889eab52f3018077a5ca77820ac379474a (diff)
downloadmeta-ti-b17cf2d6f1d9107eff707b1f88a8f7bc1a5d2aab.tar.gz
cmem: adding new recipe for cmem
cmem module provides user space contiguous memory allocation Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cmem')
-rw-r--r--recipes-bsp/cmem/cmem-mod_git.bb12
-rw-r--r--recipes-bsp/cmem/cmem.inc12
-rw-r--r--recipes-bsp/cmem/cmem_git.bb13
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb
new file mode 100644
index 00000000..2bdf9c00
--- /dev/null
+++ b/recipes-bsp/cmem/cmem-mod_git.bb
@@ -0,0 +1,12 @@
1DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
2
3include cmem.inc
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
7PR = "${MACHINE_KERNEL_PR}"
8
9inherit module
10
11EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_PREFIX="${TOOLCHAIN_PREFIX}" EXEC_DIR="${D}/lib/modules/${KERNEL_VERSION}/extra"'
12MAKE_TARGETS = "module"
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc
new file mode 100644
index 00000000..79278398
--- /dev/null
+++ b/recipes-bsp/cmem/cmem.inc
@@ -0,0 +1,12 @@
1HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:CMEM"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://include/ti/cmem.h;beginline=1;endline=30;md5=b86138d4028fb8310b3b983024edc620"
5
6BRANCH ?= "master"
7# This corresponds to version 4.00.01.08
8SRCREV = "0b68dfe9f155a1978cdb2178e052dc0d6f1e705b"
9
10SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}"
11
12S = "${WORKDIR}/git"
diff --git a/recipes-bsp/cmem/cmem_git.bb b/recipes-bsp/cmem/cmem_git.bb
new file mode 100644
index 00000000..b633d74a
--- /dev/null
+++ b/recipes-bsp/cmem/cmem_git.bb
@@ -0,0 +1,13 @@
1DESCRIPTION = "The cmem component supports contiguous memory allocation from userspace"
2
3include cmem.inc
4
5RDEPENDS_${PN} = "cmem-mod"
6
7PR = "r0+gitr${SRCPV}"
8
9PACKAGES =+ "${PN}-test"
10
11FILES_${PN}-test = "${bindir}/*"
12
13inherit autotools