summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cm3-pm-firmware
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-07-29 23:11:26 -0400
committerDenys Dmytriyenko <denys@ti.com>2015-07-30 11:25:22 -0400
commit5648801d02487560a577a7f1fd0eb3d185d5043e (patch)
tree2153a44f8c0c03935568c89fbc1785bb716b840b /recipes-bsp/cm3-pm-firmware
parent519abe696a1dccb8f1c5221f5b1893cf6e653569 (diff)
downloadmeta-ti-5648801d02487560a577a7f1fd0eb3d185d5043e.tar.gz
am33x-cm3: move into cm3-pm-firmware folder
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cm3-pm-firmware')
-rw-r--r--recipes-bsp/cm3-pm-firmware/am33x-cm3_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/am33x-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/am33x-cm3_git.bb
new file mode 100644
index 00000000..7e636ee8
--- /dev/null
+++ b/recipes-bsp/cm3-pm-firmware/am33x-cm3_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Cortex-M3 binary blob for suspend-resume"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://License.txt;md5=7bdc54a749ab7a7dea999d25d99a41b8"
5
6PV = "1.9.0"
7PR = "r0"
8PE = "1"
9
10SRCREV = "d85e6a17da1025adac9ab7f97dd7aa2a58c517ce"
11BRANCH ?= "ti-v3.14.y"
12
13SRC_URI = "git://git.ti.com/ti-cm3-pm-firmware/amx3-cm3.git;protocol=git;branch=${BRANCH}"
14
15S = "${WORKDIR}/git"
16
17FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
18
19do_compile() {
20 make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}"
21}
22
23do_install() {
24 install -d ${D}${base_libdir}/firmware
25 install -m 0644 bin/am335x-pm-firmware.elf ${D}${base_libdir}/firmware/
26 install -m 0644 bin/*-scale-data.bin ${D}${base_libdir}/firmware/
27}
28
29FILES_${PN} += "${base_libdir}/firmware"