summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cm3-pm-firmware
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-07-30 09:15:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-07-30 11:25:25 -0400
commit650aff73de019af5aba0ccc10b15c4df1b60312a (patch)
treed22f5e06c966f184a1b62aac2bf0a362a21848d1 /recipes-bsp/cm3-pm-firmware
parent5648801d02487560a577a7f1fd0eb3d185d5043e (diff)
downloadmeta-ti-650aff73de019af5aba0ccc10b15c4df1b60312a.tar.gz
amx3-cm3: add new PM firmware for 4.1 kernel
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cm3-pm-firmware')
-rw-r--r--recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
new file mode 100644
index 00000000..d3225303
--- /dev/null
+++ b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Cortex-M3 binary blob for suspend-resume"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://License.txt;md5=7bdc54a749ab7a7dea999d25d99a41b8"
5
6PV = "1.9.1"
7PR = "r0"
8
9SRCREV = "277eef8611e260a5d73a9e3773fff8f767fe2b01"
10BRANCH ?= "next-upstream"
11
12SRC_URI = "git://git.ti.com/ti-cm3-pm-firmware/amx3-cm3.git;protocol=git;branch=${BRANCH}"
13
14S = "${WORKDIR}/git"
15
16FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
17
18do_compile() {
19 make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}"
20}
21
22do_install() {
23 install -d ${D}${base_libdir}/firmware
24 install -m 0644 bin/am335x-pm-firmware.elf ${D}${base_libdir}/firmware/
25 install -m 0644 bin/*-scale-data.bin ${D}${base_libdir}/firmware/
26}
27
28FILES_${PN} += "${base_libdir}/firmware"