summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-monitor
diff options
context:
space:
mode:
authorMurali Karicheri <m-karicheri2@ti.com>2013-01-18 18:15:21 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-01-28 18:51:00 -0500
commit1920403ef28a61aabceee22f4472bb98ffe48f5d (patch)
tree83de74b4ea6de8761a57890deaf54a4d64f19e55 /recipes-bsp/boot-monitor
parent9daa29790ddd699642c1689bc2cf7c77d18ed372 (diff)
downloadmeta-ti-1920403ef28a61aabceee22f4472bb98ffe48f5d.tar.gz
keystone: boot-monitor: add initial recipe
This adds recipe to build boot monitor image. Boot monitor is a standalone image that is loaded and executed from u-boot to replace the RBL provided monitor code in ARM with Linux boot specific code. Signed-off-by: Murali Karicheri <m-karicheri2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/boot-monitor')
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
new file mode 100644
index 00000000..dc4d71e7
--- /dev/null
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Boot Monitor - TI ARM Boot monitor code"
2EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
3
4LICENSE = "BSD"
5
6BOOT_MONITOR_BINARY ?= "skern.bin"
7BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
8BOOT_MONITOR_MAKE_TARGET ?= "all"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=b676661788f8c0f8cdeafd2a39467cae"
11
12COMPATIBLE_MACHINE = "keystone-evm"
13
14SRC_URI = "git://gtgit01.gt.design.ti.com/git/projects/boot-monitor.git;protocol=git;branch=${BRANCH}"
15
16PV = "1.0"
17PR = "r0+gitr${SRCPV}"
18
19BRANCH = "master"
20
21S = "${WORKDIR}/git"
22
23SRCREV = "b8014b69e8c7e981e8bc3e067a9d990e2bb603ba"
24
25do_compile () {
26 unset LDFLAGS
27 unset CFLAGS
28 unset CPPFLAGS
29 oe_runmake ${BOOT_MONITOR_MAKE_TARGET}
30}
31
32inherit deploy
33
34addtask deploy before do_build after do_compile
35
36do_deploy () {
37 install -d ${DEPLOYDIR}
38 install ${S}/${BOOT_MONITOR_BINARY} ${DEPLOYDIR}/${BOOT_MONITOR_IMAGE}
39}