diff options
author | Denys Dmytriyenko <denys@ti.com> | 2014-10-08 04:25:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-10-07 18:44:36 -0400 |
commit | 3070224598c3a0cf0fcdfdfd7adaccbb9a920296 (patch) | |
tree | d61c8b2743b2450adac96ae26135856bb1019a17 /recipes-bsp/boot-monitor | |
parent | fe53dc3cbd322cf6db3edf2eeb2ba72263b0ea36 (diff) | |
download | meta-ti-3070224598c3a0cf0fcdfdfd7adaccbb9a920296.tar.gz |
boot-monitor: pass float ABI flag to fix gcc-4.9.1 issue with stubs
Otherwise fails with the below error, similar to am33x-cm3:
fatal error: gnu/stubs-soft.h: No such file or directory
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/boot-monitor')
-rw-r--r-- | recipes-bsp/boot-monitor/boot-monitor_git.bb | 13 |
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb index 6e682138..6967be72 100644 --- a/recipes-bsp/boot-monitor/boot-monitor_git.bb +++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb | |||
@@ -1,11 +1,5 @@ | |||
1 | DESCRIPTION = "Boot Monitor - TI ARM Boot monitor code" | 1 | DESCRIPTION = "Boot Monitor - TI ARM Boot monitor code" |
2 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" | ||
3 | |||
4 | LICENSE = "BSD" | 2 | LICENSE = "BSD" |
5 | |||
6 | BOOT_MONITOR_BINARY ?= "skern.bin" | ||
7 | BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=25fe219a6febf6e5bb45beda1b2eb315" |
10 | 4 | ||
11 | COMPATIBLE_MACHINE = "keystone" | 5 | COMPATIBLE_MACHINE = "keystone" |
@@ -22,6 +16,13 @@ S = "${WORKDIR}/git" | |||
22 | #Tag "K2_BM_14.05" | 16 | #Tag "K2_BM_14.05" |
23 | SRCREV = "0e3ffe1ea4a0cee38ae2406901b7cf4d5324b5e9" | 17 | SRCREV = "0e3ffe1ea4a0cee38ae2406901b7cf4d5324b5e9" |
24 | 18 | ||
19 | BOOT_MONITOR_BINARY ?= "skern.bin" | ||
20 | BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin" | ||
21 | |||
22 | FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" | ||
23 | |||
24 | EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}"" | ||
25 | |||
25 | do_compile () { | 26 | do_compile () { |
26 | unset LDFLAGS | 27 | unset LDFLAGS |
27 | unset CFLAGS | 28 | unset CFLAGS |