diff options
author | Denys Dmytriyenko <denys@ti.com> | 2019-02-28 07:06:08 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-02-28 01:02:24 +0000 |
commit | 4905be9164889cde6e73b022724192cb21beb1bc (patch) | |
tree | ad09eb1e46feed8eed8df095e7a295044d6cb7d9 /recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb | |
parent | 72051b974fbeb3e6c714a379b0b3fcb6fefa71c8 (diff) | |
download | meta-ti-4905be9164889cde6e73b022724192cb21beb1bc.tar.gz |
arm-trusted-firmware: update to latest snapshot based on 2.0
Upstream has changed copyright guidelines, no actual license change:
| Copyright guidance has been changed for migration of the
| ARM run project to trustedfirmware.org where the project
| governance is different.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb')
-rw-r--r-- | recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb | 63 |
1 files changed, 0 insertions, 63 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb deleted file mode 100644 index fdbf8f14..00000000 --- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_1.5.bb +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | SUMMARY = "ARM Trusted Firmware" | ||
2 | DESCRIPTION = "ARM Trusted Firmware provides a reference implementation of \ | ||
3 | Secure World software for ARMv8-A, including Exception Level 3 (EL3) software. \ | ||
4 | It provides implementations of various ARM interface standards such as the \ | ||
5 | Power State Coordination Interface (PSCI), Trusted Board Boot Requirements \ | ||
6 | (TBBR) and Secure monitor code." | ||
7 | HOMEPAGE = "http://infocenter.arm.com/help/topic/com.arm.doc.dui0928e/CJHIDGJF.html" | ||
8 | |||
9 | LICENSE = "BSD" | ||
10 | LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443" | ||
11 | |||
12 | inherit deploy | ||
13 | |||
14 | DEPENDS += "dtc-native" | ||
15 | |||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | PV_append = "+git${SRCPV}" | ||
21 | |||
22 | BRANCH = "ti-atf" | ||
23 | SRC_URI = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH}" | ||
24 | |||
25 | SRCREV ?= "d7b4c6e1fdb4553fc23a02776bca111bdcdf6b9f" | ||
26 | |||
27 | # Make ATF "aware" of OPTEE, no build dependency | ||
28 | PACKAGECONFIG[optee] = "SPD=opteed" | ||
29 | |||
30 | COMPATIBLE_MACHINE = "k3" | ||
31 | ATFPLATFORM_k3 = "k3" | ||
32 | ATFBOARD_k3 = "generic" | ||
33 | |||
34 | PACKAGECONFIG_k3 = "optee" | ||
35 | |||
36 | CFLAGS[unexport] = "1" | ||
37 | LDFLAGS[unexport] = "1" | ||
38 | AS[unexport] = "1" | ||
39 | LD[unexport] = "1" | ||
40 | |||
41 | do_configure[noexec] = "1" | ||
42 | |||
43 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" PLAT="${ATFPLATFORM}" TARGET_BOARD="${ATFBOARD}" ${PACKAGECONFIG_CONFARGS}' | ||
44 | |||
45 | do_compile() { | ||
46 | oe_runmake all | ||
47 | } | ||
48 | |||
49 | do_install() { | ||
50 | install -d ${D}/boot | ||
51 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${D}/boot/ | ||
52 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31/bl31.elf ${D}/boot/ | ||
53 | } | ||
54 | |||
55 | do_deploy() { | ||
56 | install -d ${DEPLOYDIR} | ||
57 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31.bin ${DEPLOYDIR}/ | ||
58 | install -m 0644 ${S}/build/${ATFPLATFORM}/${ATFBOARD}/release/bl31/bl31.elf ${DEPLOYDIR}/ | ||
59 | } | ||
60 | addtask deploy before do_build after do_compile | ||
61 | |||
62 | FILES_${PN} = "/boot" | ||
63 | SYSROOT_DIRS += "/boot" | ||