diff options
author | Denys Dmytriyenko <denys@ti.com> | 2014-08-13 02:03:49 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-08-12 17:52:39 -0400 |
commit | dca184c6791df0195d5d0b927767296be684c3fe (patch) | |
tree | 703410e35b1673d0457bf3e487476c4b01de0b81 /recipes-bsp/am33x-cm3 | |
parent | 20c7907504b69df3a9f1e7226e4a14950637573e (diff) | |
download | meta-ti-dca184c6791df0195d5d0b927767296be684c3fe.tar.gz |
am33x-cm3: update with version 1.8.7
* Move repo to git.ti.com
* Bump PE due to versioning schema change
* Drop init scripts needed back in 3.8 days
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/am33x-cm3')
-rw-r--r-- | recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3 | 6 | ||||
-rw-r--r-- | recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3 | 6 | ||||
-rw-r--r-- | recipes-bsp/am33x-cm3/am33x-cm3_git.bb | 43 |
3 files changed, 7 insertions, 48 deletions
diff --git a/recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3 b/recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3 deleted file mode 100644 index 56c17b33..00000000 --- a/recipes-bsp/am33x-cm3/am33x-cm3/init-am33x-cm3 +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # Load the PM CM3 firmware | ||
4 | echo 1 > /sys/devices/ocp.2/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading | ||
5 | cat /lib/firmware/am335x-pm-firmware.bin > /sys/devices/ocp.2/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/data | ||
6 | echo 0 > /sys/devices/ocp.2/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading | ||
diff --git a/recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3 b/recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3 deleted file mode 100644 index 0a75c1fd..00000000 --- a/recipes-bsp/am33x-cm3/am33x-cm3/init-am43x-cm3 +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # Load the PM CM3 firmware | ||
4 | echo 1 > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading | ||
5 | cat /lib/firmware/am335x-pm-firmware.bin > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/data | ||
6 | echo 0 > /sys/devices/44000000.ocp/44d00000.wkup_m3/firmware/am335x-pm-firmware.bin/loading | ||
diff --git a/recipes-bsp/am33x-cm3/am33x-cm3_git.bb b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb index 42f20da4..51ec9bdd 100644 --- a/recipes-bsp/am33x-cm3/am33x-cm3_git.bb +++ b/recipes-bsp/am33x-cm3/am33x-cm3_git.bb | |||
@@ -3,35 +3,14 @@ DESCRIPTION = "Cortex-M3 binary blob for suspend-resume" | |||
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://License.txt;md5=7bdc54a749ab7a7dea999d25d99a41b8" | 4 | LIC_FILES_CHKSUM = "file://License.txt;md5=7bdc54a749ab7a7dea999d25d99a41b8" |
5 | 5 | ||
6 | PV = "05.00.00.03" | 6 | PV = "1.8.7" |
7 | PR = "r1" | 7 | PR = "r0" |
8 | PE = "1" | ||
8 | 9 | ||
9 | # Make package machine specific due to different init scripts | 10 | SRCREV = "fb0117edd5810a8d3bd9b1cd8abe34e12ff2d0ba" |
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 11 | BRANCH ?= "next" |
11 | 12 | ||
12 | # SRCREV corresponds to tag v05.00.00.03 | 13 | SRC_URI = "git://git.ti.com/ti-cm3-pm-firmware/amx3-cm3.git;protocol=git;branch=${BRANCH}" |
13 | SRCREV = "a0ddffb63147e2079a08944c0e399c75538201a9" | ||
14 | BRANCH ?= "master" | ||
15 | |||
16 | # This init script is only used for older kernels that do not support | ||
17 | # hotplug of the firmware. Newer kernels do not require the initscript | ||
18 | # package. | ||
19 | INITSCRIPT_NAME = "am335x-pm-firmware-load" | ||
20 | INITSCRIPT_PARAMS = "defaults 96" | ||
21 | |||
22 | inherit update-rc.d | ||
23 | |||
24 | UPDATERCPN = "${PN}-initscript" | ||
25 | |||
26 | RDEPENDS_${PN}-initscript = "am33x-cm3" | ||
27 | |||
28 | SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \ | ||
29 | file://init-am33x-cm3 \ | ||
30 | file://init-am43x-cm3 \ | ||
31 | " | ||
32 | |||
33 | SCRIPT_ti33x = "init-am33x-cm3" | ||
34 | SCRIPT_ti43x = "init-am43x-cm3" | ||
35 | 14 | ||
36 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
37 | 16 | ||
@@ -41,15 +20,7 @@ do_compile() { | |||
41 | 20 | ||
42 | do_install() { | 21 | do_install() { |
43 | install -d ${D}${base_libdir}/firmware | 22 | install -d ${D}${base_libdir}/firmware |
44 | install -m 0644 bin/am335x-pm-firmware.bin ${D}${base_libdir}/firmware/ | 23 | install -m 0644 bin/am335x-pm-firmware.elf ${D}${base_libdir}/firmware/ |
45 | |||
46 | # Install the init script to load the PM firmware at boot | ||
47 | install -d ${D}${sysconfdir}/init.d | ||
48 | install -m 0755 ${WORKDIR}/${SCRIPT} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
49 | } | 24 | } |
50 | 25 | ||
51 | PACKAGES =+ "${PN}-initscript" | ||
52 | |||
53 | FILES_${PN} += "${base_libdir}/firmware" | 26 | FILES_${PN} += "${base_libdir}/firmware" |
54 | |||
55 | FILES_${PN}-initscript = "${sysconfdir}/*" | ||