diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:07 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:56:28 -0500 |
commit | 51cf2fad408c71f78b17441266ccc3b0f24cadf9 (patch) | |
tree | 95e8e4904c77a173520a7a5801da66be06800be8 /recipes-bsp/aif2-lld | |
parent | 88b45cf17553663dc3a8a56a170ca702bb885cb1 (diff) | |
download | meta-ti-51cf2fad408c71f78b17441266ccc3b0f24cadf9.tar.gz |
aif2-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/aif2-lld')
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld-test_git.bb | 2 | ||||
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld.inc | 17 | ||||
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld_git.bb | 2 |
3 files changed, 17 insertions, 4 deletions
diff --git a/recipes-bsp/aif2-lld/aif2-lld-test_git.bb b/recipes-bsp/aif2-lld/aif2-lld-test_git.bb index 2a9de433..9180b953 100755 --- a/recipes-bsp/aif2-lld/aif2-lld-test_git.bb +++ b/recipes-bsp/aif2-lld/aif2-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip aif2-lld qmss-lld cppi-lld" | |||
4 | 4 | ||
5 | include aif2-lld.inc | 5 | include aif2-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} AIF2_SRC_DIR=${WORKDIR}/git" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} AIF2_SRC_DIR=${WORKDIR}/git" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |
diff --git a/recipes-bsp/aif2-lld/aif2-lld.inc b/recipes-bsp/aif2-lld/aif2-lld.inc index 212813c2..cd1e1695 100755 --- a/recipes-bsp/aif2-lld/aif2-lld.inc +++ b/recipes-bsp/aif2-lld/aif2-lld.inc | |||
@@ -1,13 +1,22 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | 2 | ||
3 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" | 3 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" |
4 | BRANCH = "master" | 4 | |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/aif2-lld.git;destsuffix=git/ti/drv/aif2;protocol=git;branch=${BRANCH}" | 5 | AIF2_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/aif2-lld.git" |
6 | AIF2_LLD_GIT_PROTOCOL = "git" | ||
7 | AIF2_LLD_GIT_BRANCH = "master" | ||
8 | AIF2_LLD_GIT_DESTSUFFIX = "git/ti/drv/aif2" | ||
9 | |||
6 | # The following commit correspond to DEV.AIF2LLD.01.02.00.00A | 10 | # The following commit correspond to DEV.AIF2LLD.01.02.00.00A |
7 | SRCREV = "7f394ec9975cd4cef982b11763c882c4c763ddce" | 11 | AIF2_LLD_SRCREV = "7f394ec9975cd4cef982b11763c882c4c763ddce" |
12 | |||
13 | BRANCH = "${AIF2_LLD_GIT_BRANCH}" | ||
14 | SRC_URI = "${AIF2_LLD_GIT_URI};destsuffix=${AIF2_LLD_GIT_DESTSUFFIX};protocol=${AIF2_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
15 | SRCREV = "${AIF2_LLD_SRCREV}" | ||
8 | 16 | ||
9 | PV = "1.2.0.0" | 17 | PV = "1.2.0.0" |
18 | INC_PR = "r1" | ||
10 | 19 | ||
11 | COMPATIBLE_MACHINE = "k2hk-evm" | 20 | COMPATIBLE_MACHINE = "k2hk-evm" |
12 | 21 | ||
13 | S = "${WORKDIR}/git/ti/drv/aif2" | 22 | S = "${WORKDIR}/${AIF2_LLD_GIT_DESTSUFFIX}" |
diff --git a/recipes-bsp/aif2-lld/aif2-lld_git.bb b/recipes-bsp/aif2-lld/aif2-lld_git.bb index f6e95c28..f310b17b 100755 --- a/recipes-bsp/aif2-lld/aif2-lld_git.bb +++ b/recipes-bsp/aif2-lld/aif2-lld_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip qmss-lld cppi-lld" | |||
4 | 4 | ||
5 | include aif2-lld.inc | 5 | include aif2-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |