diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-10-23 21:08:56 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-23 15:36:06 -0400 |
commit | 51f0cdc888ad5725b08e5d623b39309029f85c3e (patch) | |
tree | 82ce1271e405d02e3846a99a88ece49b57e196d3 /recipes-bsp/aif2-lld | |
parent | b948c9010a109e3bd6e5d7dd5aef6c757465fb43 (diff) | |
download | meta-ti-51f0cdc888ad5725b08e5d623b39309029f85c3e.tar.gz |
aif2-lld: Add low level driver package for keystone2 antenna interface
- Provides low level driver and test binaries for keystone2 antenna
interface peripheral
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/aif2-lld')
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld-test_git.bb | 16 | ||||
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld.inc | 13 | ||||
-rwxr-xr-x | recipes-bsp/aif2-lld/aif2-lld_git.bb | 15 |
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes-bsp/aif2-lld/aif2-lld-test_git.bb b/recipes-bsp/aif2-lld/aif2-lld-test_git.bb new file mode 100755 index 00000000..2a9de433 --- /dev/null +++ b/recipes-bsp/aif2-lld/aif2-lld-test_git.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "TI Antenna Interface peripheral module low level driver test binaries" | ||
2 | |||
3 | DEPENDS = "common-csl-ip aif2-lld qmss-lld cppi-lld" | ||
4 | |||
5 | include aif2-lld.inc | ||
6 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} AIF2_SRC_DIR=${WORKDIR}/git" | ||
8 | |||
9 | do_compile () { | ||
10 | oe_runmake clean DEVICE=k2hk | ||
11 | oe_runmake tests DEVICE=k2hk | ||
12 | } | ||
13 | |||
14 | do_install () { | ||
15 | oe_runmake installbin DEVICE=k2hk AIF2_SRC_DIR=${WORKDIR}/git INSTALL_BIN_BASE_DIR=${D}/${bindir} | ||
16 | } | ||
diff --git a/recipes-bsp/aif2-lld/aif2-lld.inc b/recipes-bsp/aif2-lld/aif2-lld.inc new file mode 100755 index 00000000..212813c2 --- /dev/null +++ b/recipes-bsp/aif2-lld/aif2-lld.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" | ||
4 | BRANCH = "master" | ||
5 | SRC_URI = "git://git.ti.com/keystone-rtos/aif2-lld.git;destsuffix=git/ti/drv/aif2;protocol=git;branch=${BRANCH}" | ||
6 | # The following commit correspond to DEV.AIF2LLD.01.02.00.00A | ||
7 | SRCREV = "7f394ec9975cd4cef982b11763c882c4c763ddce" | ||
8 | |||
9 | PV = "1.2.0.0" | ||
10 | |||
11 | COMPATIBLE_MACHINE = "k2hk-evm" | ||
12 | |||
13 | S = "${WORKDIR}/git/ti/drv/aif2" | ||
diff --git a/recipes-bsp/aif2-lld/aif2-lld_git.bb b/recipes-bsp/aif2-lld/aif2-lld_git.bb new file mode 100755 index 00000000..f6e95c28 --- /dev/null +++ b/recipes-bsp/aif2-lld/aif2-lld_git.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Antenna Interface low level driver" | ||
2 | |||
3 | DEPENDS = "common-csl-ip qmss-lld cppi-lld" | ||
4 | |||
5 | include aif2-lld.inc | ||
6 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | ||
8 | |||
9 | do_compile () { | ||
10 | oe_runmake lib DEVICE=k2hk | ||
11 | } | ||
12 | |||
13 | do_install () { | ||
14 | oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
15 | } | ||