summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-01-20 01:40:46 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-24 12:51:24 -0600
commitf5653ce0ae0675449315a3350859f8fc2c93f530 (patch)
tree62ab1d6cd6070d51da60257866b14ae32399e406 /meta-ti-extras
parent7cd8114bb0f646225fd4cafc3c699a73caa6dc0e (diff)
downloadmeta-ti-f5653ce0ae0675449315a3350859f8fc2c93f530.tar.gz
conf: machine: Use new J7 SoC names over specific board names
Now that we have SoC names, we can avoid adding features based on the board name. We expect folks to create their own boards based on these SoCs, and so using the TI made EVM board name everywhere adds extra churn when adding a new board. Plus it is more correct for most of these features as they depend on the SoC, not on the EVM board. One other thing we do here is to not use the generic "j7" name, the current and future J7 devices are far to feature diverse to group at this level. Grouping like that will lead to the wrong things getting enabled as new J7 SoCs are added. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb b/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
index cb2f8cc2..e3b5290a 100644
--- a/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
+++ b/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
@@ -15,7 +15,7 @@ PR = "r0"
15 15
16require recipes-ti/includes/ti-paths.inc 16require recipes-ti/includes/ti-paths.inc
17 17
18COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3" 18COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am62xx|am64xx|am65xx|j721e"
19PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"
20 20
21PACKAGES:prepend = " \ 21PACKAGES:prepend = " \
@@ -43,7 +43,7 @@ PLATFORM:omap-a15 = "am572x"
43PLATFORM:am62xx = "am62x" 43PLATFORM:am62xx = "am62x"
44PLATFORM:am64xx = "am64x" 44PLATFORM:am64xx = "am64x"
45PLATFORM:am65xx = "am65x" 45PLATFORM:am65xx = "am65x"
46PLATFORM:j7 = "j721e" 46PLATFORM:j721e = "j721e"
47 47
48do_compile() { 48do_compile() {
49 for dir in ${SUBDIRS} 49 for dir in ${SUBDIRS}
@@ -155,7 +155,7 @@ do_install:append:am65xx() {
155 done 155 done
156} 156}
157 157
158do_install:append:j7() { 158do_install:append:j721e() {
159 for i in 0 1 159 for i in 0 1
160 do 160 do
161 install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \ 161 install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \
@@ -189,7 +189,7 @@ PRU_ICSS_ALTERNATIVES:omap-a15 = "am57xx-pru1_0-fw am57xx-pru1_1-fw am57xx-pru2_
189PRU_ICSS_ALTERNATIVES:am62xx = "am62x-pru0-fw am62x-pru1-fw" 189PRU_ICSS_ALTERNATIVES:am62xx = "am62x-pru0-fw am62x-pru1-fw"
190PRU_ICSS_ALTERNATIVES:am64xx = "am64x-pru0_0-fw am64x-pru0_1-fw am64x-pru1_0-fw am64x-pru1_1-fw am64x-rtu0_0-fw am64x-rtu0_1-fw am64x-rtu1_0-fw am64x-rtu1_1-fw" 190PRU_ICSS_ALTERNATIVES:am64xx = "am64x-pru0_0-fw am64x-pru0_1-fw am64x-pru1_0-fw am64x-pru1_1-fw am64x-rtu0_0-fw am64x-rtu0_1-fw am64x-rtu1_0-fw am64x-rtu1_1-fw"
191PRU_ICSS_ALTERNATIVES:am65xx = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw" 191PRU_ICSS_ALTERNATIVES:am65xx = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw"
192PRU_ICSS_ALTERNATIVES:j7 = "j7-pru0_0-fw j7-pru0_1-fw j7-pru1_0-fw j7-pru1_1-fw j7-rtu0_0-fw j7-rtu0_1-fw j7-rtu1_0-fw j7-rtu1_1-fw" 192PRU_ICSS_ALTERNATIVES:j721e = "j7-pru0_0-fw j7-pru0_1-fw j7-pru1_0-fw j7-pru1_1-fw j7-rtu0_0-fw j7-rtu0_1-fw j7-rtu1_0-fw j7-rtu1_1-fw"
193 193
194# Set up link names for the firmwares 194# Set up link names for the firmwares
195ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/am335x-pru0-fw" 195ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/am335x-pru0-fw"
@@ -259,7 +259,7 @@ ALTERNATIVE:pru-icss-halt = "${PRU_ICSS_ALTERNATIVES}"
259# Only Halt firmware images are supported for the Tx_PRU cores 259# Only Halt firmware images are supported for the Tx_PRU cores
260ALTERNATIVE:pru-icss-halt:append:am64xx = " am64x-txpru0_0-fw am64x-txpru0_1-fw am64x-txpru1_0-fw am64x-txpru1_1-fw" 260ALTERNATIVE:pru-icss-halt:append:am64xx = " am64x-txpru0_0-fw am64x-txpru0_1-fw am64x-txpru1_0-fw am64x-txpru1_1-fw"
261ALTERNATIVE:pru-icss-halt:append:am65xx = " am65x-txpru0_0-fw am65x-txpru0_1-fw am65x-txpru1_0-fw am65x-txpru1_1-fw am65x-txpru2_0-fw am65x-txpru2_1-fw" 261ALTERNATIVE:pru-icss-halt:append:am65xx = " am65x-txpru0_0-fw am65x-txpru0_1-fw am65x-txpru1_0-fw am65x-txpru1_1-fw am65x-txpru2_0-fw am65x-txpru2_1-fw"
262ALTERNATIVE:pru-icss-halt:append:j7 = " j7-txpru0_0-fw j7-txpru0_1-fw j7-txpru1_0-fw j7-txpru1_1-fw" 262ALTERNATIVE:pru-icss-halt:append:j721e = " j7-txpru0_0-fw j7-txpru0_1-fw j7-txpru1_0-fw j7-txpru1_1-fw"
263 263
264ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out" 264ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out"
265ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru1-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out" 265ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru1-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out"