diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-25 21:41:25 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-03-01 11:54:29 -0600 |
commit | f1b6ff15039c9f0b8e93d70856fb566a16cb099b (patch) | |
tree | 3984069a3e41014e2cdf5287b1cf9853422a5ed2 /meta-ti-extras | |
parent | e98a97691d50030b59a5925b389d90bb276ecbd2 (diff) | |
download | meta-ti-f1b6ff15039c9f0b8e93d70856fb566a16cb099b.tar.gz |
meta-ti: correct and do not skip "installed-vs-shipped" QA check
Skipping "installed-vs-shipped" QA check is now considered bad practice
due to possible SDK issues and is being flagged by yocto-check-layer [1]
script and could affect "Yocto Project Compatible" status for the layer.
[1] https://git.openembedded.org/openembedded-core/commit/?id=e8baa75535fc888f1d768b23a0140475e832c910
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r-- | meta-ti-extras/recipes-devtools/cuia/cuia_1.0.0.13.bb | 5 | ||||
-rw-r--r-- | meta-ti-extras/recipes-ti/vlib/vlib-c66x.inc | 2 | ||||
-rw-r--r-- | meta-ti-extras/recipes-ti/xdais/ti-xdais_6.26.01.03.bb | 2 |
3 files changed, 5 insertions, 4 deletions
diff --git a/meta-ti-extras/recipes-devtools/cuia/cuia_1.0.0.13.bb b/meta-ti-extras/recipes-devtools/cuia/cuia_1.0.0.13.bb index 1cda366d..8b16830f 100644 --- a/meta-ti-extras/recipes-devtools/cuia/cuia_1.0.0.13.bb +++ b/meta-ti-extras/recipes-devtools/cuia/cuia_1.0.0.13.bb | |||
@@ -22,9 +22,12 @@ do_compile () { | |||
22 | do_install() { | 22 | do_install() { |
23 | cd ${S} | 23 | cd ${S} |
24 | oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install | 24 | oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install |
25 | rm -rf ${D}${libdir}/boot.* | ||
26 | rm -rf ${D}${libdir}/gnu.targets.* | ||
27 | rm -rf ${D}${libdir}/syscalls.* | ||
25 | } | 28 | } |
26 | 29 | ||
27 | COMPATIBLE_HOST ?= "null" | 30 | COMPATIBLE_HOST ?= "null" |
28 | COMPATIBLE_HOST:ti-soc = "(.*)" | 31 | COMPATIBLE_HOST:ti-soc = "(.*)" |
29 | 32 | ||
30 | INSANE_SKIP:${PN} += "textrel installed-vs-shipped" | 33 | INSANE_SKIP:${PN} += "textrel" |
diff --git a/meta-ti-extras/recipes-ti/vlib/vlib-c66x.inc b/meta-ti-extras/recipes-ti/vlib/vlib-c66x.inc index 460964b3..6b5e186c 100644 --- a/meta-ti-extras/recipes-ti/vlib/vlib-c66x.inc +++ b/meta-ti-extras/recipes-ti/vlib/vlib-c66x.inc | |||
@@ -29,4 +29,4 @@ FILES:${PN}-dev += "${VLIB_C66_INSTALL_DIR_RECIPE}" | |||
29 | INHIBIT_PACKAGE_STRIP = "1" | 29 | INHIBIT_PACKAGE_STRIP = "1" |
30 | INHIBIT_SYSROOT_STRIP = "1" | 30 | INHIBIT_SYSROOT_STRIP = "1" |
31 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 31 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
32 | INSANE_SKIP:${PN}-dev = "installed-vs-shipped arch" | 32 | INSANE_SKIP:${PN}-dev = "arch" |
diff --git a/meta-ti-extras/recipes-ti/xdais/ti-xdais_6.26.01.03.bb b/meta-ti-extras/recipes-ti/xdais/ti-xdais_6.26.01.03.bb index 9fc4cee1..ee9826e6 100644 --- a/meta-ti-extras/recipes-ti/xdais/ti-xdais_6.26.01.03.bb +++ b/meta-ti-extras/recipes-ti/xdais/ti-xdais_6.26.01.03.bb | |||
@@ -7,5 +7,3 @@ LIC_FILES_CHKSUM = "file://xdais_6_26_01_03_manifest.html;md5=a5a675d49db2f658bb | |||
7 | 7 | ||
8 | SRC_URI[xdaistarball.md5sum] = "9b2bea3408254e737ec0d819a031adf6" | 8 | SRC_URI[xdaistarball.md5sum] = "9b2bea3408254e737ec0d819a031adf6" |
9 | SRC_URI[xdaistarball.sha256sum] = "d7bcbd8bcfe6fdfc5f402e4b125ced6c806dc30bc5296e98d5d43b0b5a237a0d" | 9 | SRC_URI[xdaistarball.sha256sum] = "d7bcbd8bcfe6fdfc5f402e4b125ced6c806dc30bc5296e98d5d43b0b5a237a0d" |
10 | |||
11 | INSANE_SKIP:${PN} = "installed-vs-shipped" | ||