summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-11-04 22:46:16 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-10 08:21:37 -0600
commit6f715d911c65962bd0ae51bb54f3325fe0e6d0d7 (patch)
tree50b51604cac8c26000ff9fe44a012f91485a3fe0 /meta-ti-extras
parent7e9cecaa9f140761039e9c853ccc63513da887af (diff)
downloadmeta-ti-6f715d911c65962bd0ae51bb54f3325fe0e6d0d7.tar.gz
recipies-ti: Add TI K3 Security Development Package
Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r--meta-ti-extras/recipes-ti/includes/ti-paths.inc2
-rw-r--r--meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb36
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/includes/ti-paths.inc b/meta-ti-extras/recipes-ti/includes/ti-paths.inc
index 358d7dfd..5994ff0a 100644
--- a/meta-ti-extras/recipes-ti/includes/ti-paths.inc
+++ b/meta-ti-extras/recipes-ti/includes/ti-paths.inc
@@ -51,6 +51,7 @@ export OMP_INSTALL_DIR_RECIPE = "${installdir}/ti-omp-tree"
51export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree" 51export MPM_INSTALL_DIR_RECIPE = "${installdir}/ti-mpm-tree"
52export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7" 52export TI_CGT6X_7_INSTALL_DIR_RECIPE = "${installdir}/cgt6x-7"
53export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x" 53export TI_CGT7X_INSTALL_DIR_RECIPE = "${installdir}/cgt-c7x"
54export TI_K3_SECDEV_INSTALL_DIR_RECIPE = "${installdir}/ti-k3-secdev"
54 55
55 56
56# This is where the tools will end up in sysroot 57# This is where the tools will end up in sysroot
@@ -100,6 +101,7 @@ export TI_CGT6X_7_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT6X_7_INSTALL_DIR
100export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}" 101export GCC_LINARO_BAREMETAL_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_TOOLCHAIN_RECIPE}"
101export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}" 102export GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN = "${STAGING_DIR_NATIVE}${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN_RECIPE}"
102export TI_CGT7X_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT7X_INSTALL_DIR_RECIPE}" 103export TI_CGT7X_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT7X_INSTALL_DIR_RECIPE}"
104export TI_K3_SECDEV_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
103 105
104 106
105DSPSUFFIX:omapl137 = "x674" 107DSPSUFFIX:omapl137 = "x674"
diff --git a/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb b/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb
new file mode 100644
index 00000000..7a5dd573
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Security development tools for High-Security(HS) TI K3 processors."
2HOMEPAGE = "https://git.ti.com/cgit/security-development-tools/core-secdev-k3"
3SECTION = "devel"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://manifest/k3-secdev-0.2-manifest.html;md5=f632a78870cc64550078d7b3cbac0892"
6
7# Native host tool only
8COMPATIBLE_MACHINE = "null"
9COMPATIBLE_MACHINE:class-native = "(.*)"
10COMPATIBLE_MACHINE:class-nativesdk = "(.*)"
11
12GIT_URI = "git://git.ti.com/git/security-development-tools/core-secdev-k3.git"
13GIT_PROTOCOL = "https"
14GIT_BRANCH = "master"
15GIT_SRCREV = "eb2c4d734487e5095b94cef3fd7213ee71d9e016"
16
17SRC_URI = "${GIT_URI};protocol=${GIT_PROTOCOL};branch=${GIT_BRANCH}"
18SRCREV = "${GIT_SRCREV}"
19
20S = "${WORKDIR}/git"
21
22do_install() {
23 CP_ARGS="-Prf --preserve=mode,links,timestamps --no-preserve=ownership"
24 install -d ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
25 cp ${CP_ARGS} ${S}/* ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE}
26}
27
28FILES:${PN} += "${TI_K3_SECDEV_INSTALL_DIR_RECIPE}"
29
30INSANE_SKIP:${PN} = "arch ldflags file-rdeps"
31
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1"
34INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
35
36BBCLASSEXTEND = "native nativesdk"