diff options
author | Jose Quaresma <quaresma.jose@gmail.com> | 2023-01-16 12:16:24 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-01-31 14:44:08 -0600 |
commit | b7515c5acb671ebde77d7680f748ed589601b7b6 (patch) | |
tree | 9fb015f9fd86d5f527e6d4d89d2f046646128dec /meta-ti-extras | |
parent | 574e833a9adf17a14484cae8b750b5cc36bc8d17 (diff) | |
download | meta-ti-b7515c5acb671ebde77d7680f748ed589601b7b6.tar.gz |
ti-k3-secdev: move from meta-ti-extras to meta-ti-bsp
The meta-ti-bsp layer is still broken for K3 HS platforms.
The patch [1] makes the check-layer happy again as it does not
fail any more during bitbake parsing but it will be difficult
for the end user to discover this dependency on meta-ti-extras.
On the other side, meta-ti-extras depends on meta-ti-bsp so
this is a circular dependency.
Currently the layer is broken for am62xx-evm/am64xx-evm machines:
| ERROR: Nothing PROVIDES 'ti-k3-secdev-native' (but mc:k3r5:/srv/oe/build/conf/../../layers/meta-ti/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb DEPENDS on or otherwise requires it). Close matches:
| libtspi-dev-native
| makedevs-native
[1] - 8e43835c ti-sci-fw: make dependency on meta-ti-extras soft
Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
Acked-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras')
-rw-r--r-- | meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb b/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb deleted file mode 100644 index 3763c339..00000000 --- a/meta-ti-extras/recipes-ti/secdev/ti-k3-secdev_git.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | DESCRIPTION = "Security development tools for High-Security(HS) TI K3 processors." | ||
2 | HOMEPAGE = "https://git.ti.com/cgit/security-development-tools/core-secdev-k3" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://manifest/k3-secdev-0.2-manifest.html;md5=f632a78870cc64550078d7b3cbac0892" | ||
6 | |||
7 | require recipes-ti/includes/ti-paths.inc | ||
8 | |||
9 | # Native host tool only | ||
10 | COMPATIBLE_MACHINE = "null" | ||
11 | COMPATIBLE_MACHINE:class-native = "(.*)" | ||
12 | COMPATIBLE_MACHINE:class-nativesdk = "(.*)" | ||
13 | |||
14 | GIT_URI = "git://git.ti.com/git/security-development-tools/core-secdev-k3.git" | ||
15 | GIT_PROTOCOL = "https" | ||
16 | GIT_BRANCH = "master" | ||
17 | GIT_SRCREV = "eb2c4d734487e5095b94cef3fd7213ee71d9e016" | ||
18 | |||
19 | SRC_URI = "${GIT_URI};protocol=${GIT_PROTOCOL};branch=${GIT_BRANCH}" | ||
20 | SRCREV = "${GIT_SRCREV}" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | do_install() { | ||
25 | CP_ARGS="-Prf --preserve=mode,links,timestamps --no-preserve=ownership" | ||
26 | install -d ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE} | ||
27 | cp ${CP_ARGS} ${S}/* ${D}${TI_K3_SECDEV_INSTALL_DIR_RECIPE} | ||
28 | } | ||
29 | |||
30 | FILES:${PN} += "${TI_K3_SECDEV_INSTALL_DIR_RECIPE}" | ||
31 | |||
32 | INSANE_SKIP:${PN} = "arch ldflags file-rdeps" | ||
33 | |||
34 | INHIBIT_PACKAGE_STRIP = "1" | ||
35 | INHIBIT_SYSROOT_STRIP = "1" | ||
36 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
37 | |||
38 | BBCLASSEXTEND = "native nativesdk" | ||