diff options
author | Andrew Davis <afd@ti.com> | 2023-02-08 17:22:39 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-02-16 13:31:05 -0600 |
commit | 610f1f498b107a323e7a2ea21b33e1063e059463 (patch) | |
tree | bef654ab5dd9b1a74f96c2071e4dabbb9280d468 /meta-ti-extras/recipes-ti | |
parent | 20405b32e1cad43bf387c2602614ebe3d77d7a30 (diff) | |
download | meta-ti-610f1f498b107a323e7a2ea21b33e1063e059463.tar.gz |
uio-module-drv: Remove deprecated uio-module-drv
UIO drivers are generally frowned upon in the community, and for PRU
we now have much better alternatives in RProc, RPmsg, and PRU-Consumer.
Let's not send the wrong message by continuing to support this crufty
interface. Remove the kernel module, DTBs, and test recipe.
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-ti')
-rw-r--r-- | meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb b/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb deleted file mode 100644 index d9a420d8..00000000 --- a/meta-ti-extras/recipes-ti/uio-test-pruss/uio-test-pruss_git.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | DESCRIPTION = "Provides test pruss firmware for uio based tests" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | PV = "1.0.2.0" | ||
4 | require recipes-ti/includes/ti-paths.inc | ||
5 | |||
6 | S = "${WORKDIR}/git" | ||
7 | |||
8 | DEPENDS = "ti-cgt-pru-native" | ||
9 | |||
10 | BRANCH = "master" | ||
11 | LIC_FILES_CHKSUM = "file://Makefile;startline=1;endline=31;md5=0ee4f2c42eb6b04e37859bb55a18b144" | ||
12 | |||
13 | UIO_TEST_PRUSS_GIT_URI = "git://git.ti.com/git/processor-sdk/uio-test-pruss.git" | ||
14 | UIO_TEST_PRUSS_GIT_PROTOCOL = "https" | ||
15 | SRC_URI = "${UIO_TEST_PRUSS_GIT_URI};protocol=${UIO_TEST_PRUSS_GIT_PROTOCOL};branch=${BRANCH}" | ||
16 | |||
17 | # Corresponds to version 01.00.02.00 | ||
18 | UIO_TEST_PRUSS_SRCREV = "e52a7b099d7203ca52519650df51419e9fef7e0c" | ||
19 | |||
20 | SRCREV = "${UIO_TEST_PRUSS_SRCREV}" | ||
21 | |||
22 | PR = "r0" | ||
23 | |||
24 | COMPATIBLE_MACHINE = "omap-a15|ti33x|ti43x" | ||
25 | |||
26 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
27 | |||
28 | DEVICE_NAME = "" | ||
29 | DEVICE_NAME:append:am57xx-evm = "am57xx" | ||
30 | DEVICE_NAME:append:ti33x = "am33xx" | ||
31 | DEVICE_NAME:append:ti43x = "am43xx" | ||
32 | |||
33 | EXTRA_OEMAKE = "CGT_PRU=${TI_CGT_PRU_INSTALL_DIR} DEVICE=${DEVICE_NAME}" | ||
34 | |||
35 | do_install() { | ||
36 | install -d ${D}${bindir}/ | ||
37 | cp -r *.bin ${D}${bindir}/ | ||
38 | } | ||