summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/swtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:51 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:39 -0600
commit37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e (patch)
tree0cb0ca43d699f542e4421b3ce34607823774f841 /meta-ti-extras/recipes-ti/swtools
parentc3007665063fac4140a6dddd3d76378ec5ae5c19 (diff)
downloadmeta-ti-37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e.tar.gz
meta-ti: move BIOS,XDC,XDAIS, CGT,DSP libs and components to meta-ti-extras
Legacy platforms AM3/4/5/J6 build components for multimedia acceleration and other DSP showcasing using SYS/BIOS, XDC, XDAIS, CodeGen Tools and different DSP libraries. Move all of them to meta-ti-extras. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-ti/swtools')
-rw-r--r--meta-ti-extras/recipes-ti/swtools/swtools_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/swtools/swtools_git.bb b/meta-ti-extras/recipes-ti/swtools/swtools_git.bb
new file mode 100644
index 00000000..d3b9a9b1
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/swtools/swtools_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "TI Software Tools"
2HOMEPAGE = "https://git.ti.com/ep-processor-libraries/swtools"
3SECTION = "devel"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://ti/mas/swtools/copyright.txt;md5=b1f52a1435051fdb18f8885b0384147d"
6
7require ../includes/ti-paths.inc
8
9DEPENDS = "ti-cgt6x-native \
10 ti-sysbios \
11 ti-xdctools-native"
12
13PV = "5_0_8"
14PR = "r3"
15S = "${WORKDIR}/git"
16
17SWTOOLS_GIT_BRANCH = "master"
18SWTOOLS_GIT_PROTOCOL = "git"
19SWTOOLS_GIT_URI = "git://git.ti.com/ep-processor-libraries/swtools.git"
20SWTOOLS_SRCREV = "7d1c85e686b1466cd2d535fc9cac5baf1aae24a4"
21
22SRC_URI = "${SWTOOLS_GIT_URI};protocol=${SWTOOLS_GIT_PROTOCOL};branch=${SWTOOLS_GIT_BRANCH}"
23SRCREV = "${SWTOOLS_SRCREV}"
24
25
26export C64PCODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
27export C674CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
28export C66CODEGENTOOL = "${CGTOOLS_INSTALL_DIR}"
29
30PATH:append = ":${XDC_INSTALL_DIR}"
31
32XDCPATH .= "${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages;"
33
34export XDCPATH
35
36do_compile() {
37 cd ${S}/ti/mas/swtools
38 xdc
39}
40
41do_install() {
42 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
43 install -d ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
44 cp ${CP_ARGS} ${S}/* ${D}${SWTOOLS_INSTALL_DIR_RECIPE}
45}
46
47FILES:${PN}-dev += "${SWTOOLS_INSTALL_DIR_RECIPE}"
48
49INSANE_SKIP:${PN}-dev = "arch staticdev"
50ALLOW_EMPTY:${PN} = "1"
51COMPATIBLE_HOST ?= "null"
52COMPATIBLE_HOST:ti-soc = "(.*)"