summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/ipc
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2024-11-08 14:28:48 -0600
committerRyan Eatmon <reatmon@ti.com>2024-11-12 08:04:01 -0600
commit47971372ed7252565675dd345cef457648a03730 (patch)
tree7c298902d17a33467f059aacbff206e399ba1745 /meta-ti-extras/recipes-ti/ipc
parent5602c567ae93808fbde1f96b0f0e4a8cdf91b258 (diff)
downloadmeta-ti-47971372ed7252565675dd345cef457648a03730.tar.gz
ti-ipc-examples: Remove DSP/BIOS IPC examplesmaster-wip
This IPC example is no longer supported nor recommended for new designs. The documentation is no not available either (was on Processors Wiki). Remove this example. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-ti/ipc')
-rw-r--r--meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch40
-rw-r--r--meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux_git.bb49
-rw-r--r--meta-ti-extras/recipes-ti/ipc/ti-ipc-examples.inc31
-rw-r--r--meta-ti-extras/recipes-ti/ipc/ti-ipc-examples_git.bb44
4 files changed, 0 insertions, 164 deletions
diff --git a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch b/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch
deleted file mode 100644
index ea514695..00000000
--- a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux/0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From cca4fd812959a0cd241dd3bbebfd461ece94c9b8 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denis@denix.org>
3Date: Mon, 29 Mar 2021 19:42:00 -0400
4Subject: [PATCH] examples/ClusterMgr: sys_errlist[] has been deprecated in
5 glibc
6
7Use strerror() instead.
8
9Upstream-Status: Pending
10
11Signed-off-by: Denys Dmytriyenko <denis@denix.org>
12---
13 src/examples/templates/ex46_graph/manager/ClusterMgr.c | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/src/examples/templates/ex46_graph/manager/ClusterMgr.c b/src/examples/templates/ex46_graph/manager/ClusterMgr.c
17index 19216c9..a1fa679 100644
18--- a/src/examples/templates/ex46_graph/manager/ClusterMgr.c
19+++ b/src/examples/templates/ex46_graph/manager/ClusterMgr.c
20@@ -714,7 +714,7 @@ static pid_t ClusterMgr_system(char *cmd, bool wait)
21 pid = fork();
22
23 if (pid == -1) {
24- LOG "CM_system: fork error: %s\n", sys_errlist[errno] LOGF
25+ LOG "CM_system: fork error: %s\n", strerror(errno) LOGF
26 status = -1;
27 goto leave;
28 }
29@@ -739,7 +739,7 @@ static pid_t ClusterMgr_system(char *cmd, bool wait)
30 else {
31 /* overlay a new executable */
32 execvp(argv[0], argv);
33- LOG "CM_system: execvp error: %s\n", sys_errlist[errno] LOGF
34+ LOG "CM_system: execvp error: %s\n", strerror(errno) LOGF
35 status = -1;
36 }
37
38--
392.7.4
40
diff --git a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
deleted file mode 100644
index 81706592..00000000
--- a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
2require ti-ipc-examples.inc
3
4SRC_URI += "file://0001-examples-ClusterMgr-sys_errlist-has-been-deprecated-.patch;patchdir=../git/ipc-examples"
5
6DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
7
8do_compile:append() {
9
10 if [ "${PLATFORM}" != "UNKNOWN" ]; then
11 oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
12
13 if [ ! -z ${ALT_PLATFORM} ]; then
14 oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
15 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
16 fi
17 oe_runmake -C examples all HOSTOS="linux" \
18 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
20
21 if [ ! -z ${ALT_PLATFORM} ]; then
22 oe_runmake -C examples all HOSTOS="linux" \
23 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
24 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
25 PLATFORM="${ALT_PLATFORM}"
26 fi
27 fi
28}
29
30do_install:append() {
31 cd ${S_ipc-examples}/src
32
33 if [ "${PLATFORM}" != "UNKNOWN" ]; then
34 # Install directory for linux examples
35 install -d ${D}${bindir}/ipc/examples
36 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
37 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
38 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
39
40 if [ ! -z ${ALT_PLATFORM} ]; then
41 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
42 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
43 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
44 PLATFORM="${ALT_PLATFORM}"
45 fi
46 fi
47}
48
49FILES:${PN} += "${bindir}/*"
diff --git a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples.inc b/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples.inc
deleted file mode 100644
index 09352505..00000000
--- a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples.inc
+++ /dev/null
@@ -1,31 +0,0 @@
1HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
2require recipes-ti/ipc/ti-ipc-common.inc
3require ti-ipc-rtos.inc
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://${S_ipc-examples}/src/makefile;beginline=1;endline=30;md5=a52324bd5033bb49ea07bade1244ac9a"
7
8INSANE_SKIP:${PN} += "arch"
9
10ALLOW_EMPTY:${PN} = "1"
11
12IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
13
14do_compile() {
15
16 cd ${S_ipc-examples}/src
17 oe_runmake .examples \
18 IPCTOOLS="${S_ipc-metadata}/src/etc"
19
20 for alt_platform in ${ALT_PLATFORM}; do
21 oe_runmake .examples "PLATFORM=${alt_platform}" \
22 IPCTOOLS="${S_ipc-metadata}/src/etc"
23 done
24}
25
26do_install() {
27 cd ${S_ipc-examples}/src
28 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
29}
30
31INHIBIT_PACKAGE_STRIP = "1"
diff --git a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples_git.bb b/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples_git.bb
deleted file mode 100644
index bcc8674e..00000000
--- a/meta-ti-extras/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
2require ti-ipc-examples.inc
3
4DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
5
6do_compile:append() {
7
8 if [ "${PLATFORM}" != "UNKNOWN" ]; then
9 oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
10
11 for alt_platform in ${ALT_PLATFORM}; do
12 oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
13 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
14 done
15 oe_runmake -C examples all HOSTOS="bios" \
16 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
17 for alt_platform in ${ALT_PLATFORM}; do
18 oe_runmake -C examples all HOSTOS="bios" \
19 IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
20 done
21 fi
22}
23
24do_install:append() {
25 if [ "${PLATFORM}" != "UNKNOWN" ]; then
26 # Install directory for bios examples
27 install -d ${D}/ipc_${IPC_VERSION}/examples/bios
28 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
29 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
30 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
31 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
32
33 for alt_platform in ${ALT_PLATFORM}; do
34 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
35 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
36 PLATFORM="${alt_platform}"
37 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
38 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
39 PLATFORM="${alt_platform}"
40 done
41 fi
42}
43
44FILES:${PN} += "ipc_*"