summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:51 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:39 -0600
commit37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e (patch)
tree0cb0ca43d699f542e4421b3ce34607823774f841 /meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
parentc3007665063fac4140a6dddd3d76378ec5ae5c19 (diff)
downloadmeta-ti-37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e.tar.gz
meta-ti: move BIOS,XDC,XDAIS, CGT,DSP libs and components to meta-ti-extras
Legacy platforms AM3/4/5/J6 build components for multimedia acceleration and other DSP showcasing using SYS/BIOS, XDC, XDAIS, CodeGen Tools and different DSP libraries. Move all of them to meta-ti-extras. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb')
-rw-r--r--meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
new file mode 100644
index 00000000..168e4be3
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Interface for GDB to commincate witha TI C66X DSP"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e"
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR:append = "b"
7PR = "${MACHINE_KERNEL_PR}"
8PV:append = "+git${SRCPV}"
9
10S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"
11
12inherit module
13
14PLATFORM = ""
15PLATFORM:dra7xx = "DRA7xx_PLATFORM"
16
17EXTRA_OEMAKE = "PLATFORM=${PLATFORM} KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}"
18
19# The following is to prevent an unused configure.ac from erroneously
20# triggering the QA check for gettext.
21EXTRA_OECONF = "--disable-nls"
22do_configure() {
23 :
24}
25
26COMPATIBLE_MACHINE = "dra7xx"
27PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29include gdbc6x.inc
30
31KERNEL_MODULE_AUTOLOAD += "gdbserverproxy"