summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:48 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:39 -0600
commitf81ec177d731b0d3fd77ad6f1f11d7bcfe49fcc1 (patch)
tree558074fef96d5a71fcaccb36f675ebd6eb8eca90 /meta-ti-extras/recipes-bsp
parentf11b313cdf84502e096c36388b1adb4988c61f65 (diff)
downloadmeta-ti-f81ec177d731b0d3fd77ad6f1f11d7bcfe49fcc1.tar.gz
meta-ti: move WiLink components to meta-ti-extras
Move WiLink WiFi and BT components from meta-ti-bsp to meta-ti-extras layer. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-bsp')
-rw-r--r--meta-ti-extras/recipes-bsp/bt-fw/bt-fw_git.bb24
-rw-r--r--meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch29
-rw-r--r--meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb25
3 files changed, 78 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/bt-fw/bt-fw_git.bb b/meta-ti-extras/recipes-bsp/bt-fw/bt-fw_git.bb
new file mode 100644
index 00000000..ea42c168
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/bt-fw/bt-fw_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Firmware files for Bluetooth"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=f39eac9f4573be5b012e8313831e72a9"
4
5PV = "8.7.1+git${SRCPV}"
6
7CLEANBROKEN = "1"
8
9SRCREV = "0ee619b598d023fffc77679f099bc2a4815510e4"
10BRANCH = "master"
11SRC_URI = "git://git.ti.com/ti-bt/service-packs.git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 :
17}
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware/ti-connectivity
21 oe_runmake "DEST_DIR=${D}" "BASE_LIB_DIR=${base_libdir}" install
22}
23
24FILES:${PN} += "${base_libdir}/firmware/ti-connectivity/*"
diff --git a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
new file mode 100644
index 00000000..a8db0770
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
@@ -0,0 +1,29 @@
1From 3a8fc3ccf00796254d6cef4b6d4cd70dc37012e1 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Fri, 10 Mar 2017 13:28:29 -0500
4Subject: [PATCH] Add Makefile to install firmware files
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 Makefile | 9 +++++++++
9 1 file changed, 9 insertions(+)
10 create mode 100644 Makefile
11
12diff --git a/Makefile b/Makefile
13new file mode 100644
14index 0000000..1cf38e3
15--- /dev/null
16+++ b/Makefile
17@@ -0,0 +1,9 @@
18+# Installs the the ti-connectivity wlan firmware files into the root file system
19+
20+install:
21+ @if [ ! -d $(DESTDIR) ] ; then \
22+ echo "Target filesystem directory doesn't exist."; \
23+ exit 1; \
24+ fi
25+ install -d $(DEST_DIR)/lib/firmware/ti-connectivity
26+ cp *.bin $(DEST_DIR)/lib/firmware/ti-connectivity/
27--
282.7.4
29
diff --git a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
new file mode 100644
index 00000000..48b500a8
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Firmware files for use with TI wl18xx"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://LICENCE;md5=4977a0fe767ee17765ae63c435a32a9e"
4
5SRC_URI = " \
6 git://git.ti.com/wilink8-wlan/wl18xx_fw.git;protocol=git;branch=${BRANCH} \
7 file://0001-Add-Makefile-to-install-firmware-files.patch \
8"
9
10SRCREV = "5ec05007f2662f460f881c5868311fd3ab7e6e71"
11BRANCH = "master"
12
13S = "${WORKDIR}/git"
14
15CLEANBROKEN = "1"
16
17do_compile() {
18 :
19}
20
21do_install() {
22 oe_runmake 'DEST_DIR=${D}' install
23}
24
25FILES:${PN} = "/lib/firmware/ti-connectivity/*"