summaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:51 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:39 -0600
commit37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e (patch)
tree0cb0ca43d699f542e4421b3ce34607823774f841 /meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
parentc3007665063fac4140a6dddd3d76378ec5ae5c19 (diff)
downloadmeta-ti-37ef6ae6fe518e78a6b44b8633d4c38cc7792c3e.tar.gz
meta-ti: move BIOS,XDC,XDAIS, CGT,DSP libs and components to meta-ti-extras
Legacy platforms AM3/4/5/J6 build components for multimedia acceleration and other DSP showcasing using SYS/BIOS, XDC, XDAIS, CodeGen Tools and different DSP libraries. Move all of them to meta-ti-extras. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb')
-rw-r--r--meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
new file mode 100644
index 00000000..4e863099
--- /dev/null
+++ b/meta-ti-extras/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Firmware for DSP for an example application called copycodectest"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://src/ti/framework/dce/dce.c;startline=1;endline=31;md5=2c6e9aba6ed75f22b1a2b7544b1c809d"
4
5COMPATIBLE_MACHINE = "dra7xx"
6
7inherit features_check
8
9REQUIRED_MACHINE_FEATURES = "dsp"
10
11SRC_URI = "git://git.ti.com/glsdk/dspdce.git;protocol=git"
12
13SRCREV = "de6e599f067b25c46cc0c8f74a22cc3b8aafbae8"
14
15PV = "1.00.00.07"
16
17S = "${WORKDIR}/git"
18
19require recipes-ti/includes/ti-paths.inc
20
21PR = "r4"
22inherit update-alternatives
23
24DEPENDS = "ti-xdctools-native ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native"
25
26export HWVERSION = "ES10"
27export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti"
28
29export XDCVERSION = "ti-xdctools-tree"
30export BIOSVERSION = "ti-sysbios-tree"
31export IPCVERSION = "ti-ipc-tree"
32export CEVERSION = "ti-codec-engine-tree"
33export FCVERSION = "ti-framework-components-tree"
34export XDAISVERSION = "ti-xdais-tree"
35export OSALVERSION = "ti-osal-tree"
36
37export IPCSRC = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
38export C66XCGTOOLSPATH = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
39
40do_configure() {
41 cd ${S}
42 make unconfig
43 make vayu_config
44}
45
46do_compile() {
47 cd ${S}
48 make dspbin
49}
50
51TARGET = "dra7-dsp1-fw.xe66"
52
53do_install() {
54 install -d ${D}${base_libdir}/firmware
55 install -m 0644 ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET}.${BPN}
56}
57
58ALTERNATIVE:${PN} = "dra7-dsp1-fw.xe66"
59ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}"
60ALTERNATIVE_TARGET[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}.${BPN}"
61ALTERNATIVE_PRIORITY = "10"
62
63INSANE_SKIP:${PN} = "arch"
64
65FILES:${PN} += "${base_libdir}/firmware/*"