diff options
author | Ryan Eatmon <reatmon@ti.com> | 2022-11-04 22:46:35 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-11-23 16:08:24 -0600 |
commit | c74ea6f30b97093828e9e34160cc15bde49590bd (patch) | |
tree | 114fbfde373bd4ae48935cdfae595c286461f43c /meta-ti-bsp | |
parent | e6f1b2edf01b481552b32d052c96014b2e1de6f6 (diff) | |
download | meta-ti-c74ea6f30b97093828e9e34160cc15bde49590bd.tar.gz |
machine: Add j784s4-evm configuration.
Adding support for j784s4-evm:
- Add configurations.
- Add firmware.
- Add u-boot.
- Add gpu support.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Hari Nagalla <hnagalla@ti.com>
Signed-off-by: Randolph Sapp <rs@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp')
9 files changed, 123 insertions, 6 deletions
diff --git a/meta-ti-bsp/conf/machine/j784s4-evm-k3r5.conf b/meta-ti-bsp/conf/machine/j784s4-evm-k3r5.conf new file mode 100644 index 00000000..04feebc6 --- /dev/null +++ b/meta-ti-bsp/conf/machine/j784s4-evm-k3r5.conf | |||
@@ -0,0 +1,11 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: J784S4 EVM (R5F) | ||
3 | #@DESCRIPTION: Machine configuration for the TI J784S4 EVM (R5F core) | ||
4 | |||
5 | require conf/machine/include/k3r5.inc | ||
6 | |||
7 | SYSFW_SOC = "j784s4" | ||
8 | SYSFW_CONFIG = "evm" | ||
9 | SYSFW_SUFFIX = "gp" | ||
10 | |||
11 | UBOOT_MACHINE = "j784s4_evm_r5_defconfig" | ||
diff --git a/meta-ti-bsp/conf/machine/j784s4-evm.conf b/meta-ti-bsp/conf/machine/j784s4-evm.conf new file mode 100644 index 00000000..a8ad25f6 --- /dev/null +++ b/meta-ti-bsp/conf/machine/j784s4-evm.conf | |||
@@ -0,0 +1,24 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: J784S4 EVM | ||
3 | #@DESCRIPTION: Machine configuration for the TI J784S4 EVM | ||
4 | |||
5 | require conf/machine/include/j7.inc | ||
6 | |||
7 | MACHINE_FEATURES += "gpu" | ||
8 | |||
9 | SERIAL_CONSOLES = "115200;ttyS10" | ||
10 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | ||
11 | TFA_K3_USART = "0x8" | ||
12 | OPTEE_K3_USART = "0x8" | ||
13 | |||
14 | KERNEL_DEVICETREE = " \ | ||
15 | ti/k3-j784s4-evm.dtb \ | ||
16 | " | ||
17 | |||
18 | UBOOT_MACHINE = "j784s4_evm_a72_defconfig" | ||
19 | |||
20 | do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" | ||
21 | do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" | ||
22 | |||
23 | TFA_BOARD = "j784s4" | ||
24 | |||
diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb index b066a676..5ae0cb7c 100644 --- a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb | |||
@@ -10,7 +10,7 @@ PR = "${INC_PR}.0" | |||
10 | 10 | ||
11 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
12 | 12 | ||
13 | COMPATIBLE_MACHINE = "j721e|j721s2" | 13 | COMPATIBLE_MACHINE = "j721e|j721s2|j784s4" |
14 | 14 | ||
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
16 | 16 | ||
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb index 12d21335..72dcca00 100644 --- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | |||
@@ -13,7 +13,7 @@ PR = "${INC_PR}.1" | |||
13 | 13 | ||
14 | CLEANBROKEN = "1" | 14 | CLEANBROKEN = "1" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "j721s2" | 16 | COMPATIBLE_MACHINE = "j721s2|j784s4" |
17 | 17 | ||
18 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 18 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
19 | 19 | ||
@@ -22,6 +22,7 @@ TARGET_WAVE521C = "wave521c_codec_fw.bin" | |||
22 | 22 | ||
23 | SOURCE_WAVE521C = "wave521c_codec_fw.bin" | 23 | SOURCE_WAVE521C = "wave521c_codec_fw.bin" |
24 | SOURCE_WAVE521C:j721s2 = "wave521c_j721s2_codec_fw.bin" | 24 | SOURCE_WAVE521C:j721s2 = "wave521c_j721s2_codec_fw.bin" |
25 | SOURCE_WAVE521C:j784s4 = "wave521c_j721s2_codec_fw.bin" | ||
25 | 26 | ||
26 | ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/${TARGET_WAVE521C}" | 27 | ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/${TARGET_WAVE521C}" |
27 | ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/cnm/${TARGET_WAVE521C}" | 28 | ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/cnm/${TARGET_WAVE521C}" |
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb index 95aa3299..00bc719a 100644 --- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb +++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb | |||
@@ -11,7 +11,7 @@ MACHINE_KERNEL_PR:append = "b" | |||
11 | PR = "${MACHINE_KERNEL_PR}" | 11 | PR = "${MACHINE_KERNEL_PR}" |
12 | 12 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 13 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | COMPATIBLE_MACHINE = "j721e|j721s2|am62xx" | 14 | COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" |
15 | 15 | ||
16 | DEPENDS = "virtual/kernel" | 16 | DEPENDS = "virtual/kernel" |
17 | 17 | ||
@@ -27,13 +27,15 @@ SRC_URI = " \ | |||
27 | 27 | ||
28 | S = "${WORKDIR}/git" | 28 | S = "${WORKDIR}/git" |
29 | 29 | ||
30 | SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b" | 30 | SRCREV = "ea2ac3fda4ac442b639bc3a0b73e9c4feac2081a" |
31 | 31 | ||
32 | TARGET_PRODUCT:j721e = "j721e_linux" | 32 | TARGET_PRODUCT:j721e = "j721e_linux" |
33 | TARGET_PRODUCT:j721s2 = "j721s2_linux" | 33 | TARGET_PRODUCT:j721s2 = "j721s2_linux" |
34 | TARGET_PRODUCT:j784s4 = "j784s4_linux" | ||
34 | TARGET_PRODUCT:am62xx = "am62_linux" | 35 | TARGET_PRODUCT:am62xx = "am62_linux" |
35 | TARGET_BVNC:j721e = "22.104.208.318" | 36 | TARGET_BVNC:j721e = "22.104.208.318" |
36 | TARGET_BVNC:j721s2 = "36.53.104.796" | 37 | TARGET_BVNC:j721s2 = "36.53.104.796" |
38 | TARGET_BVNC:j784s4 = "36.53.104.796" | ||
37 | TARGET_BVNC:am62xx = "33.15.11.3" | 39 | TARGET_BVNC:am62xx = "33.15.11.3" |
38 | PVR_BUILD = "release" | 40 | PVR_BUILD = "release" |
39 | PVR_WS = "wayland" | 41 | PVR_WS = "wayland" |
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 2772ee22..ba74fd8c 100644 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -35,6 +35,7 @@ SYSFW_PREFIX:j7200-evm-k3r5 = "fs" | |||
35 | SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs" | 35 | SYSFW_PREFIX:j7200-hs-evm-k3r5 = "fs" |
36 | SYSFW_PREFIX:j721s2-evm-k3r5 = "fs" | 36 | SYSFW_PREFIX:j721s2-evm-k3r5 = "fs" |
37 | SYSFW_PREFIX:j721s2-hs-evm-k3r5 = "fs" | 37 | SYSFW_PREFIX:j721s2-hs-evm-k3r5 = "fs" |
38 | SYSFW_PREFIX:j784s4-evm-k3r5 = "fs" | ||
38 | SYSFW_PREFIX:am62xx-evm-k3r5 = "fs" | 39 | SYSFW_PREFIX:am62xx-evm-k3r5 = "fs" |
39 | SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" | 40 | SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" |
40 | 41 | ||
diff --git a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb index 5d6e45b8..2abec024 100644 --- a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb +++ b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb | |||
@@ -8,17 +8,18 @@ inherit features_check | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | 8 | REQUIRED_MACHINE_FEATURES = "gpu" |
9 | 9 | ||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 10 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
11 | COMPATIBLE_MACHINE = "j721e|j721s2|am62xx" | 11 | COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx" |
12 | 12 | ||
13 | PR = "r2" | 13 | PR = "r2" |
14 | 14 | ||
15 | BRANCH = "linuxws/dunfell/k5.10/${PV}_unified_fw_pagesize" | 15 | BRANCH = "linuxws/dunfell/k5.10/${PV}_unified_fw_pagesize" |
16 | 16 | ||
17 | SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}" | 17 | SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-umlibs.git;protocol=https;branch=${BRANCH}" |
18 | SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed" | 18 | SRCREV = "4207c0ea429ec751b1ff5f831a84ceeb76ad578d" |
19 | 19 | ||
20 | TARGET_PRODUCT:j721e = "j721e_linux" | 20 | TARGET_PRODUCT:j721e = "j721e_linux" |
21 | TARGET_PRODUCT:j721s2 = "j721s2_linux" | 21 | TARGET_PRODUCT:j721s2 = "j721s2_linux" |
22 | TARGET_PRODUCT:j784s4 = "j784s4_linux" | ||
22 | TARGET_PRODUCT:am62xx = "am62_linux" | 23 | TARGET_PRODUCT:am62xx = "am62_linux" |
23 | PVR_BUILD ?= "release" | 24 | PVR_BUILD ?= "release" |
24 | PVR_WS = "wayland" | 25 | PVR_WS = "wayland" |
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc index 38289491..43cd31fe 100644 --- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc +++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc | |||
@@ -23,12 +23,14 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2" | |||
23 | # Add run-time dependency for Cadence MHDP firmware to the rootfs | 23 | # Add run-time dependency for Cadence MHDP firmware to the rootfs |
24 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw" | 24 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw" |
25 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw" | 25 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw" |
26 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw" | ||
26 | 27 | ||
27 | # Add run-time dependency for Video Decoding firmware to the rootfs | 28 | # Add run-time dependency for Video Decoding firmware to the rootfs |
28 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" | 29 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" |
29 | 30 | ||
30 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs | 31 | # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs |
31 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" | 32 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" |
33 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw" | ||
32 | 34 | ||
33 | # Add run-time dependency for TIFS Low Power Module stub | 35 | # Add run-time dependency for TIFS Low Power Module stub |
34 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub" | 36 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub" |
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index 219b86dc..0447bafe 100644 --- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -19,6 +19,7 @@ PLAT_SFX:j7200-evm = "j7200" | |||
19 | PLAT_SFX:j7200-hs-evm = "j7200" | 19 | PLAT_SFX:j7200-hs-evm = "j7200" |
20 | PLAT_SFX:j721s2-evm = "j721s2" | 20 | PLAT_SFX:j721s2-evm = "j721s2" |
21 | PLAT_SFX:j721s2-hs-evm = "j721s2" | 21 | PLAT_SFX:j721s2-hs-evm = "j721s2" |
22 | PLAT_SFX:j784s4-evm = "j784s4" | ||
22 | PLAT_SFX:am65xx = "am65xx" | 23 | PLAT_SFX:am65xx = "am65xx" |
23 | PLAT_SFX:am64xx = "am64xx" | 24 | PLAT_SFX:am64xx = "am64xx" |
24 | PLAT_SFX:am62xx = "am62xx" | 25 | PLAT_SFX:am62xx = "am62xx" |
@@ -245,6 +246,26 @@ do_install:j721s2-hs-evm() { | |||
245 | # install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR} | 246 | # install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR} |
246 | } | 247 | } |
247 | 248 | ||
249 | do_install:j784s4-evm() { | ||
250 | install -d ${LEGACY_IPC_FW_DIR} | ||
251 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
252 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
253 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
254 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu3_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
255 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu3_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
256 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu4_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
257 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu4_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | ||
258 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_1_release_strip.xe71 ${LEGACY_IPC_FW_DIR} | ||
259 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_2_release_strip.xe71 ${LEGACY_IPC_FW_DIR} | ||
260 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_3_release_strip.xe71 ${LEGACY_IPC_FW_DIR} | ||
261 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_4_release_strip.xe71 ${LEGACY_IPC_FW_DIR} | ||
262 | # DM Firmware | ||
263 | install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} | ||
264 | # ETH firmware | ||
265 | install -d ${LEGACY_ETH_FW_DIR} | ||
266 | install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR} | ||
267 | } | ||
268 | |||
248 | do_install:am65xx() { | 269 | do_install:am65xx() { |
249 | install -d ${LEGACY_IPC_FW_DIR} | 270 | install -d ${LEGACY_IPC_FW_DIR} |
250 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} | 271 | install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} |
@@ -370,6 +391,21 @@ ALTERNATIVE:${PN}:j721s2-hs-evm = "\ | |||
370 | j721s2-c71_1-fw-sec \ | 391 | j721s2-c71_1-fw-sec \ |
371 | " | 392 | " |
372 | 393 | ||
394 | ALTERNATIVE:${PN}:j784s4-evm = "\ | ||
395 | j784s4-mcu-r5f0_0-fw \ | ||
396 | j784s4-mcu-r5f0_1-fw \ | ||
397 | j784s4-main-r5f0_0-fw \ | ||
398 | j784s4-main-r5f0_1-fw \ | ||
399 | j784s4-main-r5f1_0-fw \ | ||
400 | j784s4-main-r5f1_1-fw \ | ||
401 | j784s4-main-r5f2_0-fw \ | ||
402 | j784s4-main-r5f2_1-fw \ | ||
403 | j784s4-c71_0-fw \ | ||
404 | j784s4-c71_1-fw \ | ||
405 | j784s4-c71_2-fw \ | ||
406 | j784s4-c71_3-fw \ | ||
407 | " | ||
408 | |||
373 | # Set up link names for the firmwares | 409 | # Set up link names for the firmwares |
374 | 410 | ||
375 | TARGET_MCU_R5FSS0_0:am65xx = "am65x-mcu-r5f0_0-fw" | 411 | TARGET_MCU_R5FSS0_0:am65xx = "am65x-mcu-r5f0_0-fw" |
@@ -440,6 +476,19 @@ TARGET_MAIN_R5FSS1_1_SIGNED:j721s2-hs-evm = "j721s2-main-r5f1_1-fw-sec" | |||
440 | TARGET_C7X_0_SIGNED:j721s2-hs-evm = "j721s2-c71_0-fw-sec" | 476 | TARGET_C7X_0_SIGNED:j721s2-hs-evm = "j721s2-c71_0-fw-sec" |
441 | TARGET_C7X_1_SIGNED:j721s2-hs-evm = "j721s2-c71_1-fw-sec" | 477 | TARGET_C7X_1_SIGNED:j721s2-hs-evm = "j721s2-c71_1-fw-sec" |
442 | 478 | ||
479 | TARGET_MCU_R5FSS0_0:j784s4-evm = "j784s4-mcu-r5f0_0-fw" | ||
480 | TARGET_MCU_R5FSS0_1:j784s4-evm = "j784s4-mcu-r5f0_1-fw" | ||
481 | TARGET_MAIN_R5FSS0_0:j784s4-evm = "j784s4-main-r5f0_0-fw" | ||
482 | TARGET_MAIN_R5FSS0_1:j784s4-evm = "j784s4-main-r5f0_1-fw" | ||
483 | TARGET_MAIN_R5FSS1_0:j784s4-evm = "j784s4-main-r5f1_0-fw" | ||
484 | TARGET_MAIN_R5FSS1_1:j784s4-evm = "j784s4-main-r5f1_1-fw" | ||
485 | TARGET_MAIN_R5FSS2_0:j784s4-evm = "j784s4-main-r5f2_0-fw" | ||
486 | TARGET_MAIN_R5FSS2_1:j784s4-evm = "j784s4-main-r5f2_1-fw" | ||
487 | TARGET_C7X_0:j784s4-evm = "j784s4-c71_0-fw" | ||
488 | TARGET_C7X_1:j784s4-evm = "j784s4-c71_1-fw" | ||
489 | TARGET_C7X_2:j784s4-evm = "j784s4-c71_2-fw" | ||
490 | TARGET_C7X_3:j784s4-evm = "j784s4-c71_3-fw" | ||
491 | |||
443 | ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}" | 492 | ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}" |
444 | ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}" | 493 | ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}" |
445 | 494 | ||
@@ -494,6 +543,19 @@ ALTERNATIVE_LINK_NAME[j721s2-main-r5f1_1-fw-sec] = "${base_libdir}/firmware/${TA | |||
494 | ALTERNATIVE_LINK_NAME[j721s2-c71_0-fw-sec] = "${base_libdir}/firmware/${TARGET_C7X_0_SIGNED}" | 543 | ALTERNATIVE_LINK_NAME[j721s2-c71_0-fw-sec] = "${base_libdir}/firmware/${TARGET_C7X_0_SIGNED}" |
495 | ALTERNATIVE_LINK_NAME[j721s2-c71_1-fw-sec] = "${base_libdir}/firmware/${TARGET_C7X_1_SIGNED}" | 544 | ALTERNATIVE_LINK_NAME[j721s2-c71_1-fw-sec] = "${base_libdir}/firmware/${TARGET_C7X_1_SIGNED}" |
496 | 545 | ||
546 | ALTERNATIVE_LINK_NAME[j784s4-mcu-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}" | ||
547 | ALTERNATIVE_LINK_NAME[j784s4-mcu-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}" | ||
548 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_0}" | ||
549 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_1}" | ||
550 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f1_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS1_0}" | ||
551 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f1_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS1_1}" | ||
552 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f2_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS2_0}" | ||
553 | ALTERNATIVE_LINK_NAME[j784s4-main-r5f2_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS2_1}" | ||
554 | ALTERNATIVE_LINK_NAME[j784s4-c71_0-fw] = "${base_libdir}/firmware/${TARGET_C7X_0}" | ||
555 | ALTERNATIVE_LINK_NAME[j784s4-c71_1-fw] = "${base_libdir}/firmware/${TARGET_C7X_1}" | ||
556 | ALTERNATIVE_LINK_NAME[j784s4-c71_2-fw] = "${base_libdir}/firmware/${TARGET_C7X_2}" | ||
557 | ALTERNATIVE_LINK_NAME[j784s4-c71_3-fw] = "${base_libdir}/firmware/${TARGET_C7X_3}" | ||
558 | |||
497 | # Create the firmware alternatives | 559 | # Create the firmware alternatives |
498 | 560 | ||
499 | ALTERNATIVE_TARGET[am65x-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu1_0_release_strip.xer5f" | 561 | ALTERNATIVE_TARGET[am65x-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu1_0_release_strip.xer5f" |
@@ -550,6 +612,19 @@ ALTERNATIVE_TARGET[j721s2-main-r5f1_1-fw-sec] = "${base_libdir}/firmware/pdk-ipc | |||
550 | ALTERNATIVE_TARGET[j721s2-c71_0-fw-sec] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_1_release_strip.xe71.signed" | 612 | ALTERNATIVE_TARGET[j721s2-c71_0-fw-sec] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_1_release_strip.xe71.signed" |
551 | ALTERNATIVE_TARGET[j721s2-c71_1-fw-sec] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_2_release_strip.xe71.signed" | 613 | ALTERNATIVE_TARGET[j721s2-c71_1-fw-sec] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_2_release_strip.xe71.signed" |
552 | 614 | ||
615 | ALTERNATIVE_TARGET[j784s4-mcu-r5f0_0-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_testb_mcu1_0_release_strip.xer5f" | ||
616 | ALTERNATIVE_TARGET[j784s4-mcu-r5f0_1-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu1_1_release_strip.xer5f" | ||
617 | ALTERNATIVE_TARGET[j784s4-main-r5f0_0-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu2_0_release_strip.xer5f" | ||
618 | ALTERNATIVE_TARGET[j784s4-main-r5f0_1-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu2_1_release_strip.xer5f" | ||
619 | ALTERNATIVE_TARGET[j784s4-main-r5f1_0-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu3_0_release_strip.xer5f" | ||
620 | ALTERNATIVE_TARGET[j784s4-main-r5f1_1-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu3_1_release_strip.xer5f" | ||
621 | ALTERNATIVE_TARGET[j784s4-main-r5f2_0-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu4_0_release_strip.xer5f" | ||
622 | ALTERNATIVE_TARGET[j784s4-main-r5f2_1-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_mcu4_1_release_strip.xer5f" | ||
623 | ALTERNATIVE_TARGET[j784s4-c71_0-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_1_release_strip.xe71" | ||
624 | ALTERNATIVE_TARGET[j784s4-c71_1-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_2_release_strip.xe71" | ||
625 | ALTERNATIVE_TARGET[j784s4-c71_2-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_3_release_strip.xe71" | ||
626 | ALTERNATIVE_TARGET[j784s4-c71_3-fw] = "${base_libdir}/firmware/pdk-ipc/ipc_echo_test_c7x_4_release_strip.xe71" | ||
627 | |||
553 | ALTERNATIVE_PRIORITY = "10" | 628 | ALTERNATIVE_PRIORITY = "10" |
554 | 629 | ||
555 | # make sure that lib/firmware, and all its contents are part of the package | 630 | # make sure that lib/firmware, and all its contents are part of the package |