summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-09-13 03:55:40 +0000
committerRyan Eatmon <reatmon@ti.com>2022-09-22 11:23:07 -0500
commit47d212666b1daf9f049ea2b1abd8f9086288dcf5 (patch)
tree53d4886db4e5cbbf95662fe0be239831af5c097d /meta-ti-bsp
parente1f119c925a79107d0b6840ebe6b05f11512421a (diff)
downloadmeta-ti-47d212666b1daf9f049ea2b1abd8f9086288dcf5.tar.gz
trusted-firmware-a: Allow build to continue without TI_SECURE_DEV_PKG set
Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend38
1 files changed, 16 insertions, 22 deletions
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 41241a57..14463846 100644
--- a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -9,42 +9,36 @@ TFA_SPD:k3 = "opteed"
9EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" 9EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
10EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" 10EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
11 11
12do_compile:append:am65xx-hs-evm() { 12# Signing procedure for K3 HS devices
13tfa_sign_k3hs() {
13 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 14 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
14 ( cd ${BUILD_DIR}; \ 15 ( cd ${BUILD_DIR}; \
15 mv bl31.bin bl31.bin.unsigned; \ 16 mv bl31.bin bl31.bin.unsigned; \
16 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ 17 if [ -f ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ]; then \
18 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
19 else \
20 echo "Warning: TI_SECURE_DEV_PKG not set, TF-A not signed."; \
21 cp bl31.bin.unsigned bl31.bin; \
22 fi; \
17 ) 23 )
18} 24}
19 25
26do_compile:append:am65xx-hs-evm() {
27 tfa_sign_k3hs
28}
29
20do_compile:append:am64xx-hs-evm() { 30do_compile:append:am64xx-hs-evm() {
21 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 31 tfa_sign_k3hs
22 ( cd ${BUILD_DIR}; \
23 mv bl31.bin bl31.bin.unsigned; \
24 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
25 )
26} 32}
27 33
28do_compile:append:j721e-hs-evm() { 34do_compile:append:j721e-hs-evm() {
29 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 35 tfa_sign_k3hs
30 ( cd ${BUILD_DIR}; \
31 mv bl31.bin bl31.bin.unsigned; \
32 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
33 )
34} 36}
35 37
36do_compile:append:j7200-hs-evm() { 38do_compile:append:j7200-hs-evm() {
37 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 39 tfa_sign_k3hs
38 ( cd ${BUILD_DIR}; \
39 mv bl31.bin bl31.bin.unsigned; \
40 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
41 )
42} 40}
43 41
44do_compile:append:j721s2-hs-evm() { 42do_compile:append:j721s2-hs-evm() {
45 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 43 tfa_sign_k3hs
46 ( cd ${B}/${BUILD_DIR}/release/; \
47 mv bl31.bin bl31.bin.unsigned; \
48 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
49 )
50} 44}