summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-01-20 01:40:46 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-20 15:55:32 -0600
commit86d02e62e543e341b0bed9e9874e19bf04e29c39 (patch)
tree466d9a90bd4aab7a4aad7b3d9a8578107f8d85c3 /meta-ti-bsp
parentad3d14240d10970de46043ae78d8de7eed6bf884 (diff)
downloadmeta-ti-86d02e62e543e341b0bed9e9874e19bf04e29c39.tar.gz
conf: machine: Use new J7 SoC names over specific board names
Now that we have SoC names, we can avoid adding features based on the board name. We expect folks to create their own boards based on these SoCs, and so using the TI made EVM board name everywhere adds extra churn when adding a new board. Plus it is more correct for most of these features as they depend on the SoC, not on the EVM board. One other thing we do here is to not use the generic "j7" name, the current and future J7 devices are far to feature diverse to group at this level. Grouping like that will lead to the wrong things getting enabled as new J7 SoCs are added. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb3
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc5
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb2
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb39
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb6
7 files changed, 29 insertions, 30 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index 0e8ed897..e7aa9ef4 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -27,8 +27,7 @@ ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/cnm
27ALTERNATIVE_PRIORITY = "10" 27ALTERNATIVE_PRIORITY = "10"
28 28
29# Set up names for the firmwares 29# Set up names for the firmwares
30ALTERNATIVE_${PN}:j7 = "\ 30ALTERNATIVE_${PN} = "wave521c_codec_fw.bin"
31 wave521c_codec_fw.bin"
32 31
33do_install() { 32do_install() {
34 install -d ${D}${nonarch_base_libdir}/firmware/cnm 33 install -d ${D}${nonarch_base_libdir}/firmware/cnm
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
index 7727e9af..bd103198 100644
--- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -9,7 +9,7 @@ PR = "${INC_PR}.0"
9 9
10CLEANBROKEN = "1" 10CLEANBROKEN = "1"
11 11
12COMPATIBLE_MACHINE = "j7" 12COMPATIBLE_MACHINE = "j721e"
13 13
14PACKAGE_ARCH = "${MACHINE_ARCH}" 14PACKAGE_ARCH = "${MACHINE_ARCH}"
15 15
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index 5127e137..6f5b6313 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -32,7 +32,10 @@ PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/b
32PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE},,ti-rtos-firmware" 32PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE},,ti-rtos-firmware"
33 33
34PACKAGECONFIG:append:aarch64 = " atf optee" 34PACKAGECONFIG:append:aarch64 = " atf optee"
35PACKAGECONFIG:append:j7 = " dm" 35PACKAGECONFIG:append:j721e = " dm"
36PACKAGECONFIG:append:j7200 = " dm"
37PACKAGECONFIG:append:j721s2 = " dm"
38PACKAGECONFIG:append:j784s4 = " dm"
36PACKAGECONFIG:append:am62xx = " dm" 39PACKAGECONFIG:append:am62xx = " dm"
37 40
38COMPATIBLE_MACHINE = "(ti-soc)" 41COMPATIBLE_MACHINE = "(ti-soc)"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 61dcbcd8..808a4766 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -25,7 +25,7 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw"
25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw" 25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw"
26 26
27# Add run-time dependency for Video Decoding firmware to the rootfs 27# Add run-time dependency for Video Decoding firmware to the rootfs
28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" 28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
29 29
30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs 30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" 31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index bf230dbc..67b28b2a 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -42,4 +42,4 @@ module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus" 42module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus" 43module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc" 44KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
45KERNEL_MODULE_AUTOLOAD:append:j7 = " rpmsg_kdrv_switch" 45KERNEL_MODULE_AUTOLOAD:append:j721e = " rpmsg_kdrv_switch"
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 0447bafe..9a6da088 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -13,13 +13,10 @@ inherit deploy
13inherit update-alternatives 13inherit update-alternatives
14 14
15PLAT_SFX = "" 15PLAT_SFX = ""
16PLAT_SFX:j7 = "j721e" 16PLAT_SFX:j721e = "j721e"
17PLAT_SFX:j721e-hs-evm = "j721e" 17PLAT_SFX:j7200 = "j7200"
18PLAT_SFX:j7200-evm = "j7200" 18PLAT_SFX:j721s2 = "j721s2"
19PLAT_SFX:j7200-hs-evm = "j7200" 19PLAT_SFX:j784s4 = "j784s4"
20PLAT_SFX:j721s2-evm = "j721s2"
21PLAT_SFX:j721s2-hs-evm = "j721s2"
22PLAT_SFX:j784s4-evm = "j784s4"
23PLAT_SFX:am65xx = "am65xx" 20PLAT_SFX:am65xx = "am65xx"
24PLAT_SFX:am64xx = "am64xx" 21PLAT_SFX:am64xx = "am64xx"
25PLAT_SFX:am62xx = "am62xx" 22PLAT_SFX:am62xx = "am62xx"
@@ -50,7 +47,7 @@ LEGACY_DM_FW_DIR = "${D}${nonarch_base_libdir}/firmware/pdk-ipc/"
50 47
51DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" 48DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
52 49
53# J7 HS support 50# J721e HS support
54do_install:prepend:j721e-hs-evm() { 51do_install:prepend:j721e-hs-evm() {
55 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 52 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
56 ( cd ${RTOS_DM_FW_DIR}; \ 53 ( cd ${RTOS_DM_FW_DIR}; \
@@ -81,7 +78,7 @@ do_install:prepend:j721e-hs-evm() {
81 ) 78 )
82} 79}
83 80
84# J7 HS support 81# J7200 HS support
85do_install:prepend:j7200-hs-evm() { 82do_install:prepend:j7200-hs-evm() {
86 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 83 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
87 ( cd ${RTOS_DM_FW_DIR}; \ 84 ( cd ${RTOS_DM_FW_DIR}; \
@@ -102,7 +99,7 @@ do_install:prepend:j7200-hs-evm() {
102 ) 99 )
103} 100}
104 101
105# J7 HS support 102# J721s2 HS support
106do_install:prepend:j721s2-hs-evm() { 103do_install:prepend:j721s2-hs-evm() {
107 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 104 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
108 ( cd ${RTOS_DM_FW_DIR}; \ 105 ( cd ${RTOS_DM_FW_DIR}; \
@@ -149,7 +146,7 @@ do_install() {
149 : 146 :
150} 147}
151 148
152do_install:j7() { 149do_install:j721e() {
153 install -d ${LEGACY_IPC_FW_DIR} 150 install -d ${LEGACY_IPC_FW_DIR}
154 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 151 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
155 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 152 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
@@ -335,7 +332,7 @@ ALTERNATIVE:${PN}:j721e-hs-evm = "\
335 j7-c71_0-fw-sec \ 332 j7-c71_0-fw-sec \
336 " 333 "
337 334
338ALTERNATIVE:${PN}:j7 = "\ 335ALTERNATIVE:${PN}:j721e-evm = "\
339 j7-mcu-r5f0_0-fw \ 336 j7-mcu-r5f0_0-fw \
340 j7-mcu-r5f0_1-fw \ 337 j7-mcu-r5f0_1-fw \
341 j7-main-r5f0_0-fw \ 338 j7-main-r5f0_0-fw \
@@ -420,15 +417,15 @@ TARGET_MCU_M4FSS0_0:am64xx = "am64-mcu-m4f0_0-fw"
420TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw" 417TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw"
421TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw" 418TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw"
422 419
423TARGET_MCU_R5FSS0_0:j7 = "j7-mcu-r5f0_0-fw" 420TARGET_MCU_R5FSS0_0:j721e = "j7-mcu-r5f0_0-fw"
424TARGET_MCU_R5FSS0_1:j7 = "j7-mcu-r5f0_1-fw" 421TARGET_MCU_R5FSS0_1:j721e = "j7-mcu-r5f0_1-fw"
425TARGET_MAIN_R5FSS0_0:j7 = "j7-main-r5f0_0-fw" 422TARGET_MAIN_R5FSS0_0:j721e = "j7-main-r5f0_0-fw"
426TARGET_MAIN_R5FSS0_1:j7 = "j7-main-r5f0_1-fw" 423TARGET_MAIN_R5FSS0_1:j721e = "j7-main-r5f0_1-fw"
427TARGET_MAIN_R5FSS1_0:j7 = "j7-main-r5f1_0-fw" 424TARGET_MAIN_R5FSS1_0:j721e = "j7-main-r5f1_0-fw"
428TARGET_MAIN_R5FSS1_1:j7 = "j7-main-r5f1_1-fw" 425TARGET_MAIN_R5FSS1_1:j721e = "j7-main-r5f1_1-fw"
429TARGET_C66_0:j7 = "j7-c66_0-fw" 426TARGET_C66_0:j721e = "j7-c66_0-fw"
430TARGET_C66_1:j7 = "j7-c66_1-fw" 427TARGET_C66_1:j721e = "j7-c66_1-fw"
431TARGET_C7X_0:j7 = "j7-c71_0-fw" 428TARGET_C7X_0:j721e = "j7-c71_0-fw"
432 429
433TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec" 430TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec"
434TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec" 431TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec"
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
index be1ff013..ff715ce0 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
@@ -1,7 +1,7 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" 2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
3 3
4COMPATIBLE_MACHINE = "ti-soc" 4COMPATIBLE_MACHINE = "j721e|j7200|am65xx|am64xx"
5 5
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
@@ -10,8 +10,8 @@ INHIBIT_DEFAULT_DEPS = "1"
10inherit nopackages deploy 10inherit nopackages deploy
11 11
12PLAT_SFX = "" 12PLAT_SFX = ""
13PLAT_SFX:j7 = "/j721e" 13PLAT_SFX:j721e = "/j721e"
14PLAT_SFX:j7200-evm = "/j7200" 14PLAT_SFX:j7200 = "/j7200"
15PLAT_SFX:am65xx = "/am65xx" 15PLAT_SFX:am65xx = "/am65xx"
16PLAT_SFX:am64xx = "/am64x" 16PLAT_SFX:am64xx = "/am64x"
17 17