summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-06-06 14:35:25 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-09 08:06:52 -0500
commitffcf419a28d1c71580dc09e9f01aef36b5cda5c9 (patch)
tree2b179d3448b70aa62749c1ba5b2e0d6ab4e36aed /meta-ti-bsp
parent803a9256d6ce9615f49c0c7ab81a822d23aa7f30 (diff)
downloadmeta-ti-ffcf419a28d1c71580dc09e9f01aef36b5cda5c9.tar.gz
ti-img-rogue-umlibs: drop the api specific dev packages
Well, flew a bit too close to the sun on that last patch. Apparently there are a few hidden runtime dependencies on the API devlinks that make things like EGL upset when they aren't present. We may circle back to this at some point but for now we're fine shipping the devlinks in the base API packages as these links don't step on any other package. Fixes: 1899f5ea (ti-img-rogue-umlibs: bump version and explicitly package, 2023-06-01) Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb30
1 files changed, 11 insertions, 19 deletions
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
index 3fcb786c..5e7f533f 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -36,11 +36,11 @@ do_install:append() {
36} 36}
37 37
38PACKAGES = " \ 38PACKAGES = " \
39 libgles1-rogue libgles1-rogue-dev \ 39 libgles1-rogue \
40 libgles2-rogue libgles2-rogue-dev \ 40 libgles2-rogue \
41 libgles3-rogue libgles3-rogue-dev \ 41 libgles3-rogue \
42 libvk-rogue libvk-rogue-dev \ 42 libvk-rogue \
43 libopencl-rogue libopencl-rogue-dev \ 43 libopencl-rogue \
44 libopencl-rogue-tools \ 44 libopencl-rogue-tools \
45 ${PN}-tools \ 45 ${PN}-tools \
46 ${PN}-firmware \ 46 ${PN}-firmware \
@@ -65,34 +65,26 @@ python __anonymous() {
65 mlprefix = d.getVar("MLPREFIX") 65 mlprefix = d.getVar("MLPREFIX")
66 pkgs = " " + " ".join(mlprefix + x + suffix for x in p[1:]) 66 pkgs = " " + " ".join(mlprefix + x + suffix for x in p[1:])
67 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1") 67 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1")
68 d.setVar("INSANE_SKIP:" + fullp, "dev-so")
68 d.appendVar("RRECOMMENDS:" + fullp, " ${MLPREFIX}ti-img-rogue-umlibs" + suffix) 69 d.appendVar("RRECOMMENDS:" + fullp, " ${MLPREFIX}ti-img-rogue-umlibs" + suffix)
69
70 # For -dev, the first element is both the Debian and original name
71 fullp = mlprefix + p[1] + "-rogue-dev" + suffix
72 pkgs = " " + mlprefix + p[1] + "-dev" + suffix
73 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1")
74} 70}
75 71
76# gles specific shared objects 72# gles specific shared objects
77FILES:libgles1-rogue = "${libdir}/libGLESv1*.so.*" 73FILES:libgles1-rogue = "${libdir}/libGLESv1*.so*"
78FILES:libgles1-rogue-dev = "${libdir}/libGLESv1*.so" 74FILES:libgles2-rogue = "${libdir}/libGLESv2*.so*"
79FILES:libgles2-rogue = "${libdir}/libGLESv2*.so.*"
80FILES:libgles2-rogue-dev = "${libdir}/libGLESv2*.so"
81RDEPENDS:libgles1-rogue += "mesa-megadriver" 75RDEPENDS:libgles1-rogue += "mesa-megadriver"
82RDEPENDS:libgles2-rogue += "mesa-megadriver" 76RDEPENDS:libgles2-rogue += "mesa-megadriver"
83RDEPENDS:libgles3-rogue-dev += "libgles2-rogue-dev"
84 77
85# vulkan specific shared objects and configs 78# vulkan specific shared objects and configs
86FILES:libvk-rogue = "${libdir}/libVK_IMG.so.* ${datadir}/vulkan" 79FILES:libvk-rogue = "${libdir}/libVK_IMG.so* ${datadir}/vulkan"
87FILES:libvk-rogue-dev = "${libdir}/libVK_IMG.so"
88RDEPENDS:libvk-rogue += "vulkan-loader libx11-xcb wayland libdrm" 80RDEPENDS:libvk-rogue += "vulkan-loader libx11-xcb wayland libdrm"
89 81
90# opencl specific shared objects and configs 82# opencl specific shared objects and configs
91FILES:libopencl-rogue = "${libdir}/libPVROCL.so.* ${sysconfdir}/OpenCL" 83FILES:libopencl-rogue = "${libdir}/libPVROCL.so* ${sysconfdir}/OpenCL"
92FILES:libopencl-rogue-dev = "${libdir}/libPVROCL.so"
93RDEPENDS:libopencl-rogue += "opencl-icd-loader" 84RDEPENDS:libopencl-rogue += "opencl-icd-loader"
94RRECOMMENDS:libopencl-rogue += "libopencl-rogue-tools" 85RRECOMMENDS:libopencl-rogue += "libopencl-rogue-tools"
95FILES:libopencl-rogue-tools += "${bindir}/ocl*" 86FILES:libopencl-rogue-tools += "${bindir}/ocl*"
87DEBIAN_NOAUTONAME:libopencl-rogue-tools = "1"
96 88
97# optional tools and tests 89# optional tools and tests
98FILES:${PN}-tools = "${bindir}/" 90FILES:${PN}-tools = "${bindir}/"