diff options
author | Etheridge, Darren <detheridge@ti.com> | 2022-05-02 14:51:06 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-05-02 11:31:08 -0500 |
commit | 28fa5882ed43a47a22d24b6df9151f12e32ab6dc (patch) | |
tree | 22c5eacc0c9194e58f84ff04c0f72e224a2fd3cd /meta-ti-bsp | |
parent | 15ae8b802a05cebb6a272047816d82f345703704 (diff) | |
download | meta-ti-28fa5882ed43a47a22d24b6df9151f12e32ab6dc.tar.gz |
ti-graphics: gpu enable and move all platforms to ddk 1.15
Enable the GPU for am62xx and j721s2 and use IMG DDK 1.15
Migrate Imagination DDK 1.13 to DDK 1.15 for J721e
Signed-off-by: Darren Etheridge <detheridge@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp')
-rw-r--r-- | meta-ti-bsp/conf/machine/am62xx-evm.conf | 2 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/j721s2-evm.conf | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb | 40 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb | 44 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb (renamed from meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb) | 13 |
5 files changed, 55 insertions, 46 deletions
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm.conf b/meta-ti-bsp/conf/machine/am62xx-evm.conf index 0588d34c..eb1563f8 100644 --- a/meta-ti-bsp/conf/machine/am62xx-evm.conf +++ b/meta-ti-bsp/conf/machine/am62xx-evm.conf | |||
@@ -4,6 +4,8 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/am62xx.inc | 5 | require conf/machine/include/am62xx.inc |
6 | 6 | ||
7 | MACHINE_FEATURES += "gpu" | ||
8 | |||
7 | KERNEL_DEVICETREE = " \ | 9 | KERNEL_DEVICETREE = " \ |
8 | ti/k3-am625-sk.dtb \ | 10 | ti/k3-am625-sk.dtb \ |
9 | " | 11 | " |
diff --git a/meta-ti-bsp/conf/machine/j721s2-evm.conf b/meta-ti-bsp/conf/machine/j721s2-evm.conf index a2c15f74..5d977776 100644 --- a/meta-ti-bsp/conf/machine/j721s2-evm.conf +++ b/meta-ti-bsp/conf/machine/j721s2-evm.conf | |||
@@ -4,6 +4,8 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/j721s2.inc | 5 | require conf/machine/include/j721s2.inc |
6 | 6 | ||
7 | MACHINE_FEATURES += "gpu" | ||
8 | |||
7 | SERIAL_CONSOLES = "115200;ttyS10" | 9 | SERIAL_CONSOLES = "115200;ttyS10" |
8 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | 10 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" |
9 | TFA_K3_USART = "0x8" | 11 | TFA_K3_USART = "0x8" |
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb deleted file mode 100644 index 6ed3a40b..00000000 --- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver" | ||
3 | LICENSE = "MIT | GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2" | ||
5 | |||
6 | inherit module features_check | ||
7 | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | ||
9 | |||
10 | MACHINE_KERNEL_PR:append = "b" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | COMPATIBLE_MACHINE = "j7" | ||
15 | |||
16 | DEPENDS = "virtual/kernel" | ||
17 | |||
18 | PROVIDES = "virtual/gpudriver" | ||
19 | |||
20 | BRANCH = "1.13-5776728/linux-k5.10" | ||
21 | |||
22 | SRC_URI = " \ | ||
23 | git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \ | ||
24 | file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \ | ||
25 | " | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | SRCREV = "35a25875ae8738f82c7cabc6b077ef992b0cca84" | ||
30 | |||
31 | PVR_SOC = "j721e_linux" | ||
32 | PVR_BVNC = "22.104.208.318" | ||
33 | PVR_BUILD = "release" | ||
34 | PVR_WS = "wayland" | ||
35 | |||
36 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${PVR_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${PVR_SOC} WINDOW_SYSTEM=${PVR_WS}' | ||
37 | |||
38 | do_install() { | ||
39 | make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${PVR_SOC}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install | ||
40 | } | ||
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb new file mode 100644 index 00000000..94b05436 --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver" | ||
3 | LICENSE = "MIT | GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2" | ||
5 | |||
6 | inherit module features_check | ||
7 | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | ||
9 | |||
10 | MACHINE_KERNEL_PR:append = "a" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | COMPATIBLE_MACHINE = "j721e|j721s2|am62xx" | ||
15 | |||
16 | DEPENDS = "virtual/kernel" | ||
17 | |||
18 | PROVIDES = "virtual/gpudriver" | ||
19 | |||
20 | BRANCH = "linuxws/dunfell/k5.10/${PV}" | ||
21 | |||
22 | SRC_URI = " \ | ||
23 | git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \ | ||
24 | file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \ | ||
25 | " | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5" | ||
30 | |||
31 | TARGET_PRODUCT:j721e = "j721e_linux" | ||
32 | TARGET_PRODUCT:j721s2 = "j721s2_linux" | ||
33 | TARGET_PRODUCT:am62xx = "am62_linux" | ||
34 | TARGET_BVNC:j721e = "22.104.208.318" | ||
35 | TARGET_BVNC:j721s2 = "36.53.104.796" | ||
36 | TARGET_BVNC:am62xx = "33.15.11.3" | ||
37 | PVR_BUILD = "release" | ||
38 | PVR_WS = "wayland" | ||
39 | |||
40 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${TARGET_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}' | ||
41 | |||
42 | do_install() { | ||
43 | make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install | ||
44 | } | ||
diff --git a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb index 18b36fbb..115344b1 100644 --- a/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.13.5776728.bb +++ b/meta-ti-bsp/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb | |||
@@ -8,17 +8,18 @@ inherit features_check | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | 8 | REQUIRED_MACHINE_FEATURES = "gpu" |
9 | 9 | ||
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 10 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
11 | COMPATIBLE_MACHINE = "j721e" | 11 | COMPATIBLE_MACHINE = "j721e|j721s2|am62xx" |
12 | 12 | ||
13 | PR = "r3" | 13 | PR = "r1" |
14 | 14 | ||
15 | BRANCH = "linuxws/dunfell/k5.10/${PV}" | 15 | BRANCH = "linuxws/dunfell/k5.10/${PV}" |
16 | 16 | ||
17 | SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" | 17 | SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" |
18 | SRCREV = "47c3ffc44f2881397d45c8a2b5dfa7d6c58b79fb" | ||
18 | 19 | ||
19 | SRCREV = "5ef38353c38d921a65ea6df75c7b6ce710b66034" | 20 | TARGET_PRODUCT:j721e = "j721e_linux" |
20 | 21 | TARGET_PRODUCT:j721s2 = "j721s2_linux" | |
21 | PVR_SOC ?= "j721e_linux" | 22 | TARGET_PRODUCT:am62xx = "am62_linux" |
22 | PVR_BUILD ?= "release" | 23 | PVR_BUILD ?= "release" |
23 | PVR_WS = "wayland" | 24 | PVR_WS = "wayland" |
24 | 25 | ||
@@ -50,7 +51,7 @@ RRECOMMENDS:${PN} += "ti-img-rogue-driver" | |||
50 | S = "${WORKDIR}/git" | 51 | S = "${WORKDIR}/git" |
51 | 52 | ||
52 | do_install () { | 53 | do_install () { |
53 | oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS} | 54 | oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS} |
54 | chown -R root:root ${D} | 55 | chown -R root:root ${D} |
55 | } | 56 | } |
56 | 57 | ||