diff options
author | Paresh Bhagat <p-bhagat@ti.com> | 2023-03-20 04:11:53 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-03-20 16:45:07 -0500 |
commit | 4829b4f0282c09b89f8a14ddf81691b42bb6c42e (patch) | |
tree | 22b10f0b85357e1d072967d996cef654ace84235 /meta-ti-bsp/recipes-ti | |
parent | e64e97b1c128352818636c5a437b0abafeec83fc (diff) | |
download | meta-ti-4829b4f0282c09b89f8a14ddf81691b42bb6c42e.tar.gz |
machine: Add am62axx evm configuration
Lets add the basic AM62Axx-evm configuration.
- Add configurations.
- Add firmware overrides.
- Add u-boot overrides.
- Add tifs-lpm-stub.
- Add cnm-wave-fw.
Signed-off-by: Sai Sree Kartheek Adivi <s-adivi@ti.com>
Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti')
-rw-r--r-- | meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 65 |
1 files changed, 44 insertions, 21 deletions
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index ddfa07be..9b94a61e 100644 --- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -20,6 +20,7 @@ PLAT_SFX:j784s4 = "j784s4" | |||
20 | PLAT_SFX:am65xx = "am65xx" | 20 | PLAT_SFX:am65xx = "am65xx" |
21 | PLAT_SFX:am64xx = "am64xx" | 21 | PLAT_SFX:am64xx = "am64xx" |
22 | PLAT_SFX:am62xx = "am62xx" | 22 | PLAT_SFX:am62xx = "am62xx" |
23 | PLAT_SFX:am62axx = "am62axx" | ||
23 | 24 | ||
24 | FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" | 25 | FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" |
25 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | 26 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
@@ -63,31 +64,34 @@ C7X_4_FW = "ipc_echo_test_c7x_4_release_strip.xe71" | |||
63 | ETH_FW = "app_remoteswitchcfg_server_strip.xer5f" | 64 | ETH_FW = "app_remoteswitchcfg_server_strip.xer5f" |
64 | 65 | ||
65 | DM_FW_LIST = "" | 66 | DM_FW_LIST = "" |
66 | DM_FW_LIST:am65xx = "" | 67 | DM_FW_LIST:am65xx = "" |
67 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" | 68 | DM_FW_LIST:j721e = "${DM_FIRMWARE}" |
68 | DM_FW_LIST:j7200 = "${DM_FIRMWARE}" | 69 | DM_FW_LIST:j7200 = "${DM_FIRMWARE}" |
69 | DM_FW_LIST:j721s2 = "${DM_FIRMWARE}" | 70 | DM_FW_LIST:j721s2 = "${DM_FIRMWARE}" |
70 | DM_FW_LIST:am64xx = "" | 71 | DM_FW_LIST:am64xx = "" |
71 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" | 72 | DM_FW_LIST:am62xx = "${DM_FIRMWARE}" |
72 | DM_FW_LIST:j784s4 = "${DM_FIRMWARE}" | 73 | DM_FW_LIST:am62axx = "${DM_FIRMWARE}" |
74 | DM_FW_LIST:j784s4 = "${DM_FIRMWARE}" | ||
73 | 75 | ||
74 | IPC_FW_LIST = "" | 76 | IPC_FW_LIST = "" |
75 | IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}" | 77 | IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}" |
76 | IPC_FW_LIST:j721e = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}" | 78 | IPC_FW_LIST:j721e = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}" |
77 | IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}" | 79 | IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}" |
78 | IPC_FW_LIST:j721s2 = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_2_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW}" | 80 | IPC_FW_LIST:j721s2 = " ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_2_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW}" |
79 | IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}" | 81 | IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}" |
80 | IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}" | 82 | IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}" |
81 | IPC_FW_LIST:j784s4 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW} ${C7X_3_FW} ${C7X_4_FW}" | 83 | IPC_FW_LIST:am62axx = " ${MCU_2_0_FW} ${C7X_1_FW}" |
84 | IPC_FW_LIST:j784s4 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C7X_1_FW} ${C7X_2_FW} ${C7X_3_FW} ${C7X_4_FW}" | ||
82 | 85 | ||
83 | ETH_FW_LIST = "" | 86 | ETH_FW_LIST = "" |
84 | ETH_FW_LIST:am65xx = "" | 87 | ETH_FW_LIST:am65xx = "" |
85 | ETH_FW_LIST:j721e = "${ETH_FW}" | 88 | ETH_FW_LIST:j721e = "${ETH_FW}" |
86 | ETH_FW_LIST:j7200 = "${ETH_FW}" | 89 | ETH_FW_LIST:j7200 = "${ETH_FW}" |
87 | ETH_FW_LIST:j721s2 = "" | 90 | ETH_FW_LIST:j721s2 = "" |
88 | ETH_FW_LIST:am64xx = "" | 91 | ETH_FW_LIST:am64xx = "" |
89 | ETH_FW_LIST:am62xx = "" | 92 | ETH_FW_LIST:am62xx = "" |
90 | ETH_FW_LIST:j784s4 = "${ETH_FW}" | 93 | ETH_FW_LIST:am62axx = "" |
94 | ETH_FW_LIST:j784s4 = "${ETH_FW}" | ||
91 | 95 | ||
92 | # Update the am64xx ipc binaries to be consistent with other platforms | 96 | # Update the am64xx ipc binaries to be consistent with other platforms |
93 | do_install:prepend:am64xx() { | 97 | do_install:prepend:am64xx() { |
@@ -107,6 +111,13 @@ do_install:prepend:am62xx() { | |||
107 | ) | 111 | ) |
108 | } | 112 | } |
109 | 113 | ||
114 | # Update the am62axx ipc binaries to be consistent with other platforms | ||
115 | do_install:prepend:am62axx() { | ||
116 | ( cd ${RTOS_IPC_FW_DIR}; \ | ||
117 | ln -s am62a-mcu-r5f0_0-fw ${MCU_1_0_FW}; \ | ||
118 | ) | ||
119 | } | ||
120 | |||
110 | # Sign the firmware | 121 | # Sign the firmware |
111 | do_install:prepend() { | 122 | do_install:prepend() { |
112 | # DM Firmware | 123 | # DM Firmware |
@@ -183,6 +194,11 @@ ALTERNATIVE:${PN}:am62xx = "\ | |||
183 | am62-main-r5f0_0-fw \ | 194 | am62-main-r5f0_0-fw \ |
184 | " | 195 | " |
185 | 196 | ||
197 | ALTERNATIVE:${PN}:am62axx = "\ | ||
198 | am62a-mcu-r5f0_0-fw \ | ||
199 | am62a-c71_0-fw \ | ||
200 | " | ||
201 | |||
186 | ALTERNATIVE:${PN}:j721e = "\ | 202 | ALTERNATIVE:${PN}:j721e = "\ |
187 | j7-mcu-r5f0_0-fw \ | 203 | j7-mcu-r5f0_0-fw \ |
188 | j7-mcu-r5f0_1-fw \ | 204 | j7-mcu-r5f0_1-fw \ |
@@ -257,6 +273,9 @@ ALTERNATIVE_LINK_NAME[am64-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am6 | |||
257 | ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" | 273 | ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" |
258 | ALTERNATIVE_LINK_NAME[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-mcu-m4f0_0-fw" | 274 | ALTERNATIVE_LINK_NAME[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-mcu-m4f0_0-fw" |
259 | 275 | ||
276 | ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw" | ||
277 | ALTERNATIVE_LINK_NAME[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/am62a-c71_0-fw" | ||
278 | |||
260 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw" | 279 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw" |
261 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_1-fw" | 280 | ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_1-fw" |
262 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-main-r5f0_0-fw" | 281 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-main-r5f0_0-fw" |
@@ -326,6 +345,10 @@ ALTERNATIVE_TARGET[am64-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ip | |||
326 | ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | 345 | ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" |
327 | ALTERNATIVE_TARGET[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" | 346 | ALTERNATIVE_TARGET[am62-mcu-m4f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" |
328 | 347 | ||
348 | ALTERNATIVE_TARGET[am62a-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | ||
349 | ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_2_0_FW}" | ||
350 | ALTERNATIVE_TARGET[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${C7X_1_FW}" | ||
351 | |||
329 | ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" | 352 | ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE}" |
330 | ALTERNATIVE_TARGET[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_1_1_FW}" | 353 | ALTERNATIVE_TARGET[j7-mcu-r5f0_1-fw] = "${nonarch_base_libdir}/firmware/pdk-ipc/${MCU_1_1_FW}" |
331 | ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/ethfw/${ETH_FW}" | 354 | ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/ethfw/${ETH_FW}" |