diff options
author | Aparna M <a-m1@ti.com> | 2022-09-13 03:54:38 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-09-22 11:23:07 -0500 |
commit | 25b110448a989cf1a865859166427f86275223c9 (patch) | |
tree | 1a2c287ceb3d93913d362f8e1f846b92e9c74043 /meta-ti-bsp/recipes-ti | |
parent | e210d36ad1a214df08039ebf8a6cb16fa23eea4a (diff) | |
download | meta-ti-25b110448a989cf1a865859166427f86275223c9.tar.gz |
ti-tros-firmware: Add DM firmware binary to deploy directory for am62xx-evm
The DM firmware binary is required for building uboot binaries for
am62xx-evm using toplevel makefile in SDK. Add this file to deploy
directory so it can be included in prebuilt-images directory of SDK
for am62xx-evm.
Signed-off-by: Aparna M <a-m1@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti')
-rw-r--r-- | meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index 93429570..317ff4c4 100644 --- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -167,6 +167,16 @@ do_install:am62xx() { | |||
167 | install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} | 167 | install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR} |
168 | } | 168 | } |
169 | 169 | ||
170 | |||
171 | do_deploy() { | ||
172 | install -d ${DEPLOYDIR} | ||
173 | } | ||
174 | |||
175 | do_deploy:am62xx() { | ||
176 | install -d ${DEPLOYDIR} | ||
177 | install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${DEPLOYDIR} | ||
178 | } | ||
179 | |||
170 | # Set up names for the firmwares | 180 | # Set up names for the firmwares |
171 | ALTERNATIVE:${PN}:am65xx = "\ | 181 | ALTERNATIVE:${PN}:am65xx = "\ |
172 | am65x-mcu-r5f0_0-fw \ | 182 | am65x-mcu-r5f0_0-fw \ |
@@ -355,3 +365,5 @@ INSANE_SKIP:${PN} += "arch" | |||
355 | # we don't want to configure and build the source code | 365 | # we don't want to configure and build the source code |
356 | do_compile[noexec] = "1" | 366 | do_compile[noexec] = "1" |
357 | do_configure[noexec] = "1" | 367 | do_configure[noexec] = "1" |
368 | |||
369 | addtask deploy after do_install | ||