diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-22 04:13:45 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-22 12:01:38 -0600 |
commit | 20f3191aeb592dd889eeaf96a31526297de95306 (patch) | |
tree | aec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb | |
parent | bea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff) | |
download | meta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz |
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r-- | meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb new file mode 100644 index 00000000..bcc8674e --- /dev/null +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux" | ||
2 | require ti-ipc-examples.inc | ||
3 | |||
4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" | ||
5 | |||
6 | do_compile:append() { | ||
7 | |||
8 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | ||
9 | oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
10 | |||
11 | for alt_platform in ${ALT_PLATFORM}; do | ||
12 | oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \ | ||
13 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
14 | done | ||
15 | oe_runmake -C examples all HOSTOS="bios" \ | ||
16 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" | ||
17 | for alt_platform in ${ALT_PLATFORM}; do | ||
18 | oe_runmake -C examples all HOSTOS="bios" \ | ||
19 | IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}" | ||
20 | done | ||
21 | fi | ||
22 | } | ||
23 | |||
24 | do_install:append() { | ||
25 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | ||
26 | # Install directory for bios examples | ||
27 | install -d ${D}/ipc_${IPC_VERSION}/examples/bios | ||
28 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
29 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" | ||
30 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
31 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" | ||
32 | |||
33 | for alt_platform in ${ALT_PLATFORM}; do | ||
34 | oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
35 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \ | ||
36 | PLATFORM="${alt_platform}" | ||
37 | oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ | ||
38 | HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \ | ||
39 | PLATFORM="${alt_platform}" | ||
40 | done | ||
41 | fi | ||
42 | } | ||
43 | |||
44 | FILES:${PN} += "ipc_*" | ||