summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb')
-rw-r--r--meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb b/meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb
new file mode 100644
index 00000000..ceefe0d6
--- /dev/null
+++ b/meta-ti-bsp/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Userspace setup for beaglebone capes"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6PR = "r4"
7
8inherit allarch
9
10SRC_URI = "file://cape.service \
11 file://cape.sh \
12 file://cape-stop.sh \
13 "
14
15do_install() {
16 install -d ${D}${base_libdir}/systemd/system/
17 install -m 0644 ${WORKDIR}/cape.service ${D}${base_libdir}/systemd/system
18
19 install -d ${D}${base_libdir}/systemd/system/basic.target.wants
20 ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/
21
22 install -d ${D}${bindir}
23 install -m 0755 ${WORKDIR}/cape*.sh ${D}${bindir}
24}
25
26FILES:${PN} += "${base_libdir}/systemd/system"