diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2023-06-13 21:18:42 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-06-14 10:01:45 -0500 |
commit | 4c5461c23708d9f235976f25acd95cd30114af7e (patch) | |
tree | 1e983f4eeaa762821f2cc99b25c470d951101aff /meta-ti-bsp/recipes-security | |
parent | a0ce9c392faf09dce4452d48fb00039ad023ad42 (diff) | |
download | meta-ti-4c5461c23708d9f235976f25acd95cd30114af7e.tar.gz |
optee: local fix for stray CFG_MAP_EXT_DT_SECURE=y in meta-arm
Latest update in meta-arm added unconditional CFG_MAP_EXT_DT_SECURE=y
that affects all platforms, but was only needed for qemu. And it also
depends on CFG_DT=y, which is platform-specific. The fix was submitted
upstream[0], overlay it locally until upstream resolves it.
[0] https://patchwork.yoctoproject.org/project/arm/patch/20230613181723.1711212-1-denis@denix.org/
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-security')
3 files changed, 7 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit-ti.inc new file mode 100644 index 00000000..df46e243 --- /dev/null +++ b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit-ti.inc | |||
@@ -0,0 +1 @@ | |||
EXTRA_OEMAKE:remove = "CFG_MAP_EXT_DT_SECURE=y" | |||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend new file mode 100644 index 00000000..08c5256b --- /dev/null +++ b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | OPTEE_TI = "" | ||
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | ||
3 | |||
4 | require ${OPTEE_TI} | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc index 20f88127..1f898a6d 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc | |||
@@ -1,6 +1,8 @@ | |||
1 | # Use TI SECDEV for signing | 1 | # Use TI SECDEV for signing |
2 | inherit ti-secdev | 2 | inherit ti-secdev |
3 | 3 | ||
4 | EXTRA_OEMAKE:remove = "CFG_MAP_EXT_DT_SECURE=y" | ||
5 | |||
4 | EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" | 6 | EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" |
5 | 7 | ||
6 | EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1" | 8 | EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1" |