summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-security
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-03-20 11:24:17 +0000
committerRyan Eatmon <reatmon@ti.com>2023-03-21 13:03:29 -0500
commit05fb51715fac1f00ce9a71d66fe944ae31c30107 (patch)
tree1d3e8313a808df72dcc5e42d8c1bab96dd5068e2 /meta-ti-bsp/recipes-security
parent2857a0abe3ad03f3b617ddf18cbd00a0aacc1073 (diff)
downloadmeta-ti-05fb51715fac1f00ce9a71d66fe944ae31c30107.tar.gz
optee-os-tadevkit: update to match optee-os
This installs shared OPTEE-OS APIs and needs to match in order for latest client/test/examples to be able to build. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-security')
-rw-r--r--meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_3.20.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_3.20.0.bb b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_3.20.0.bb
new file mode 100644
index 00000000..f2cc06d8
--- /dev/null
+++ b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_3.20.0.bb
@@ -0,0 +1,24 @@
1require recipes-security/optee/optee-os_3.20.0.bb
2
3SUMMARY = "OP-TEE Trusted OS TA devkit"
4DESCRIPTION = "OP-TEE TA devkit for build TAs"
5HOMEPAGE = "https://www.op-tee.org/"
6
7DEPENDS += "python3-pycryptodome-native"
8
9do_install() {
10 #install TA devkit
11 install -d ${D}${includedir}/optee/export-user_ta/
12 for f in ${B}/export-ta_${OPTEE_ARCH}/* ; do
13 cp -aR $f ${D}${includedir}/optee/export-user_ta/
14 done
15}
16
17do_deploy() {
18 echo "Do not inherit do_deploy from optee-os."
19}
20
21FILES:${PN} = "${includedir}/optee/"
22
23# Build paths are currently embedded
24INSANE_SKIP:${PN}-dev += "buildpaths"