summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-10-23 22:38:16 +0000
committerRyan Eatmon <reatmon@ti.com>2023-10-24 09:56:29 -0500
commit242846833a9f1b05b95fb9335ed01668bc0eef7e (patch)
tree363a0d6bcb5e22607ac7ead800701a4b23cb0cfc /meta-ti-bsp/recipes-kernel
parent9aef8115192fc78f6af76c4f4152d67fd7638796 (diff)
downloadmeta-ti-242846833a9f1b05b95fb9335ed01668bc0eef7e.tar.gz
conf: machine: move RDEPENDS and RRECOMMENDS from kernel-rdepends.inc
Instead of making kernel RDEPENDS on devicetree and different FW images with lots of machine-override appends that are hard to modify downstream, use proper MACHINE_ESSENTIAL_EXTRA_RDEPENDS and MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS vars that are specifically designed for this purpose. This also makes such dependencies generic and not tied to a particular kernel recipe including kernel-rdepends.inc with the entire machine-specific list. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Acked-by: Andrew Davis <afd@ti.com> Acked-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc38
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb1
4 files changed, 0 insertions, 41 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
deleted file mode 100644
index 266a7ef5..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ /dev/null
@@ -1,38 +0,0 @@
1# Pull in the devicetree files into the rootfs
2RDEPENDS:${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree"
3
4# Add run-time dependency for PM firmware to the rootfs
5RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " amx3-cm3"
6RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " amx3-cm3"
7
8# Add run-time dependency for VPE VPDMA firmware to the rootfs
9RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " vpdma-fw"
10
11# Add run-time dependency for Goodix firmware to the rootfs
12RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:dra7xx = " goodix-fw"
13
14# Add run-time dependency for PRU Ethernet firmware to the rootfs
15RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr-fw pruprp-fw"
16RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
17RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
18RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
19RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
20RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
21
22# Add run-time dependency for Cadence MHDP firmware to the rootfs
23RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw"
24RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw"
25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw"
26
27# Add run-time dependency for Video Decoding firmware to the rootfs
28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
29
30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
32RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw"
33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " cnm-wave-fw"
34
35# Add run-time dependency for TI ETH firmware to the rootfs
36RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " ti-eth-fw"
37RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7200 = " ti-eth-fw"
38RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " ti-eth-fw"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
index dfa46f48..a7b5ca74 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6inherit kernel 6inherit kernel
7 7
8require recipes-kernel/linux/kernel-rdepends.inc
9require recipes-kernel/linux/ti-kernel.inc 8require recipes-kernel/linux/ti-kernel.inc
10 9
11DEPENDS += "gmp-native libmpc-native" 10DEPENDS += "gmp-native libmpc-native"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index 7f3911e4..0cf0a319 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -9,7 +9,6 @@ inherit kernel
9 9
10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
11require recipes-kernel/linux/setup-defconfig.inc 11require recipes-kernel/linux/setup-defconfig.inc
12require recipes-kernel/linux/kernel-rdepends.inc
13require recipes-kernel/linux/ti-kernel.inc 12require recipes-kernel/linux/ti-kernel.inc
14include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 13include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
15 14
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index 66be6944..ee106a7f 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -7,7 +7,6 @@ inherit ti-secdev
7inherit kernel 7inherit kernel
8 8
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/kernel-rdepends.inc
11require recipes-kernel/linux/ti-kernel.inc 10require recipes-kernel/linux/ti-kernel.inc
12include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
13include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''} 12include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}