diff options
author | Andrew Davis <afd@ti.com> | 2023-11-08 10:58:30 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-11-14 11:57:07 -0600 |
commit | dc51c0878b365c4b22c84bb3667425fdd6edf298 (patch) | |
tree | 3c6bedc06c0be8d1eb32a9ae95d2f3e392c36729 /meta-ti-bsp/recipes-kernel | |
parent | 9efb0c6fc4f5089f4f2a305c2823dba311505487 (diff) | |
download | meta-ti-dc51c0878b365c4b22c84bb3667425fdd6edf298.tar.gz |
linux-ti-staging: Remove kernel v5.10 packages
We support Linux v6.1 as our official version for Kirkstone. The older
kernel version was kept around during the transition to the newer version,
but we are past that now. Remove this old version.
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel')
21 files changed, 0 insertions, 430 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/0001-ata-ahci-fix-enum-constants-for-gcc-13.patch b/meta-ti-bsp/recipes-kernel/linux/files/0001-ata-ahci-fix-enum-constants-for-gcc-13.patch deleted file mode 100644 index 634b1588..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/files/0001-ata-ahci-fix-enum-constants-for-gcc-13.patch +++ /dev/null | |||
@@ -1,351 +0,0 @@ | |||
1 | From f07788079f515ca4a681c5f595bdad19cfbd7b1d Mon Sep 17 00:00:00 2001 | ||
2 | From: Arnd Bergmann <arnd@arndb.de> | ||
3 | Date: Sat, 3 Dec 2022 11:54:25 +0100 | ||
4 | Subject: [PATCH] ata: ahci: fix enum constants for gcc-13 | ||
5 | |||
6 | gcc-13 slightly changes the type of constant expressions that are defined | ||
7 | in an enum, which triggers a compile time sanity check in libata: | ||
8 | |||
9 | linux/drivers/ata/libahci.c: In function 'ahci_led_store': | ||
10 | linux/include/linux/compiler_types.h:357:45: error: call to '__compiletime_assert_302' declared with attribute error: BUILD_BUG_ON failed: sizeof(_s) > sizeof(long) | ||
11 | 357 | _compiletime_assert(condition, msg, __compiletime_assert_, __COUNTER__) | ||
12 | |||
13 | The new behavior is that sizeof() returns the same value for the | ||
14 | constant as it does for the enum type, which is generally more sensible | ||
15 | and consistent. | ||
16 | |||
17 | The problem in libata is that it contains a single enum definition for | ||
18 | lots of unrelated constants, some of which are large positive (unsigned) | ||
19 | integers like 0xffffffff, while others like (1<<31) are interpreted as | ||
20 | negative integers, and this forces the enum type to become 64 bit wide | ||
21 | even though most constants would still fit into a signed 32-bit 'int'. | ||
22 | |||
23 | Fix this by changing the entire enum definition to use BIT(x) in place | ||
24 | of (1<<x), which results in all values being seen as 'unsigned' and | ||
25 | fitting into an unsigned 32-bit type. | ||
26 | |||
27 | Link: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107917 | ||
28 | Link: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=107405 | ||
29 | Reported-by: Luis Machado <luis.machado@arm.com> | ||
30 | Cc: linux-ide@vger.kernel.org | ||
31 | Cc: Damien Le Moal <damien.lemoal@opensource.wdc.com> | ||
32 | Cc: stable@vger.kernel.org | ||
33 | Cc: Randy Dunlap <rdunlap@infradead.org> | ||
34 | Signed-off-by: Arnd Bergmann <arnd@arndb.de> | ||
35 | Tested-by: Luis Machado <luis.machado@arm.com> | ||
36 | Signed-off-by: Damien Le Moal <damien.lemoal@opensource.wdc.com> | ||
37 | --- | ||
38 | drivers/ata/ahci.h | 245 +++++++++++++++++++++++---------------------- | ||
39 | 1 file changed, 123 insertions(+), 122 deletions(-) | ||
40 | |||
41 | --- a/drivers/ata/ahci.h | ||
42 | +++ b/drivers/ata/ahci.h | ||
43 | @@ -24,6 +24,7 @@ | ||
44 | #include <linux/libata.h> | ||
45 | #include <linux/phy/phy.h> | ||
46 | #include <linux/regulator/consumer.h> | ||
47 | +#include <linux/bits.h> | ||
48 | |||
49 | /* Enclosure Management Control */ | ||
50 | #define EM_CTRL_MSG_TYPE 0x000f0000 | ||
51 | @@ -54,12 +55,12 @@ enum { | ||
52 | AHCI_PORT_PRIV_FBS_DMA_SZ = AHCI_CMD_SLOT_SZ + | ||
53 | AHCI_CMD_TBL_AR_SZ + | ||
54 | (AHCI_RX_FIS_SZ * 16), | ||
55 | - AHCI_IRQ_ON_SG = (1 << 31), | ||
56 | - AHCI_CMD_ATAPI = (1 << 5), | ||
57 | - AHCI_CMD_WRITE = (1 << 6), | ||
58 | - AHCI_CMD_PREFETCH = (1 << 7), | ||
59 | - AHCI_CMD_RESET = (1 << 8), | ||
60 | - AHCI_CMD_CLR_BUSY = (1 << 10), | ||
61 | + AHCI_IRQ_ON_SG = BIT(31), | ||
62 | + AHCI_CMD_ATAPI = BIT(5), | ||
63 | + AHCI_CMD_WRITE = BIT(6), | ||
64 | + AHCI_CMD_PREFETCH = BIT(7), | ||
65 | + AHCI_CMD_RESET = BIT(8), | ||
66 | + AHCI_CMD_CLR_BUSY = BIT(10), | ||
67 | |||
68 | RX_FIS_PIO_SETUP = 0x20, /* offset of PIO Setup FIS data */ | ||
69 | RX_FIS_D2H_REG = 0x40, /* offset of D2H Register FIS data */ | ||
70 | @@ -77,37 +78,37 @@ enum { | ||
71 | HOST_CAP2 = 0x24, /* host capabilities, extended */ | ||
72 | |||
73 | /* HOST_CTL bits */ | ||
74 | - HOST_RESET = (1 << 0), /* reset controller; self-clear */ | ||
75 | - HOST_IRQ_EN = (1 << 1), /* global IRQ enable */ | ||
76 | - HOST_MRSM = (1 << 2), /* MSI Revert to Single Message */ | ||
77 | - HOST_AHCI_EN = (1 << 31), /* AHCI enabled */ | ||
78 | + HOST_RESET = BIT(0), /* reset controller; self-clear */ | ||
79 | + HOST_IRQ_EN = BIT(1), /* global IRQ enable */ | ||
80 | + HOST_MRSM = BIT(2), /* MSI Revert to Single Message */ | ||
81 | + HOST_AHCI_EN = BIT(31), /* AHCI enabled */ | ||
82 | |||
83 | /* HOST_CAP bits */ | ||
84 | - HOST_CAP_SXS = (1 << 5), /* Supports External SATA */ | ||
85 | - HOST_CAP_EMS = (1 << 6), /* Enclosure Management support */ | ||
86 | - HOST_CAP_CCC = (1 << 7), /* Command Completion Coalescing */ | ||
87 | - HOST_CAP_PART = (1 << 13), /* Partial state capable */ | ||
88 | - HOST_CAP_SSC = (1 << 14), /* Slumber state capable */ | ||
89 | - HOST_CAP_PIO_MULTI = (1 << 15), /* PIO multiple DRQ support */ | ||
90 | - HOST_CAP_FBS = (1 << 16), /* FIS-based switching support */ | ||
91 | - HOST_CAP_PMP = (1 << 17), /* Port Multiplier support */ | ||
92 | - HOST_CAP_ONLY = (1 << 18), /* Supports AHCI mode only */ | ||
93 | - HOST_CAP_CLO = (1 << 24), /* Command List Override support */ | ||
94 | - HOST_CAP_LED = (1 << 25), /* Supports activity LED */ | ||
95 | - HOST_CAP_ALPM = (1 << 26), /* Aggressive Link PM support */ | ||
96 | - HOST_CAP_SSS = (1 << 27), /* Staggered Spin-up */ | ||
97 | - HOST_CAP_MPS = (1 << 28), /* Mechanical presence switch */ | ||
98 | - HOST_CAP_SNTF = (1 << 29), /* SNotification register */ | ||
99 | - HOST_CAP_NCQ = (1 << 30), /* Native Command Queueing */ | ||
100 | - HOST_CAP_64 = (1 << 31), /* PCI DAC (64-bit DMA) support */ | ||
101 | + HOST_CAP_SXS = BIT(5), /* Supports External SATA */ | ||
102 | + HOST_CAP_EMS = BIT(6), /* Enclosure Management support */ | ||
103 | + HOST_CAP_CCC = BIT(7), /* Command Completion Coalescing */ | ||
104 | + HOST_CAP_PART = BIT(13), /* Partial state capable */ | ||
105 | + HOST_CAP_SSC = BIT(14), /* Slumber state capable */ | ||
106 | + HOST_CAP_PIO_MULTI = BIT(15), /* PIO multiple DRQ support */ | ||
107 | + HOST_CAP_FBS = BIT(16), /* FIS-based switching support */ | ||
108 | + HOST_CAP_PMP = BIT(17), /* Port Multiplier support */ | ||
109 | + HOST_CAP_ONLY = BIT(18), /* Supports AHCI mode only */ | ||
110 | + HOST_CAP_CLO = BIT(24), /* Command List Override support */ | ||
111 | + HOST_CAP_LED = BIT(25), /* Supports activity LED */ | ||
112 | + HOST_CAP_ALPM = BIT(26), /* Aggressive Link PM support */ | ||
113 | + HOST_CAP_SSS = BIT(27), /* Staggered Spin-up */ | ||
114 | + HOST_CAP_MPS = BIT(28), /* Mechanical presence switch */ | ||
115 | + HOST_CAP_SNTF = BIT(29), /* SNotification register */ | ||
116 | + HOST_CAP_NCQ = BIT(30), /* Native Command Queueing */ | ||
117 | + HOST_CAP_64 = BIT(31), /* PCI DAC (64-bit DMA) support */ | ||
118 | |||
119 | /* HOST_CAP2 bits */ | ||
120 | - HOST_CAP2_BOH = (1 << 0), /* BIOS/OS handoff supported */ | ||
121 | - HOST_CAP2_NVMHCI = (1 << 1), /* NVMHCI supported */ | ||
122 | - HOST_CAP2_APST = (1 << 2), /* Automatic partial to slumber */ | ||
123 | - HOST_CAP2_SDS = (1 << 3), /* Support device sleep */ | ||
124 | - HOST_CAP2_SADM = (1 << 4), /* Support aggressive DevSlp */ | ||
125 | - HOST_CAP2_DESO = (1 << 5), /* DevSlp from slumber only */ | ||
126 | + HOST_CAP2_BOH = BIT(0), /* BIOS/OS handoff supported */ | ||
127 | + HOST_CAP2_NVMHCI = BIT(1), /* NVMHCI supported */ | ||
128 | + HOST_CAP2_APST = BIT(2), /* Automatic partial to slumber */ | ||
129 | + HOST_CAP2_SDS = BIT(3), /* Support device sleep */ | ||
130 | + HOST_CAP2_SADM = BIT(4), /* Support aggressive DevSlp */ | ||
131 | + HOST_CAP2_DESO = BIT(5), /* DevSlp from slumber only */ | ||
132 | |||
133 | /* registers for each SATA port */ | ||
134 | PORT_LST_ADDR = 0x00, /* command list DMA addr */ | ||
135 | @@ -129,24 +130,24 @@ enum { | ||
136 | PORT_DEVSLP = 0x44, /* device sleep */ | ||
137 | |||
138 | /* PORT_IRQ_{STAT,MASK} bits */ | ||
139 | - PORT_IRQ_COLD_PRES = (1 << 31), /* cold presence detect */ | ||
140 | - PORT_IRQ_TF_ERR = (1 << 30), /* task file error */ | ||
141 | - PORT_IRQ_HBUS_ERR = (1 << 29), /* host bus fatal error */ | ||
142 | - PORT_IRQ_HBUS_DATA_ERR = (1 << 28), /* host bus data error */ | ||
143 | - PORT_IRQ_IF_ERR = (1 << 27), /* interface fatal error */ | ||
144 | - PORT_IRQ_IF_NONFATAL = (1 << 26), /* interface non-fatal error */ | ||
145 | - PORT_IRQ_OVERFLOW = (1 << 24), /* xfer exhausted available S/G */ | ||
146 | - PORT_IRQ_BAD_PMP = (1 << 23), /* incorrect port multiplier */ | ||
147 | - | ||
148 | - PORT_IRQ_PHYRDY = (1 << 22), /* PhyRdy changed */ | ||
149 | - PORT_IRQ_DEV_ILCK = (1 << 7), /* device interlock */ | ||
150 | - PORT_IRQ_CONNECT = (1 << 6), /* port connect change status */ | ||
151 | - PORT_IRQ_SG_DONE = (1 << 5), /* descriptor processed */ | ||
152 | - PORT_IRQ_UNK_FIS = (1 << 4), /* unknown FIS rx'd */ | ||
153 | - PORT_IRQ_SDB_FIS = (1 << 3), /* Set Device Bits FIS rx'd */ | ||
154 | - PORT_IRQ_DMAS_FIS = (1 << 2), /* DMA Setup FIS rx'd */ | ||
155 | - PORT_IRQ_PIOS_FIS = (1 << 1), /* PIO Setup FIS rx'd */ | ||
156 | - PORT_IRQ_D2H_REG_FIS = (1 << 0), /* D2H Register FIS rx'd */ | ||
157 | + PORT_IRQ_COLD_PRES = BIT(31), /* cold presence detect */ | ||
158 | + PORT_IRQ_TF_ERR = BIT(30), /* task file error */ | ||
159 | + PORT_IRQ_HBUS_ERR = BIT(29), /* host bus fatal error */ | ||
160 | + PORT_IRQ_HBUS_DATA_ERR = BIT(28), /* host bus data error */ | ||
161 | + PORT_IRQ_IF_ERR = BIT(27), /* interface fatal error */ | ||
162 | + PORT_IRQ_IF_NONFATAL = BIT(26), /* interface non-fatal error */ | ||
163 | + PORT_IRQ_OVERFLOW = BIT(24), /* xfer exhausted available S/G */ | ||
164 | + PORT_IRQ_BAD_PMP = BIT(23), /* incorrect port multiplier */ | ||
165 | + | ||
166 | + PORT_IRQ_PHYRDY = BIT(22), /* PhyRdy changed */ | ||
167 | + PORT_IRQ_DEV_ILCK = BIT(7), /* device interlock */ | ||
168 | + PORT_IRQ_CONNECT = BIT(6), /* port connect change status */ | ||
169 | + PORT_IRQ_SG_DONE = BIT(5), /* descriptor processed */ | ||
170 | + PORT_IRQ_UNK_FIS = BIT(4), /* unknown FIS rx'd */ | ||
171 | + PORT_IRQ_SDB_FIS = BIT(3), /* Set Device Bits FIS rx'd */ | ||
172 | + PORT_IRQ_DMAS_FIS = BIT(2), /* DMA Setup FIS rx'd */ | ||
173 | + PORT_IRQ_PIOS_FIS = BIT(1), /* PIO Setup FIS rx'd */ | ||
174 | + PORT_IRQ_D2H_REG_FIS = BIT(0), /* D2H Register FIS rx'd */ | ||
175 | |||
176 | PORT_IRQ_FREEZE = PORT_IRQ_HBUS_ERR | | ||
177 | PORT_IRQ_IF_ERR | | ||
178 | @@ -162,34 +163,34 @@ enum { | ||
179 | PORT_IRQ_PIOS_FIS | PORT_IRQ_D2H_REG_FIS, | ||
180 | |||
181 | /* PORT_CMD bits */ | ||
182 | - PORT_CMD_ASP = (1 << 27), /* Aggressive Slumber/Partial */ | ||
183 | - PORT_CMD_ALPE = (1 << 26), /* Aggressive Link PM enable */ | ||
184 | - PORT_CMD_ATAPI = (1 << 24), /* Device is ATAPI */ | ||
185 | - PORT_CMD_FBSCP = (1 << 22), /* FBS Capable Port */ | ||
186 | - PORT_CMD_ESP = (1 << 21), /* External Sata Port */ | ||
187 | - PORT_CMD_HPCP = (1 << 18), /* HotPlug Capable Port */ | ||
188 | - PORT_CMD_PMP = (1 << 17), /* PMP attached */ | ||
189 | - PORT_CMD_LIST_ON = (1 << 15), /* cmd list DMA engine running */ | ||
190 | - PORT_CMD_FIS_ON = (1 << 14), /* FIS DMA engine running */ | ||
191 | - PORT_CMD_FIS_RX = (1 << 4), /* Enable FIS receive DMA engine */ | ||
192 | - PORT_CMD_CLO = (1 << 3), /* Command list override */ | ||
193 | - PORT_CMD_POWER_ON = (1 << 2), /* Power up device */ | ||
194 | - PORT_CMD_SPIN_UP = (1 << 1), /* Spin up device */ | ||
195 | - PORT_CMD_START = (1 << 0), /* Enable port DMA engine */ | ||
196 | - | ||
197 | - PORT_CMD_ICC_MASK = (0xf << 28), /* i/f ICC state mask */ | ||
198 | - PORT_CMD_ICC_ACTIVE = (0x1 << 28), /* Put i/f in active state */ | ||
199 | - PORT_CMD_ICC_PARTIAL = (0x2 << 28), /* Put i/f in partial state */ | ||
200 | - PORT_CMD_ICC_SLUMBER = (0x6 << 28), /* Put i/f in slumber state */ | ||
201 | + PORT_CMD_ASP = BIT(27), /* Aggressive Slumber/Partial */ | ||
202 | + PORT_CMD_ALPE = BIT(26), /* Aggressive Link PM enable */ | ||
203 | + PORT_CMD_ATAPI = BIT(24), /* Device is ATAPI */ | ||
204 | + PORT_CMD_FBSCP = BIT(22), /* FBS Capable Port */ | ||
205 | + PORT_CMD_ESP = BIT(21), /* External Sata Port */ | ||
206 | + PORT_CMD_HPCP = BIT(18), /* HotPlug Capable Port */ | ||
207 | + PORT_CMD_PMP = BIT(17), /* PMP attached */ | ||
208 | + PORT_CMD_LIST_ON = BIT(15), /* cmd list DMA engine running */ | ||
209 | + PORT_CMD_FIS_ON = BIT(14), /* FIS DMA engine running */ | ||
210 | + PORT_CMD_FIS_RX = BIT(4), /* Enable FIS receive DMA engine */ | ||
211 | + PORT_CMD_CLO = BIT(3), /* Command list override */ | ||
212 | + PORT_CMD_POWER_ON = BIT(2), /* Power up device */ | ||
213 | + PORT_CMD_SPIN_UP = BIT(1), /* Spin up device */ | ||
214 | + PORT_CMD_START = BIT(0), /* Enable port DMA engine */ | ||
215 | + | ||
216 | + PORT_CMD_ICC_MASK = (0xfu << 28), /* i/f ICC state mask */ | ||
217 | + PORT_CMD_ICC_ACTIVE = (0x1u << 28), /* Put i/f in active state */ | ||
218 | + PORT_CMD_ICC_PARTIAL = (0x2u << 28), /* Put i/f in partial state */ | ||
219 | + PORT_CMD_ICC_SLUMBER = (0x6u << 28), /* Put i/f in slumber state */ | ||
220 | |||
221 | /* PORT_FBS bits */ | ||
222 | PORT_FBS_DWE_OFFSET = 16, /* FBS device with error offset */ | ||
223 | PORT_FBS_ADO_OFFSET = 12, /* FBS active dev optimization offset */ | ||
224 | PORT_FBS_DEV_OFFSET = 8, /* FBS device to issue offset */ | ||
225 | PORT_FBS_DEV_MASK = (0xf << PORT_FBS_DEV_OFFSET), /* FBS.DEV */ | ||
226 | - PORT_FBS_SDE = (1 << 2), /* FBS single device error */ | ||
227 | - PORT_FBS_DEC = (1 << 1), /* FBS device error clear */ | ||
228 | - PORT_FBS_EN = (1 << 0), /* Enable FBS */ | ||
229 | + PORT_FBS_SDE = BIT(2), /* FBS single device error */ | ||
230 | + PORT_FBS_DEC = BIT(1), /* FBS device error clear */ | ||
231 | + PORT_FBS_EN = BIT(0), /* Enable FBS */ | ||
232 | |||
233 | /* PORT_DEVSLP bits */ | ||
234 | PORT_DEVSLP_DM_OFFSET = 25, /* DITO multiplier offset */ | ||
235 | @@ -197,52 +198,52 @@ enum { | ||
236 | PORT_DEVSLP_DITO_OFFSET = 15, /* DITO offset */ | ||
237 | PORT_DEVSLP_MDAT_OFFSET = 10, /* Minimum assertion time */ | ||
238 | PORT_DEVSLP_DETO_OFFSET = 2, /* DevSlp exit timeout */ | ||
239 | - PORT_DEVSLP_DSP = (1 << 1), /* DevSlp present */ | ||
240 | - PORT_DEVSLP_ADSE = (1 << 0), /* Aggressive DevSlp enable */ | ||
241 | + PORT_DEVSLP_DSP = BIT(1), /* DevSlp present */ | ||
242 | + PORT_DEVSLP_ADSE = BIT(0), /* Aggressive DevSlp enable */ | ||
243 | |||
244 | /* hpriv->flags bits */ | ||
245 | |||
246 | #define AHCI_HFLAGS(flags) .private_data = (void *)(flags) | ||
247 | |||
248 | - AHCI_HFLAG_NO_NCQ = (1 << 0), | ||
249 | - AHCI_HFLAG_IGN_IRQ_IF_ERR = (1 << 1), /* ignore IRQ_IF_ERR */ | ||
250 | - AHCI_HFLAG_IGN_SERR_INTERNAL = (1 << 2), /* ignore SERR_INTERNAL */ | ||
251 | - AHCI_HFLAG_32BIT_ONLY = (1 << 3), /* force 32bit */ | ||
252 | - AHCI_HFLAG_MV_PATA = (1 << 4), /* PATA port */ | ||
253 | - AHCI_HFLAG_NO_MSI = (1 << 5), /* no PCI MSI */ | ||
254 | - AHCI_HFLAG_NO_PMP = (1 << 6), /* no PMP */ | ||
255 | - AHCI_HFLAG_SECT255 = (1 << 8), /* max 255 sectors */ | ||
256 | - AHCI_HFLAG_YES_NCQ = (1 << 9), /* force NCQ cap on */ | ||
257 | - AHCI_HFLAG_NO_SUSPEND = (1 << 10), /* don't suspend */ | ||
258 | - AHCI_HFLAG_SRST_TOUT_IS_OFFLINE = (1 << 11), /* treat SRST timeout as | ||
259 | + AHCI_HFLAG_NO_NCQ = BIT(0), | ||
260 | + AHCI_HFLAG_IGN_IRQ_IF_ERR = BIT(1), /* ignore IRQ_IF_ERR */ | ||
261 | + AHCI_HFLAG_IGN_SERR_INTERNAL = BIT(2), /* ignore SERR_INTERNAL */ | ||
262 | + AHCI_HFLAG_32BIT_ONLY = BIT(3), /* force 32bit */ | ||
263 | + AHCI_HFLAG_MV_PATA = BIT(4), /* PATA port */ | ||
264 | + AHCI_HFLAG_NO_MSI = BIT(5), /* no PCI MSI */ | ||
265 | + AHCI_HFLAG_NO_PMP = BIT(6), /* no PMP */ | ||
266 | + AHCI_HFLAG_SECT255 = BIT(8), /* max 255 sectors */ | ||
267 | + AHCI_HFLAG_YES_NCQ = BIT(9), /* force NCQ cap on */ | ||
268 | + AHCI_HFLAG_NO_SUSPEND = BIT(10), /* don't suspend */ | ||
269 | + AHCI_HFLAG_SRST_TOUT_IS_OFFLINE = BIT(11), /* treat SRST timeout as | ||
270 | link offline */ | ||
271 | - AHCI_HFLAG_NO_SNTF = (1 << 12), /* no sntf */ | ||
272 | - AHCI_HFLAG_NO_FPDMA_AA = (1 << 13), /* no FPDMA AA */ | ||
273 | - AHCI_HFLAG_YES_FBS = (1 << 14), /* force FBS cap on */ | ||
274 | - AHCI_HFLAG_DELAY_ENGINE = (1 << 15), /* do not start engine on | ||
275 | + AHCI_HFLAG_NO_SNTF = BIT(12), /* no sntf */ | ||
276 | + AHCI_HFLAG_NO_FPDMA_AA = BIT(13), /* no FPDMA AA */ | ||
277 | + AHCI_HFLAG_YES_FBS = BIT(14), /* force FBS cap on */ | ||
278 | + AHCI_HFLAG_DELAY_ENGINE = BIT(15), /* do not start engine on | ||
279 | port start (wait until | ||
280 | error-handling stage) */ | ||
281 | - AHCI_HFLAG_NO_DEVSLP = (1 << 17), /* no device sleep */ | ||
282 | - AHCI_HFLAG_NO_FBS = (1 << 18), /* no FBS */ | ||
283 | + AHCI_HFLAG_NO_DEVSLP = BIT(17), /* no device sleep */ | ||
284 | + AHCI_HFLAG_NO_FBS = BIT(18), /* no FBS */ | ||
285 | |||
286 | #ifdef CONFIG_PCI_MSI | ||
287 | - AHCI_HFLAG_MULTI_MSI = (1 << 20), /* per-port MSI(-X) */ | ||
288 | + AHCI_HFLAG_MULTI_MSI = BIT(20), /* per-port MSI(-X) */ | ||
289 | #else | ||
290 | /* compile out MSI infrastructure */ | ||
291 | AHCI_HFLAG_MULTI_MSI = 0, | ||
292 | #endif | ||
293 | - AHCI_HFLAG_WAKE_BEFORE_STOP = (1 << 22), /* wake before DMA stop */ | ||
294 | - AHCI_HFLAG_YES_ALPM = (1 << 23), /* force ALPM cap on */ | ||
295 | - AHCI_HFLAG_NO_WRITE_TO_RO = (1 << 24), /* don't write to read | ||
296 | + AHCI_HFLAG_WAKE_BEFORE_STOP = BIT(22), /* wake before DMA stop */ | ||
297 | + AHCI_HFLAG_YES_ALPM = BIT(23), /* force ALPM cap on */ | ||
298 | + AHCI_HFLAG_NO_WRITE_TO_RO = BIT(24), /* don't write to read | ||
299 | only registers */ | ||
300 | - AHCI_HFLAG_IS_MOBILE = (1 << 25), /* mobile chipset, use | ||
301 | + AHCI_HFLAG_IS_MOBILE = BIT(25), /* mobile chipset, use | ||
302 | SATA_MOBILE_LPM_POLICY | ||
303 | as default lpm_policy */ | ||
304 | - AHCI_HFLAG_SUSPEND_PHYS = (1 << 26), /* handle PHYs during | ||
305 | + AHCI_HFLAG_SUSPEND_PHYS = BIT(26), /* handle PHYs during | ||
306 | suspend/resume */ | ||
307 | - AHCI_HFLAG_IGN_NOTSUPP_POWER_ON = (1 << 27), /* ignore -EOPNOTSUPP | ||
308 | + AHCI_HFLAG_IGN_NOTSUPP_POWER_ON = BIT(27), /* ignore -EOPNOTSUPP | ||
309 | from phy_power_on() */ | ||
310 | - AHCI_HFLAG_NO_SXS = (1 << 28), /* SXS not supported */ | ||
311 | + AHCI_HFLAG_NO_SXS = BIT(28), /* SXS not supported */ | ||
312 | |||
313 | /* ap->flags bits */ | ||
314 | |||
315 | @@ -258,22 +259,22 @@ enum { | ||
316 | EM_MAX_RETRY = 5, | ||
317 | |||
318 | /* em_ctl bits */ | ||
319 | - EM_CTL_RST = (1 << 9), /* Reset */ | ||
320 | - EM_CTL_TM = (1 << 8), /* Transmit Message */ | ||
321 | - EM_CTL_MR = (1 << 0), /* Message Received */ | ||
322 | - EM_CTL_ALHD = (1 << 26), /* Activity LED */ | ||
323 | - EM_CTL_XMT = (1 << 25), /* Transmit Only */ | ||
324 | - EM_CTL_SMB = (1 << 24), /* Single Message Buffer */ | ||
325 | - EM_CTL_SGPIO = (1 << 19), /* SGPIO messages supported */ | ||
326 | - EM_CTL_SES = (1 << 18), /* SES-2 messages supported */ | ||
327 | - EM_CTL_SAFTE = (1 << 17), /* SAF-TE messages supported */ | ||
328 | - EM_CTL_LED = (1 << 16), /* LED messages supported */ | ||
329 | + EM_CTL_RST = BIT(9), /* Reset */ | ||
330 | + EM_CTL_TM = BIT(8), /* Transmit Message */ | ||
331 | + EM_CTL_MR = BIT(0), /* Message Received */ | ||
332 | + EM_CTL_ALHD = BIT(26), /* Activity LED */ | ||
333 | + EM_CTL_XMT = BIT(25), /* Transmit Only */ | ||
334 | + EM_CTL_SMB = BIT(24), /* Single Message Buffer */ | ||
335 | + EM_CTL_SGPIO = BIT(19), /* SGPIO messages supported */ | ||
336 | + EM_CTL_SES = BIT(18), /* SES-2 messages supported */ | ||
337 | + EM_CTL_SAFTE = BIT(17), /* SAF-TE messages supported */ | ||
338 | + EM_CTL_LED = BIT(16), /* LED messages supported */ | ||
339 | |||
340 | /* em message type */ | ||
341 | - EM_MSG_TYPE_LED = (1 << 0), /* LED */ | ||
342 | - EM_MSG_TYPE_SAFTE = (1 << 1), /* SAF-TE */ | ||
343 | - EM_MSG_TYPE_SES2 = (1 << 2), /* SES-2 */ | ||
344 | - EM_MSG_TYPE_SGPIO = (1 << 3), /* SGPIO */ | ||
345 | + EM_MSG_TYPE_LED = BIT(0), /* LED */ | ||
346 | + EM_MSG_TYPE_SAFTE = BIT(1), /* SAF-TE */ | ||
347 | + EM_MSG_TYPE_SES2 = BIT(2), /* SES-2 */ | ||
348 | + EM_MSG_TYPE_SGPIO = BIT(3), /* SGPIO */ | ||
349 | }; | ||
350 | |||
351 | struct ahci_cmd_hdr { | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/defconfig deleted file mode 100644 index d083d182..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_omap2_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/dra7xx/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/dra7xx/defconfig deleted file mode 100644 index dcb53bab..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/dra7xx/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_dra7x_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/k3/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/k3/defconfig deleted file mode 100644 index b9bc6137..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/k3/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_arm64_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/omapl138/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/omapl138/defconfig deleted file mode 100644 index b3467853..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/omapl138/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_omapl138_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti33x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti33x/defconfig deleted file mode 100644 index 88f80fa9..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti33x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am3x_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti43x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti43x/defconfig deleted file mode 100644 index 4b9daaf9..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-5.10/ti43x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am4x_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/defconfig deleted file mode 100644 index f0b8bab0..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_omap2_rt_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/dra7xx/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/dra7xx/defconfig deleted file mode 100644 index 47e3d04a..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/dra7xx/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_dra7x_rt_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/k3/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/k3/defconfig deleted file mode 100644 index cc10bfda..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/k3/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_arm64_rt_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti33x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti33x/defconfig deleted file mode 100644 index 0a4fbac2..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti33x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am3x_rt_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti43x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti43x/defconfig deleted file mode 100644 index 99594c81..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt-5.10/ti43x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am4x_rt_release | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_5.10.bb deleted file mode 100644 index 952af859..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-rt_5.10.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | require linux-ti-staging_5.10.bb | ||
2 | |||
3 | # Look in the generic major.minor directory for files | ||
4 | # This will have priority over generic non-rt path | ||
5 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.10:" | ||
6 | |||
7 | BRANCH = "ti-rt-linux-5.10.y" | ||
8 | |||
9 | SRCREV = "101d44260b8dfbab27763581e4bbd534dd36ae33" | ||
10 | PV = "5.10.168+git${SRCPV}" | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/defconfig deleted file mode 100644 index 5d051bd1..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_omap2_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/dra7xx/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/dra7xx/defconfig deleted file mode 100644 index 2b3635c3..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/dra7xx/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_dra7x_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/k3/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/k3/defconfig deleted file mode 100644 index 56cf9302..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/k3/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_arm64_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/omapl138/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/omapl138/defconfig deleted file mode 100644 index 95b61168..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/omapl138/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_omapl138_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti33x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti33x/defconfig deleted file mode 100644 index 9ab6733c..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti33x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am3x_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti43x/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti43x/defconfig deleted file mode 100644 index 825c31cd..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest-5.10/ti43x/defconfig +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | use-tisdk-config=ti_sdk_am4x_debug | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest_5.10.bb deleted file mode 100644 index e57d82eb..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging-systest_5.10.bb +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | require linux-ti-staging_5.10.bb | ||
2 | |||
3 | # Look in the generic major.minor directory for files | ||
4 | # This will have priority over generic non-rt path | ||
5 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.10:" | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb deleted file mode 100644 index 0cf0a319..00000000 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | SECTION = "kernel" | ||
2 | SUMMARY = "Linux kernel for TI devices" | ||
3 | LICENSE = "GPL-2.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | ||
5 | |||
6 | KERNEL_CLASSES += "${@bb.utils.contains('TFA_PLATFORM', 'k3', 'kernel-fitimage-ti-u-boot', '', d)}" | ||
7 | |||
8 | inherit kernel | ||
9 | |||
10 | DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" | ||
11 | require recipes-kernel/linux/setup-defconfig.inc | ||
12 | require recipes-kernel/linux/ti-kernel.inc | ||
13 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} | ||
14 | |||
15 | DEPENDS += "gmp-native libmpc-native" | ||
16 | |||
17 | # Look in the generic major.minor directory for files | ||
18 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.10:" | ||
19 | |||
20 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \ | ||
21 | ${EXTRA_DTC_ARGS}" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | BRANCH = "ti-linux-5.10.y" | ||
26 | |||
27 | SRCREV = "991c5ce91e43cb620f534dc9fe7b0ad21f4f4388" | ||
28 | PV = "5.10.168+git${SRCPV}" | ||
29 | |||
30 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild | ||
31 | MACHINE_KERNEL_PR:append = "b" | ||
32 | PR = "${MACHINE_KERNEL_PR}" | ||
33 | |||
34 | KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git" | ||
35 | KERNEL_GIT_PROTOCOL = "https" | ||
36 | SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ | ||
37 | file://0001-ata-ahci-fix-enum-constants-for-gcc-13.patch \ | ||
38 | file://defconfig" | ||
39 | |||
40 | FILES:${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb" | ||
41 | |||
42 | # Special configuration for remoteproc/rpmsg IPC modules | ||
43 | module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample" | ||
44 | module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus" | ||
45 | module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus" | ||
46 | KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc" | ||
47 | KERNEL_MODULE_AUTOLOAD:append:j721e = " rpmsg_kdrv_switch" | ||