summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-03-29 10:34:50 -0500
committerRyan Eatmon <reatmon@ti.com>2023-03-31 09:16:08 -0500
commit183e6abac6611fea0f52d7ac7303131536516a80 (patch)
tree3e7f9aa2e40d69aaac3ff604c978efe4fbb5e203 /meta-ti-bsp/recipes-kernel
parent11900123fa73f7866c272b4d5df499d2f367938e (diff)
downloadmeta-ti-183e6abac6611fea0f52d7ac7303131536516a80.tar.gz
kernel-fitimage: Add signing of fitImage entries for 5.10 kernel
While we are mirgrating to kernel v6.1 and u-boot v2023.04, we want to keep kernel v5.10 and u-boot v2021.01 "working" for anyone looking at kirkstone. One of the items we are looking at changing is the signing of entries in the fitImage. To try and acheive a limited parity with dunfell while we work on the migration, this commit creates a class that implements the logic that was in dunfell and applies that class to the 5.10 kernel. This is a temporary patch that will be remvoed when we remove the 5.10 recipe down the road. This logic will not apply to the 6.1 kernel. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index cc67188a..f3793baf 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -3,6 +3,8 @@ SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only" 3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5 5
6KERNEL_CLASSES += "${@bb.utils.contains('TFA_PLATFORM', 'k3', 'kernel-fitimage-ti-u-boot', '', d)}"
7
6inherit kernel 8inherit kernel
7 9
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 10DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"