summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-03-17 10:20:54 -0500
committerRyan Eatmon <reatmon@ti.com>2023-03-31 09:25:41 -0500
commit094be4d0f50ade1447590c2f09ac1dc9487a4384 (patch)
treec464053eb9c24cf1ae57144b29a6b9661d742391 /meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
parent4baa0cbd9b2dfa54dba4461926d8d3e6d033c405 (diff)
downloadmeta-ti-094be4d0f50ade1447590c2f09ac1dc9487a4384.tar.gz
linux-ti-staging: Add 6.1 kernel in prep for LTS migration
We are preparing to migrate our kernel version to 6.1. As we are still working on the migration, mark the default preference low for this version. We will enable building with this kernel in a meta-arago brand in the near future. Once the migration is complete, we will remove the 5.10 kernel and make this the default. Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb')
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
new file mode 100644
index 00000000..131dd1b3
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -0,0 +1,38 @@
1SECTION = "kernel"
2SUMMARY = "Linux kernel for TI devices"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
5
6inherit kernel
7
8DEFAULT_PREFERENCE = "-1"
9
10require recipes-kernel/linux/setup-defconfig.inc
11require recipes-kernel/linux/kernel-rdepends.inc
12require recipes-kernel/linux/ti-kernel.inc
13include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
14
15DEPENDS += "gmp-native libmpc-native"
16
17# Look in the generic major.minor directory for files
18FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-6.1:"
19
20KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
21 ${EXTRA_DTC_ARGS}"
22
23S = "${WORKDIR}/git"
24
25BRANCH = "ti-linux-6.1.y"
26
27SRCREV = "7b7231fbf048963b434d76a3cb866165365b14e0"
28PV = "6.1+git${SRCPV}"
29
30# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
31MACHINE_KERNEL_PR:append = "b"
32PR = "${MACHINE_KERNEL_PR}"
33
34KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git"
35KERNEL_GIT_PROTOCOL = "https"
36SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
37 file://defconfig"
38