diff options
author | Randolph Sapp <rs@ti.com> | 2023-10-16 21:29:49 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-10-17 21:58:11 -0500 |
commit | 213928ec15ff35d92a7bc9f7f36ae64a3f50dd5d (patch) | |
tree | 12725a9c0d07b13dc970d1a96c4b18b8f3dc34b8 /meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb | |
parent | fdc7c0a03bf80570fa8692dfad48eca533617206 (diff) | |
download | meta-ti-213928ec15ff35d92a7bc9f7f36ae64a3f50dd5d.tar.gz |
ti-sgx-ddk-*: version bump to support kirkstone
Bump ti-sgx-ddk-um and ti-sgx-ddk-km to the new branch for Kirkstone and
mesa independent builds. This also sets up SGX to use the latest mesa
revision rogue uses.
Changelog:
- IMG Support has officially ended. This repo will not be getting
regular updates after this unless things are really broken.
- The Mesa patches which were previously being relicensed internally
were opened and combined with the unofficial rogue efforts on
freedesktop.
- Toolchains were upgraded and multiple warnings and issues were
addressed. Hardware recoveries work now, but there are still some
longstanding issues with SGX that remain to be addressed if further
resources are set aside for that.
- We moved to an lws-generic build target to avoid rebuilding external
components. As such, these external components must be patched as
needed. Libdrm is an example of this and the required patches can be
found in meta-ti.
Known bugs:
- Buffer allocations under Weston may misbehave
- GLSL macro redefinitions will cause errors regardless of whether or
not they are identical
Signed-off-by: Randolph Sapp <rs@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb')
-rw-r--r-- | meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb | 53 |
1 files changed, 20 insertions, 33 deletions
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb index 755cc4f5..d2565318 100644 --- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb +++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb | |||
@@ -1,38 +1,35 @@ | |||
1 | DESCRIPTION = "Userspace libraries for PowerVR SGX chipset on TI SoCs" | 1 | DESCRIPTION = "Userspace libraries for PowerVR SGX chipset on TI SoCs" |
2 | HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-um-linux" | 2 | HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-um-linux" |
3 | LICENSE = "TI-TSPA" | 3 | LICENSE = "TI-TSPA" |
4 | LIC_FILES_CHKSUM = "file://TI-Linux-Graphics-DDK-UM-Manifest.doc;md5=b17390502bc89535c86cfbbae961a2a8" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f" |
5 | 5 | ||
6 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 6 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
7 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am65xx" | 7 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am65xx" |
8 | 8 | ||
9 | PR = "r38" | 9 | PR = "r38" |
10 | 10 | ||
11 | BRANCH = "ti-img-sgx/kirkstone-mesa/${PV}" | 11 | BRANCH = "${PV}/mesa/glibc-2.35" |
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \ | 14 | git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \ |
15 | file://pvrsrvkm.rules \ | ||
16 | " | 15 | " |
17 | SRCREV = "bbae7217051341f515515ec190e165119102f45a" | 16 | SRCREV = "70364424dd496833fad5b243c9e6cc8b077f04ac" |
18 | |||
19 | TARGET_PRODUCT:ti33x = "ti335x" | ||
20 | TARGET_PRODUCT:ti43x = "ti437x" | ||
21 | TARGET_PRODUCT:omap-a15 = "ti572x" | ||
22 | TARGET_PRODUCT:am65xx = "ti654x" | ||
23 | 17 | ||
24 | INITSCRIPT_NAME = "rc.pvr" | 18 | INITSCRIPT_NAME = "rc.pvr" |
25 | INITSCRIPT_PARAMS = "defaults 8" | 19 | INITSCRIPT_PARAMS = "defaults 8" |
26 | 20 | ||
27 | PACKAGECONFIG ??= "udev" | 21 | PACKAGECONFIG ??= "udev" |
28 | PACKAGECONFIG[udev] = ",,,udev" | 22 | PACKAGECONFIG[udev] = "UDEV=true,,,udev" |
23 | |||
24 | def use_sysvinit(d): | ||
25 | return d.getVar('VIRTUAL-RUNTIME_init_manager') == 'sysvinit' | ||
29 | 26 | ||
30 | def use_initscript(d): | 27 | inherit ${@oe.utils.ifelse(use_sysvinit(d), 'update-rc.d', '')} |
31 | sysvinit = bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d) | ||
32 | udev = bb.utils.contains('PACKAGECONFIG', 'udev', True, False, d) | ||
33 | return sysvinit and not udev | ||
34 | 28 | ||
35 | inherit ${@oe.utils.ifelse(use_initscript(d), 'update-rc.d', '')} | 29 | TARGET_PRODUCT:ti33x = "ti335x_linux" |
30 | TARGET_PRODUCT:ti43x = "ti437x_linux" | ||
31 | TARGET_PRODUCT:omap-a15 = "ti572x_linux" | ||
32 | TARGET_PRODUCT:am65xx = "ti654x_linux" | ||
36 | 33 | ||
37 | RDEPENDS:${PN} += "libdrm" | 34 | RDEPENDS:${PN} += "libdrm" |
38 | 35 | ||
@@ -40,24 +37,10 @@ RRECOMMENDS:${PN} += "ti-sgx-ddk-km" | |||
40 | 37 | ||
41 | S = "${WORKDIR}/git" | 38 | S = "${WORKDIR}/git" |
42 | 39 | ||
43 | do_install () { | 40 | EXTRA_OEMAKE += "DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} ${PACKAGECONFIG_CONFARGS}" |
44 | oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} | ||
45 | |||
46 | without_sysvinit=${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)} | ||
47 | with_udev=${@bb.utils.contains('PACKAGECONFIG', 'udev', 'true', 'false', d)} | ||
48 | 41 | ||
49 | # Delete initscript if it is not needed or would conflict with the udev rules | 42 | do_install() { |
50 | if ${@oe.utils.ifelse(use_initscript(d), 'false', 'true')}; then | 43 | oe_runmake install |
51 | rm -rf ${D}${sysconfdir}/init.d | ||
52 | rmdir --ignore-fail-on-non-empty ${D}${sysconfdir} | ||
53 | fi | ||
54 | |||
55 | if $with_udev; then | ||
56 | install -m644 -D ${WORKDIR}/pvrsrvkm.rules \ | ||
57 | ${D}${nonarch_base_libdir}/udev/rules.d/80-pvrsrvkm.rules | ||
58 | fi | ||
59 | |||
60 | chown -R root:root ${D} | ||
61 | } | 44 | } |
62 | 45 | ||
63 | FILES:${PN} = "${bindir}/*" | 46 | FILES:${PN} = "${bindir}/*" |
@@ -66,6 +49,10 @@ FILES:${PN} += "${includedir}/*" | |||
66 | FILES:${PN} += "${sysconfdir}/*" | 49 | FILES:${PN} += "${sysconfdir}/*" |
67 | FILES:${PN} += "${datadir}/*" | 50 | FILES:${PN} += "${datadir}/*" |
68 | FILES:${PN} += "${nonarch_base_libdir}/udev/rules.d" | 51 | FILES:${PN} += "${nonarch_base_libdir}/udev/rules.d" |
52 | FILES:${PN} += "${nonarch_base_libdir}/systemd/system" | ||
53 | |||
54 | # No debug or dev packages for this recipe | ||
55 | PACKAGES = "${PN}" | ||
69 | 56 | ||
70 | INSANE_SKIP:${PN} += "ldflags" | 57 | INSANE_SKIP:${PN} += "ldflags" |
71 | INSANE_SKIP:${PN} += "already-stripped" | 58 | INSANE_SKIP:${PN} += "already-stripped dev-so" |