summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb')
-rw-r--r--meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
new file mode 100644
index 00000000..0f2705b8
--- /dev/null
+++ b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Diagnostic tool for TI K3 processors"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d"
5
6PV = "0.2+git${SRCPV}"
7
8COMPATIBLE_MACHINE = "k3"
9
10BRANCH ?= "master"
11SRCREV = "79f007cd462384ce22e750e9002b714878f56892"
12
13SRC_URI = "git://git.ti.com/k3conf/k3conf.git;protocol=git;branch=${BRANCH}"
14
15S = "${WORKDIR}/git"
16
17do_compile () {
18 oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install ${S}/k3conf ${D}${bindir}
24}