diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-22 04:13:45 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-22 12:01:38 -0600 |
commit | 20f3191aeb592dd889eeaf96a31526297de95306 (patch) | |
tree | aec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-core/udev | |
parent | bea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff) | |
download | meta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz |
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-core/udev')
-rw-r--r-- | meta-ti-bsp/recipes-core/udev/eudev/firmware.rules | 3 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-core/udev/eudev/omap-tty.rules | 17 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-core/udev/eudev_%.bbappend | 13 |
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-core/udev/eudev/firmware.rules b/meta-ti-bsp/recipes-core/udev/eudev/firmware.rules new file mode 100644 index 00000000..f7a08ce9 --- /dev/null +++ b/meta-ti-bsp/recipes-core/udev/eudev/firmware.rules | |||
@@ -0,0 +1,3 @@ | |||
1 | # stub for immediately telling the kernel that userspace firmware loading | ||
2 | # failed; necessary to avoid long timeouts with CONFIG_FW_LOADER_USER_HELPER=y | ||
3 | SUBSYSTEM=="firmware", ACTION=="add", ATTR{loading}="-1" | ||
diff --git a/meta-ti-bsp/recipes-core/udev/eudev/omap-tty.rules b/meta-ti-bsp/recipes-core/udev/eudev/omap-tty.rules new file mode 100644 index 00000000..989d60f8 --- /dev/null +++ b/meta-ti-bsp/recipes-core/udev/eudev/omap-tty.rules | |||
@@ -0,0 +1,17 @@ | |||
1 | # There are a number of modifiers that are allowed to be used in some | ||
2 | # of the different fields. They provide the following subsitutions: | ||
3 | # | ||
4 | # %n the "kernel number" of the device. | ||
5 | # For example, 'sda3' has a "kernel number" of '3' | ||
6 | # %e the smallest number for that name which does not matches an existing node | ||
7 | # %k the kernel name for the device | ||
8 | # %M the kernel major number for the device | ||
9 | # %m the kernel minor number for the device | ||
10 | # %b the bus id for the device | ||
11 | # %c the string returned by the PROGRAM | ||
12 | # %s{filename} the content of a sysfs attribute | ||
13 | # %% the '%' char itself | ||
14 | # | ||
15 | |||
16 | # Backward compatibility with old OMAP UART-style ttyO0 naming | ||
17 | SUBSYSTEM=="tty", ATTR{uartclk}!="0", KERNEL=="ttyS[0-9]", SYMLINK+="ttyO%n" | ||
diff --git a/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend b/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend new file mode 100644 index 00000000..ddb1e75d --- /dev/null +++ b/meta-ti-bsp/recipes-core/udev/eudev_%.bbappend | |||
@@ -0,0 +1,13 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI:append:ti-soc = " \ | ||
4 | file://omap-tty.rules \ | ||
5 | file://firmware.rules \ | ||
6 | " | ||
7 | |||
8 | PR:append:ti-soc = ".3" | ||
9 | |||
10 | do_install:append:ti-soc() { | ||
11 | install -m 0644 ${WORKDIR}/omap-tty.rules ${D}${sysconfdir}/udev/rules.d/ | ||
12 | install -m 0644 ${WORKDIR}/firmware.rules ${D}${sysconfdir}/udev/rules.d/ | ||
13 | } | ||