diff options
author | Aniket Limaye <a-limaye@ti.com> | 2023-10-12 22:59:46 +0530 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-10-17 21:58:11 -0500 |
commit | e5ea7f74e0470575dce7c3eea73e9d39509a0a7a (patch) | |
tree | 0166ca734accd4c9049284679fd196662ef506e5 /meta-ti-bsp/recipes-bsp | |
parent | 99bf17e270d7dc71d57cb29e72d4122f63669946 (diff) | |
download | meta-ti-e5ea7f74e0470575dce7c3eea73e9d39509a0a7a.tar.gz |
ti-sci-fw: Remove COMPATIBLE_MACHINE and extend recipe to k3 machines
Revert ebcf15bf0f31208e87ce60a4696e585940b46777 :
"recipes-bsp:ti-sci-fw: Add k3r5 as COMPATIBLE_MACHINE"
Extend recipe to k3 machines too, to provide ti-fs-stub-* firmware
for u-boot aarch64 build.
Update do_deploy() to allow multiconfig builds for k3 machines
Signed-off-by: Aniket Limaye <a-limaye@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 6 |
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 801c8768..2ad93a5d 100644 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -4,7 +4,6 @@ inherit deploy | |||
4 | 4 | ||
5 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | 5 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
6 | 6 | ||
7 | COMPATIBLE_MACHINE = "k3r5" | ||
8 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 7 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
9 | 8 | ||
10 | CFLAGS[unexport] = "1" | 9 | CFLAGS[unexport] = "1" |
@@ -26,7 +25,10 @@ do_install() { | |||
26 | 25 | ||
27 | FILES:${PN} = "${nonarch_base_libdir}/firmware" | 26 | FILES:${PN} = "${nonarch_base_libdir}/firmware" |
28 | 27 | ||
29 | do_deploy() { | 28 | do_deploy(){ |
29 | } | ||
30 | |||
31 | do_deploy:k3r5() { | ||
30 | install -d ${DEPLOYDIR}/ti-sysfw | 32 | install -d ${DEPLOYDIR}/ti-sysfw |
31 | install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw | 33 | install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw |
32 | install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw | 34 | install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw |