summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-03-29 10:32:05 -0500
committerRyan Eatmon <reatmon@ti.com>2023-03-30 16:18:36 -0500
commit44708d277f85178b821df6c356d4b1d8d5845fd6 (patch)
treef4db3c76fb4cf909b375dcc1484877704443e816 /meta-ti-bsp/recipes-bsp
parentd484ef5b8196206cc60e5c099da659dca9022dd4 (diff)
downloadmeta-ti-44708d277f85178b821df6c356d4b1d8d5845fd6.tar.gz
trusted-firmware-a: Only sign files for platforms that support it
We are seeing some testing issues where the new code that signs all of the files at all times is causing issues. So rollback the logic and only sign for platforms that support it. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend40
1 files changed, 38 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 9b8dd142..c65ecd9c 100644
--- a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -12,12 +12,48 @@ inherit ti-secdev
12EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" 12EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}"
13EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}" 13EXTRA_OEMAKE:append:k3 = "${@ ' K3_PM_SYSTEM_SUSPEND=' + d.getVar('TFA_K3_SYSTEM_SUSPEND') if d.getVar('TFA_K3_SYSTEM_SUSPEND') else ''}"
14 14
15# Signing procedure for K3 devices 15# Signing procedure for K3 HS devices
16do_compile:append:k3() { 16tfa_sign_k3hs() {
17 mv ${BUILD_DIR}/bl31.bin ${BUILD_DIR}/bl31.bin.unsigned 17 mv ${BUILD_DIR}/bl31.bin ${BUILD_DIR}/bl31.bin.unsigned
18 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${BUILD_DIR}/bl31.bin.unsigned ${BUILD_DIR}/bl31.bin 18 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${BUILD_DIR}/bl31.bin.unsigned ${BUILD_DIR}/bl31.bin
19} 19}
20 20
21do_compile:append:am65xx-hs-evm() {
22 tfa_sign_k3hs
23}
24
25do_compile:append:am64xx-evm() {
26 tfa_sign_k3hs
27}
28
29do_compile:append:am62xx-evm() {
30 tfa_sign_k3hs
31}
32
33do_compile:append:am62xx-lp-evm() {
34 tfa_sign_k3hs
35}
36
37do_compile:append:am62axx-evm() {
38 tfa_sign_k3hs
39}
40
41do_compile:append:j721e-hs-evm() {
42 tfa_sign_k3hs
43}
44
45do_compile:append:j7200-hs-evm() {
46 tfa_sign_k3hs
47}
48
49do_compile:append:j721s2-hs-evm() {
50 tfa_sign_k3hs
51}
52
53do_compile:append:j784s4-hs-evm() {
54 tfa_sign_k3hs
55}
56
21do_install:append:k3() { 57do_install:append:k3() {
22 if [ -f ${BUILD_DIR}/bl31.bin.unsigned ]; then 58 if [ -f ${BUILD_DIR}/bl31.bin.unsigned ]; then
23 echo "Install bl31.bin.unsigned" 59 echo "Install bl31.bin.unsigned"