diff options
author | Andrew Davis <afd@ti.com> | 2023-05-25 13:11:26 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-06-06 08:24:37 -0500 |
commit | 080ed73c11ee5415973c401b03f0e07bf54090fe (patch) | |
tree | 0f0ac6f7977830caf0fe46489bbd615f0756b816 /meta-ti-bsp/recipes-bsp | |
parent | a73e0f2e5f9e804b198f8544c48a24cef52d677c (diff) | |
download | meta-ti-080ed73c11ee5415973c401b03f0e07bf54090fe.tar.gz |
ti-sci-fw: Remove source package recipe
K3-image-gen is going away and we don't do SRCIPK packages like this
anymore anyway. Remove this recipe.
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb | 45 |
1 files changed, 0 insertions, 45 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb deleted file mode 100644 index bab4acf0..00000000 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | # ti-sci-fw builds and packages multiple config variants via multiconfig | ||
2 | # Let's take a page from gcc-source as a common recipe for all gcc stages, | ||
3 | # but also to provide a single package for MAINMACHINE of all multiconfigs | ||
4 | |||
5 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
6 | |||
7 | SUMMARY += "- sources" | ||
8 | |||
9 | COMPATIBLE_MACHINE = "k3" | ||
10 | |||
11 | EXCLUDE_FROM_WORLD = "1" | ||
12 | INHIBIT_DEFAULT_DEPS = "1" | ||
13 | DEPENDS = "" | ||
14 | |||
15 | PACKAGES = "${PN}" | ||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | do_configure[noexec] = "1" | ||
19 | do_compile[noexec] = "1" | ||
20 | |||
21 | SRCIPK_SRC_DIR = "${WORKDIR}/imggen" | ||
22 | SRCIPK_INSTALL_DIR = "board-support/k3-image-gen-${PV}" | ||
23 | FILES:${PN} = "${SRCIPK_INSTALL_DIR}" | ||
24 | |||
25 | do_install() { | ||
26 | # Copy sources for packaging | ||
27 | mkdir -p ${D}/${SRCIPK_INSTALL_DIR} | ||
28 | if [ -e ${SRCIPK_SRC_DIR} ]; then | ||
29 | if [ "${SRCIPK_SRC_DIR}" = "${WORKDIR}" ]; then | ||
30 | excludes='--exclude ./temp --exclude ${D}' | ||
31 | fi | ||
32 | tar -C ${SRCIPK_SRC_DIR} -cO $excludes . | tar -C ${D}/${SRCIPK_INSTALL_DIR} -xpf - | ||
33 | fi | ||
34 | |||
35 | # Fix up patches/ directory to contain actual patches instead of symlinks | ||
36 | if [ -e ${D}/${SRCIPK_INSTALL_DIR}/patches ] | ||
37 | then | ||
38 | mv ${D}/${SRCIPK_INSTALL_DIR}/patches ${D}/${SRCIPK_INSTALL_DIR}/patches-links | ||
39 | cp -rL ${D}/${SRCIPK_INSTALL_DIR}/patches-links ${D}/${SRCIPK_INSTALL_DIR}/patches | ||
40 | rm -rf ${D}/${SRCIPK_INSTALL_DIR}/patches-links | ||
41 | fi | ||
42 | } | ||
43 | |||
44 | # Do not perform any QA checks on source package | ||
45 | INSANE_SKIP:${PN} += "${ALL_QA}" | ||