diff options
author | Ryan Eatmon <reatmon@ti.com> | 2022-05-04 10:21:58 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-05-04 10:21:58 -0500 |
commit | 88e8c1cbf370940fae6dac4a8b732366f75173dc (patch) | |
tree | 1e2fbf69f3484e4d64d0f4c8302652ec0ea18272 /meta-ti-bsp/recipes-bsp | |
parent | 0b48ef9815be8f4774e868f2ea06db5c4846a728 (diff) | |
download | meta-ti-88e8c1cbf370940fae6dac4a8b732366f75173dc.tar.gz |
uio-module-drv: Remove unneeded patch.
Now that we have moved to a newer version, this patch is no longer
needed.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
2 files changed, 0 insertions, 37 deletions
diff --git a/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch b/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch deleted file mode 100644 index 955ef558..00000000 --- a/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From b5c4036dac06817bffd0be21c5fa1b7f75f74e4b Mon Sep 17 00:00:00 2001 | ||
2 | From: Suman Anna <s-anna@ti.com> | ||
3 | Date: Mon, 19 Apr 2021 13:15:51 -0500 | ||
4 | Subject: [PATCH] uio-module-drv: Replace ioremap_nocache with ioremap | ||
5 | |||
6 | The ioremap_nocache is the same as the regular ioremap and its | ||
7 | definition has been dropped from the Linux kernel v5.6 onwards in | ||
8 | commit 4bdc0d676a64 ("remove ioremap_nocache and devm_ioremap_nocache") | ||
9 | [1]. The uio-module-drv module fails to build against these newer | ||
10 | kernels, so fix it by simply replacing ioremap_nocache with ioremap. | ||
11 | |||
12 | [1] | ||
13 | https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=4bdc0d676a643140bdf17dbf7eafedee3d496a3c | ||
14 | |||
15 | Signed-off-by: Suman Anna <s-anna@ti.com> | ||
16 | --- | ||
17 | uio_module_drv.c | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/uio_module_drv.c b/uio_module_drv.c | ||
21 | index 5a67dd199e21..7cc6005d1f05 100644 | ||
22 | --- a/uio_module_drv.c | ||
23 | +++ b/uio_module_drv.c | ||
24 | @@ -240,7 +240,7 @@ static ssize_t uio_module_drv_transfer(struct file *file, char __user *buf, | ||
25 | return -EINVAL; | ||
26 | } | ||
27 | |||
28 | - virt_addr_p = ioremap_nocache(phys_addr, count); | ||
29 | + virt_addr_p = ioremap(phys_addr, count); | ||
30 | if (!virt_addr_p) { | ||
31 | dev_err(uio_module_drv->dev, "Mapping of virtual memory failed\n"); | ||
32 | return(-ENOMEM); | ||
33 | -- | ||
34 | 2.30.1 | ||
35 | |||
diff --git a/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv_git.bb index 2bb1f0b3..df5faa9a 100644 --- a/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv_git.bb +++ b/meta-ti-bsp/recipes-bsp/uio-module-drv/uio-module-drv_git.bb | |||
@@ -4,8 +4,6 @@ include uio-module-drv.inc | |||
4 | 4 | ||
5 | FILESEXTRAPATHS:prepend:= "${THISDIR}/${PN}:" | 5 | FILESEXTRAPATHS:prepend:= "${THISDIR}/${PN}:" |
6 | 6 | ||
7 | SRC_URI += "file://0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch" | ||
8 | |||
9 | # This package builds a kernel module, use kernel PR as base and append a local | 7 | # This package builds a kernel module, use kernel PR as base and append a local |
10 | MACHINE_KERNEL_PR:append = "d" | 8 | MACHINE_KERNEL_PR:append = "d" |
11 | PR = "${MACHINE_KERNEL_PR}" | 9 | PR = "${MACHINE_KERNEL_PR}" |