diff options
author | Paresh Bhagat <p-bhagat@ti.com> | 2023-06-14 12:37:54 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-06-14 12:49:59 -0500 |
commit | 82695339888e0678d9e98b57b134f768983d073a (patch) | |
tree | bd8dc54e78382600488148b65c12f84ecc6d161e /meta-ti-bsp/recipes-bsp/u-boot | |
parent | 4c5461c23708d9f235976f25acd95cd30114af7e (diff) | |
download | meta-ti-82695339888e0678d9e98b57b134f768983d073a.tar.gz |
ti-extras: Add support for extra kernel/u-boot features
There are some features that will either never be accepted into the
upstream kernel, or are not ready to be accepted. ti-extras allows for
controlling the kernel and u-boot repos, breanches, and srcrevs to gain
access to those features via the TI_EXTRAS variable in the local.conf
file.
Initial support for TI_EXTRAS=tie-jailhouse is being added by this
patch.
Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Acked-by: Paresh Bhagat <p-bhagat@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/u-boot')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc | 12 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | 2 |
3 files changed, 15 insertions, 1 deletions
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc new file mode 100644 index 00000000..3a016c6c --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | |||
2 | # This will have priority over generic uboot path | ||
3 | |||
4 | COMPATIBLE_MACHINE = "am62xx" | ||
5 | |||
6 | BRANCH = "ti-u-boot-2023.04" | ||
7 | BRANCH:tie-jailhouse = "ti-u-boot-2023.04-jailhouse" | ||
8 | |||
9 | SRCREV = "010afc1fe7a1412f92363c8af69c848d76a53e42" | ||
10 | SRCREV:tie-jailhouse = "79615e1c99b9aa73948f811f5f866cff2e34dc37" | ||
11 | |||
12 | UBOOT_GIT_URI = "git://git.ti.com/git/processor-sdk/u-boot.git" | ||
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb index f4c5e88c..4bde0256 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require u-boot-ti.inc | 1 | require u-boot-ti.inc |
2 | 2 | ||
3 | include ${@ 'recipes-bsp/u-boot/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''} | ||
4 | |||
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" | 5 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" |
4 | 6 | ||
5 | PR = "r0" | 7 | PR = "r0" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index 9a2c3181..d9a3a520 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -16,7 +16,7 @@ LICENSE = "GPL-2.0-or-later" | |||
16 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" | 16 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" |
17 | 17 | ||
18 | BRANCH ?= "master" | 18 | BRANCH ?= "master" |
19 | UBOOT_GIT_URI = "git://git.ti.com/git/ti-u-boot/ti-u-boot.git" | 19 | UBOOT_GIT_URI ?= "git://git.ti.com/git/ti-u-boot/ti-u-boot.git" |
20 | UBOOT_GIT_PROTOCOL = "https" | 20 | UBOOT_GIT_PROTOCOL = "https" |
21 | SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}" | 21 | SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}" |
22 | 22 | ||