summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorDevarsh Thakkar <devarsht@ti.com>2023-06-14 20:03:05 +0530
committerRyan Eatmon <reatmon@ti.com>2023-06-19 13:40:25 -0500
commit1fed958bfe8a8825996134f62097ac02206f43b2 (patch)
tree9767b00ea6cc56554217088acd0d358c2c5fff46 /meta-ti-bsp/recipes-bsp/u-boot
parentf2c401efc32ea868362309e0f1c1243d75ce1b7e (diff)
downloadmeta-ti-1fed958bfe8a8825996134f62097ac02206f43b2.tar.gz
u-boot-ti-staging_2023.04: Copy bitmap file to boot partition for AM62x
Early splash screen support for AM62x has been enabled in u-boot and it requires bitmap tarball to be present in boot partition as per the default environment settings done in u-boot [1]. Copy the ti logo bitmap tarball to boot partition of wic image in order to enable out of box early display on AM62x. [1] https://git.ti.com/cgit/ti-u-boot/ti-u-boot/tree/board/ti/am62x/am62x.env Signed-off-by: Devarsh Thakkar <devarsht@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/u-boot')
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
index f1c469ac..5698de1d 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
@@ -10,3 +10,12 @@ BRANCH = "ti-u-boot-2023.04"
10 10
11SRCREV = "a3595f1e3ed4905e1894d47cc91f0887a5cbfee0" 11SRCREV = "a3595f1e3ed4905e1894d47cc91f0887a5cbfee0"
12 12
13do_install:append:am62xx() {
14 install -d ${D}/boot
15 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot
16}
17
18do_deploy:append:am62xx() {
19 install -d ${DEPLOYDIR}
20 install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR}
21}