diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-22 04:13:45 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-22 12:01:38 -0600 |
commit | 20f3191aeb592dd889eeaf96a31526297de95306 (patch) | |
tree | aec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/trusted-firmware-a | |
parent | bea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff) | |
download | meta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz |
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/trusted-firmware-a')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend new file mode 100644 index 00000000..8fe7c08e --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | |||
@@ -0,0 +1,41 @@ | |||
1 | PV:k3 = "2.5" | ||
2 | LIC_FILES_CHKSUM:k3 = "file://license.rst;md5=1dd070c98a281d18d9eefd938729b031" | ||
3 | BRANCH:k3 = "ti-atf" | ||
4 | SRC_URI:k3 = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH};name=tfa" | ||
5 | SRCREV_tfa:k3 = "0693f356eb2a25adf8758d98058120bed082cc73" | ||
6 | COMPATIBLE_MACHINE:k3 = "k3" | ||
7 | TFA_BUILD_TARGET:k3 = "all" | ||
8 | TFA_INSTALL_TARGET:k3 = "bl31" | ||
9 | TFA_SPD:k3 = "opteed" | ||
10 | |||
11 | do_compile:append:am65xx-hs-evm() { | ||
12 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
13 | ( cd ${BUILD_DIR}; \ | ||
14 | mv bl31.bin bl31.bin.unsigned; \ | ||
15 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
16 | ) | ||
17 | } | ||
18 | |||
19 | do_compile:append:am64xx-hs-evm() { | ||
20 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
21 | ( cd ${BUILD_DIR}; \ | ||
22 | mv bl31.bin bl31.bin.unsigned; \ | ||
23 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
24 | ) | ||
25 | } | ||
26 | |||
27 | do_compile:append:j7-hs-evm() { | ||
28 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
29 | ( cd ${BUILD_DIR}; \ | ||
30 | mv bl31.bin bl31.bin.unsigned; \ | ||
31 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
32 | ) | ||
33 | } | ||
34 | |||
35 | do_compile:append:j7200-hs-evm() { | ||
36 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | ||
37 | ( cd ${BUILD_DIR}; \ | ||
38 | mv bl31.bin bl31.bin.unsigned; \ | ||
39 | ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \ | ||
40 | ) | ||
41 | } | ||