summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/tifs-lpm-stub
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-06-15 15:18:49 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-15 15:31:23 -0500
commitc23cd182375ff248046e153c5c0a95418e4a8bae (patch)
tree68285f60ab1fdaf95094f721fc78c6171fafff49 /meta-ti-bsp/recipes-bsp/tifs-lpm-stub
parent3e3b625c8100ebaedd749acf9cb48d18f04b9c6a (diff)
downloadmeta-ti-c23cd182375ff248046e153c5c0a95418e4a8bae.tar.gz
ti-sci-fw: Include the TIFS LPM stub with the rest of SYSFW
This firmware is shipped with the rest of ti-sysfw blobs, it shares the same versions too and so should be simply bundled with the same. This stub is also built into U-Boot and not loaded during kernel runtime anymore, so remove the RDEPENDS in kernel. Signed-off-by: Andrew Davis <afd@ti.com> Reviewed-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/tifs-lpm-stub')
-rw-r--r--meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
deleted file mode 100644
index 2db761ba..00000000
--- a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "TI Foundational security Low Power Management Stub"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${TIFS_LPM_STUB_FW_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am62xx|am62axx"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = "ti-fs-stub-firmware-am62x-gp-signed.bin"
17
18do_install() {
19 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw/
20 install -m 0644 ${S}/ti-sysfw/${TARGET} ${D}${nonarch_base_libdir}/firmware/ti-sysfw/${TARGET}
21}
22
23FILES:${PN} = "${nonarch_base_libdir}/firmware"